cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

Update:

Found this link...Radeon™ RX 590 Previous Drivers | AMD

All of my issues began with 20.11.2.  All previous versions worked. 

I downloaded 20.10.1, release date 10.16.20 and installed.

Everything back to normal.  The AMD Radeon Software app works again.  Blender rendering works perfectly.  No issues with any software.  I clearly don't need 20.11.2.  Will wait for the next driver release.  Perhaps this issue will be resolved. 

Certainly one's hardware also plays a role.  My hardware specs:

Lian Li PC-011DX 011 Mid Tower Case

Corsair TXM TX750M 750 Watt Power Supply

AMD Ryzen 7 2700X CPU

Gigabyte X570 PCIe 4.0 SATA 6GB/s USB 3.1 AMD X570 ATX Motherboard

64 gig memory total:

Corsair Vengeance RGB Pro 32GB (2 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600)

Corsair LPX 32 GB 3200 MHz C16 DDR4 Dram

 

MSI Radeon RX 590 8GB GDRR5 Memory Graphics Card

Samsung 970 EVO 500 GB PCIe M.2 2280 SSD

WD 1TB 7200 rpm Sata 6 gb/s, 64 mb cache Hard Drive

Uphere 3-pack 120 mm fans

Gigabyte GC-WB867D-I REV Bluetooth 4.2/Wireless AC/B/G/N Band Dual Freq 2.4Ghz/5.8Ghz Expansion Card

 

 

 

 

heyider
Adept I

Re: after update to 20.11.3 Blender does not render objects

Here the same problem, even installing the previous driver did not solve (DDU), I don't know what to do, I need to solve this to do my job.

Amd Radeon Rx 580.
Windows 10 Pro (20H2) 19042,662
Blender all versions.
The problem started with the 20.11.3 driver.

EDIT: I was able to solve by installing the 20.11.1 driver(Subsequent versions are not working here.)

0 Kudos
cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

Just received an email that Version 20.12.1 has been released.  I read the release notes.  Did not see any mention about the rendering issues in Blender.  Has anyone with these rendering issues tried this new version?

Version 20.10.1 continues to work fine for me.  However, this evening or tomorrow I will try 20.12.1.  If it works...great.  If not I will revert back to 20.10.1.

 

 

0 Kudos
cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

Installed 20.12.1.  Does not work in Blender.   Back to 20.10.1.  

Perhaps AMD is still working on the problem.  I will give them the benefit of the doubt.  For now.

I sent a support request on 12/2.  No reply so far.

klodzonov
Adept I

Re: after update to 20.11.3 Blender does not render objects

Нет,кажись с версии драйвера.Поставил 20.9.2 - заработало!

0 Kudos
arcdipesh
Journeyman III

Re: after update to 20.11.3 Blender does not render objects

same problem man.only cycles work evee dont work

 

cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

I am currently working with AMD tech support.  The problem has been elevated up to the next level.  For now Tech Support told me to continue using the last driver version that worked.

sekurko
Journeyman III

Re: after update to 20.11.3 Blender does not render objects

RX 570 (4GB) ARMOR

I have the same problem.

After 20.11.3 Blender can't render any objects. They are "invisible".  Even 20.12.1 update didn't fix anything.

I work as a 3D artist and because of this my work suffers!
Cycles renderCycles render



0 Kudos
cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

Revert to version 20.10.1.  Should render fine.  Wait for a fix from AMD.  They are aware of the issue.

0 Kudos
Odog
Journeyman III

Re: after update to 20.11.3 Blender does not render objects

Hey everyone , 

 

Any idea when or if AMD radeon is going to fix this?

Im just starting with blender but i almost gave up because nothing was working like the tutorials explained. And i didn't understand why my computer didnt work correctly in blender.

Thankfully i found other people with the same problem all of them using AMD I tryed downgrading my gpu to 20.10.1 but windows stopped the installiation halfway through several times due to errors and i'd rather use my computer on a updated gpu.

Learning is basically useless now for me because i cant follow 99% of the tutorials. And i hope this issue gets resolved soon for the entire amd blender community.  I see that a lot of people rely on it to feed themselves and maybe even their children. Please fix it asap. 

0 Kudos