cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

cgcartist
Adept II

after update to 20.11.3 Blender does not render objects

Updated an MSI  MSI Radeon RX 590 8GB GDRR5 Memory Graphics Card with Version 20.11.3 about noon today.  After the update I resumed work in Blender 2.91.  No files would render.  All objects render as black outlines.  No setting were changed in Blender.  The 3 Blender files I worked on this morning tat rendered perfectly this morning would no longer render.  Nothin in my system changed other than the update to 20.11.3.

Unless a solution exists I would like to revert to the previous version assuming that is possible.  Have not determined how to revert.

46 Replies
Denchik85
Journeyman III

Re: after update to 20.11.3 Blender does not render objects

RX 570 4GB. I went back to the previous version (20.11.2), but everything is the same...EEVEE rendering doesn't work...there are always some problems with AMD drivers!!!

0 Kudos
colesdav
MVP

Re: after update to 20.11.3 Blender does not render objects

I will take a look on a Gigabyte RX590 Rev 2.0 (Bait and Switch edition) later today and let you know what I see. 

I just tried rendering in Blender on a Radeon Pro DUO (Fiji) GPU with Adrenalin 2020 20.11.3 Drivers. 
I am using GPU based Rendering FYI. It is much faster than CPU based.
If you have 7 GPU on your system it scales almost ~ 7x faster. 

The Primary GPU will render a basic cube in Blender O.K.  If I select the secondary GPU it simply hangs Blender.
The Secondary GPU on that card runs all the same CompuBench 2.0 tests that the Primary GPU runs. 
Apart from one. 
The AMD Driver reports a "Timeout" on the final Optical Flow test.  
I would report that BUG to AMD but there is no accepable way to do it any more. 

You might try running CompuBench 2.0 OpenCL tests on your RX590 card as another OpenCL test.
I have RX590 benchmark info I could crossreference with your card. 

0 Kudos
Denchik85
Journeyman III

Re: after update to 20.11.3 Blender does not render objects

Я полностью удалил программное обеспечение Radeon adrenalin, и без него eevee начал работать.Так же провел тесты в CompuBench 2.0 и все работает нормально. Так что проблема не в драйверах, а в программном обеспечении amd Radeon adrenalin...у них просто кривые руки и растут из задницы(((

I completely removed the Radeon adrenalin software, and without it, eevee started working.I also ran tests in CompuBench 2.0 and everything works fine. So the problem is not with the drivers, but with the amd Radeon adrenalin software...they just have crooked arms and grow out of their ass(((

colesdav
MVP

Re: after update to 20.11.3 Blender does not render objects

I just tested a Gigabyte RX590 8GB on Blender 2.9.1. 
I downloaded and installed the Windows Zip Version and extracted it under my C: drive.
Downloaded from here: https://www.blender.org/download/Blender2.91/blender-2.91.0-windows64.zip/

GPU based rendering is working on the RX590 for basic Cube. 
Eevee is also running. 
Note the RX590 is being used as a Blender Accelerator via a PCIe2.0x1 -> USB3 Mining Adapter. 
Primary display output is from an RX5700XT. 
The RX590 also manages to run Compubench 2.0 tests.

0 Kudos
cgcartist
Adept II

Re: after update to 20.11.3 Blender does not render objects

Thanks for all the replies.

I can render again in Blender.  I did the following.

1. I have a Win 10 system. Opened Device Manager. Display Adapter Shows Radeon RX 590 Series. 

2. Uninstalled Device and rebooted.

3. Back to Device Manager and Display Adapter. Update Driver Button. Download began.

4. Rebooted.

5. Device Manager Display Adapter now shows a Driver Date of 8/27/19 (The date I first installed this card) Driver Version 26.20.13002.133

6. Opened Blender.  Every Object now renders perfectly again.

The Radeon Software does NOT work.  Error message with my Driver Version (Too old apparently) 

My problems began with 20.11.3. ALL versions prior to 20.11.3 worked fine in Blender 2.83 and 2.9.1

I am not a gamer.  For now I can get by just fine with the 8/27/2019 driver version.  Once I complete the current Blender projects I will try the latest Driver Version again.  I did send a support message to AMD support.  Will see if and when they respond.  I also completed a bug report.  Hopefully AMD can address this issue.  I will post any new responses from AMD.  I suggest that anyone experiencing issues contact Support and file a bug report.  

Thanks to everyone posting on this thread.  Hopefully AMD will address this issue in the next release.

Michael

 

colesdav
MVP

Re: after update to 20.11.3 Blender does not render objects

Glad you got it running. 
I am just about to test running the RX590 as primary display output for you using Adrenalin 2020 12.11.3 drivers. 

You may want to try a full DDU uninstall and reinstall of your current driver? 
I will post a link on how to do it next, just in case. 

0 Kudos
colesdav
MVP

Re: after update to 20.11.3 Blender does not render objects

RX590 render of basic cube using Eevee, with the RX590 as the display out (HDMI)  is broken. 
It renders the cube in a checkerboard pattern. 

All other cpu and GPU based rendering runs o.k. 
There does indeed seem to be a problem with RX500 series, Blender and Adrenalin 2020 20.11.3 driver, on Eevee.
Thanks. 

deepforest
Adept III

Re: after update to 20.11.3 Blender does not render objects

Same here on rx580 Sapphire at 20.11.3 driver at my previous 20.8.3 all look good

In Viewport shading>Solid all objects are transparent can see only yellow contour

In  Viewport shading>Look Dev all objects are totally black

Tags (3)
deepforest
Adept III

Re: after update to 20.11.3 Blender does not render objects

Тоже самое на 20,11,3 в Блендере 2,80

То есть проблема только в оболочке радеон драйвера? Если использовать один драйвер 20,11,3 то все корректно отображается в блендере?

0 Kudos