Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

after update to 20.11.3 Blender does not render objects

Updated an MSI  MSI Radeon RX 590 8GB GDRR5 Memory Graphics Card with Version 20.11.3 about noon today.  After the update I resumed work in Blender 2.91.  No files would render.  All objects render as black outlines.  No setting were changed in Blender.  The 3 Blender files I worked on this morning tat rendered perfectly this morning would no longer render.  Nothin in my system changed other than the update to 20.11.3.

Unless a solution exists I would like to revert to the previous version assuming that is possible.  Have not determined how to revert.

48 Replies
Journeyman III

RX 570 4GB. I went back to the previous version (20.11.2), but everything is the same...EEVEE rendering doesn't work...there are always some problems with AMD drivers!!!


I will take a look on a Gigabyte RX590 Rev 2.0 (Bait and Switch edition) later today and let you know what I see. 

I just tried rendering in Blender on a Radeon Pro DUO (Fiji) GPU with Adrenalin 2020 20.11.3 Drivers. 
I am using GPU based Rendering FYI. It is much faster than CPU based.
If you have 7 GPU on your system it scales almost ~ 7x faster. 

The Primary GPU will render a basic cube in Blender O.K.  If I select the secondary GPU it simply hangs Blender.
The Secondary GPU on that card runs all the same CompuBench 2.0 tests that the Primary GPU runs. 
Apart from one. 
The AMD Driver reports a "Timeout" on the final Optical Flow test.  
I would report that BUG to AMD but there is no accepable way to do it any more. 

You might try running CompuBench 2.0 OpenCL tests on your RX590 card as another OpenCL test.
I have RX590 benchmark info I could crossreference with your card. 


same problem man.only cycles work evee dont work


I am currently working with AMD tech support.  The problem has been elevated up to the next level.  For now Tech Support told me to continue using the last driver version that worked.

RX 570 (4GB) ARMOR

I have the same problem.

After 20.11.3 Blender can't render any objects. They are "invisible".  Even 20.12.1 update didn't fix anything.

I work as a 3D artist and because of this my work suffers!
Cycles renderCycles render


Revert to version 20.10.1.  Should render fine.  Wait for a fix from AMD.  They are aware of the issue.

Journeyman III

Я полностью удалил программное обеспечение Radeon adrenalin, и без него eevee начал работать.Так же провел тесты в CompuBench 2.0 и все работает нормально. Так что проблема не в драйверах, а в программном обеспечении amd Radeon adrenalin...у них просто кривые руки и растут из задницы(((

I completely removed the Radeon adrenalin software, and without it, eevee started working.I also ran tests in CompuBench 2.0 and everything works fine. So the problem is not with the drivers, but with the amd Radeon adrenalin software...they just have crooked arms and grow out of their ass(((

I just tested a Gigabyte RX590 8GB on Blender 2.9.1. 
I downloaded and installed the Windows Zip Version and extracted it under my C: drive.
Downloaded from here:

GPU based rendering is working on the RX590 for basic Cube. 
Eevee is also running. 
Note the RX590 is being used as a Blender Accelerator via a PCIe2.0x1 -> USB3 Mining Adapter. 
Primary display output is from an RX5700XT. 
The RX590 also manages to run Compubench 2.0 tests.


Thanks for all the replies.

I can render again in Blender.  I did the following.

1. I have a Win 10 system. Opened Device Manager. Display Adapter Shows Radeon RX 590 Series. 

2. Uninstalled Device and rebooted.

3. Back to Device Manager and Display Adapter. Update Driver Button. Download began.

4. Rebooted.

5. Device Manager Display Adapter now shows a Driver Date of 8/27/19 (The date I first installed this card) Driver Version 26.20.13002.133

6. Opened Blender.  Every Object now renders perfectly again.

The Radeon Software does NOT work.  Error message with my Driver Version (Too old apparently) 

My problems began with 20.11.3. ALL versions prior to 20.11.3 worked fine in Blender 2.83 and 2.9.1

I am not a gamer.  For now I can get by just fine with the 8/27/2019 driver version.  Once I complete the current Blender projects I will try the latest Driver Version again.  I did send a support message to AMD support.  Will see if and when they respond.  I also completed a bug report.  Hopefully AMD can address this issue.  I will post any new responses from AMD.  I suggest that anyone experiencing issues contact Support and file a bug report.  

Thanks to everyone posting on this thread.  Hopefully AMD will address this issue in the next release.



Glad you got it running. 
I am just about to test running the RX590 as primary display output for you using Adrenalin 2020 12.11.3 drivers. 

You may want to try a full DDU uninstall and reinstall of your current driver? 
I will post a link on how to do it next, just in case. 


RX590 render of basic cube using Eevee, with the RX590 as the display out (HDMI)  is broken. 
It renders the cube in a checkerboard pattern. 

All other cpu and GPU based rendering runs o.k. 
There does indeed seem to be a problem with RX500 series, Blender and Adrenalin 2020 20.11.3 driver, on Eevee.

Same here on rx580 Sapphire at 20.11.3 driver at my previous 20.8.3 all look good

In Viewport shading>Solid all objects are transparent can see only yellow contour

In  Viewport shading>Look Dev all objects are totally black

Тоже самое на 20,11,3 в Блендере 2,80

То есть проблема только в оболочке радеон драйвера? Если использовать один драйвер 20,11,3 то все корректно отображается в блендере?



Found this link...Radeon™ RX 590 Previous Drivers | AMD

All of my issues began with 20.11.2.  All previous versions worked. 

I downloaded 20.10.1, release date 10.16.20 and installed.

Everything back to normal.  The AMD Radeon Software app works again.  Blender rendering works perfectly.  No issues with any software.  I clearly don't need 20.11.2.  Will wait for the next driver release.  Perhaps this issue will be resolved. 

Certainly one's hardware also plays a role.  My hardware specs:

Lian Li PC-011DX 011 Mid Tower Case

Corsair TXM TX750M 750 Watt Power Supply

AMD Ryzen 7 2700X CPU

Gigabyte X570 PCIe 4.0 SATA 6GB/s USB 3.1 AMD X570 ATX Motherboard

64 gig memory total:

Corsair Vengeance RGB Pro 32GB (2 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600)

Corsair LPX 32 GB 3200 MHz C16 DDR4 Dram


MSI Radeon RX 590 8GB GDRR5 Memory Graphics Card

Samsung 970 EVO 500 GB PCIe M.2 2280 SSD

WD 1TB 7200 rpm Sata 6 gb/s, 64 mb cache Hard Drive

Uphere 3-pack 120 mm fans

Gigabyte GC-WB867D-I REV Bluetooth 4.2/Wireless AC/B/G/N Band Dual Freq 2.4Ghz/5.8Ghz Expansion Card





Here the same problem, even installing the previous driver did not solve (DDU), I don't know what to do, I need to solve this to do my job.

Amd Radeon Rx 580.
Windows 10 Pro (20H2) 19042,662
Blender all versions.
The problem started with the 20.11.3 driver.

EDIT: I was able to solve by installing the 20.11.1 driver(Subsequent versions are not working here.)


Just received an email that Version 20.12.1 has been released.  I read the release notes.  Did not see any mention about the rendering issues in Blender.  Has anyone with these rendering issues tried this new version?

Version 20.10.1 continues to work fine for me.  However, this evening or tomorrow I will try 20.12.1.  If it works...great.  If not I will revert back to 20.10.1.




Installed 20.12.1.  Does not work in Blender.   Back to 20.10.1.  

Perhaps AMD is still working on the problem.  I will give them the benefit of the doubt.  For now.

I sent a support request on 12/2.  No reply so far.

Нет,кажись с версии драйвера.Поставил 20.9.2 - заработало!

Journeyman III

Hey everyone , 


Any idea when or if AMD radeon is going to fix this?

Im just starting with blender but i almost gave up because nothing was working like the tutorials explained. And i didn't understand why my computer didnt work correctly in blender.

Thankfully i found other people with the same problem all of them using AMD I tryed downgrading my gpu to 20.10.1 but windows stopped the installiation halfway through several times due to errors and i'd rather use my computer on a updated gpu.

Learning is basically useless now for me because i cant follow 99% of the tutorials. And i hope this issue gets resolved soon for the entire amd blender community.  I see that a lot of people rely on it to feed themselves and maybe even their children. Please fix it asap. 


May be we need go to nvidia cards?

Adept III

Still no any news about fix?


I received an update today from AMD technical support.  The tech stated again that the "driver team" at AMD is aware of the problem.  He also speculated that the Blender developers may need to create a patch to the Blender software.  Wait and see.

For now, 20.10.1 works perfectly.  


Hey cgcartist, Im curious if 20.11.1 will fix your issue? Many people with 5000x series cards have had issues with drivers from 20.11.2 to the current driver of 20.12.1. 

Asus B450-I 2700x GSkill Trident Z 16GB 3200 CL16 XFX 5700 DD Ultra

Since all my problems began with 20.11.2 it is likely that 20.11.1 would work.  I don't recall but that probably was the driver version I was using at the time.  I reverted to  20.10.1 over a month ago because when I searched for legacy drivers it was shown in the list.  For some reason 20.11.1 was not on the list at that time (It is now).  

For now I am staying with 20.10.1 because it works fine in Blender and in Photoshop which are my main two programs. Will see what happens with the next driver update.  As I mentioned in a previous post the possibility exists that Blender may need some kind of patch .  A few users in the Blender Community have also reported this problem.  But I do not know if the Blender developers are involved at this time.

For now everything works fine.

I will continue to post any updates I received from AMD or Blender.

Why Blender team must fix AMD driver problems?


They shouldn't.
They should be working closely with support from AMD to make sure people like me do not go out, buy RX590 for use as blender accelerators only to find out they cannot even complete basic blender benchmark tests. 
Blender should be part of AMD Driver release QA test suite. 


Blender may need to patch this? That's ridiculous. That's beyond ridiculous! AMD introduces a problem, then says others have to work around it? What about all the versions of blender that are totally out of development? Every version of blender between 2.79 and 2.83 would be unusable on AMD devices, along with all the plugins that haven't been updated.

With responses like that, it's really starting to sound like time to get a NVidia card.

Journeyman III

yeah shame with me it looks like it happent with onlt the rx 400 and 500 cards i have a rx 480 8gb and nothing is rendering in eevee just a weird artifact i hope they fix it for now i just i have to send my blenders files to a firend if i want to render them 


It seems that Blender released a fix in version 2.92 (daily build), it is probably not the final solution, as I think it will need a driver update.



Edit: It seems to work well (tested on the Rx580).
Edit 2: The wireframe has not yet been fixed.

Its a mirracle! Last alfa daily build of Blender good working on 20.12.1!


Apparently  the AMD tech I corresponded with was correct.  The issue was with Blender.  

I downloaded the Blender 2.92 alpha build.  Then updated the AMD driver to 20.11.3 ( I did not try the 20.12.1 driver given that my issues began with 20.11.3)  Blender 2.92 now renders my files perfectly with  AMD version 20.11.3.

Since 2.92 is an alpha version the developer cautions that a Blender file could become corrupted.  Easy to avoid by not saving over a good file.



No, man. If the issue were with Blender, it either would've appears years ago, or wouldn't have affected legacy versions of Blender.

As it stands, AMD made a change that broke compatibility, and has shoved the issue off onto the Blender devs, ensuring that all legacy versions of Blender with Eevee support will be forever broken on AMD cards.

Oh no( Its still broke( Now wireframe mode is transparent


Just downloaded  2.93 Alpha.  2.92 Beta is also available. 2.93 Alpha seems to work fine during the few minutes that I used it.  Rendering not an issue.  


This video will explain 2.93.   

Blender 2.93 Alpha RELEASED! & UPDATES! - YouTube


Forgot to add.....wireframe working again also.


There are still several problems like:
Split kernel error with OpenCL


amd is guilty of this all problems


Never had an issue like this before, really disappointed. I hope they come out with another driver update really soon and fix this mess because I can't work like this.  


AMD just released Version 21.1.1.

Blender 2.92 alpha and Blender 2.93 alpha no longer render. Wireframe also does not function.  I reverted, again, to 20.12.1.  Render and Wireframe functions ok with 20.12.1.