Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

After intalling 19.1.1 and 19.1.2 can't play any video file

Being using and old version for a long time without problems, recently updated to 19.1.1 and wasn't able to play any video file. Thought it was the video player first but tried with potplayer and vlc and nothing. Installed yesterday 19.1.2, was able to play video files again, today I can't play video files again. It has to be something with the codecs, at potplayer the program fails to load sound and video it just freezes when the window resizes to the size of the video, at vlc, plays sound but no video.

Video ASUS R9 270

Windows 10 64bits - 1809

10 Replies
Journeyman III

Yesterday made a complete removal of drivers in safe mode with AMD Cleanup Utility, without proper drivers I was able to play video files again but choppy, installed lastest beta version 19.2.1 all good, reboot all good, but today again the problem returned.

Just to be clear this only happends with local files, youtube works perfect.


 That sounds maybe more like malware. I would scan would run rkill, then rouge killer, finally malwarebytes anti-malware. You can get them from reputable sites like bleepingcomputer_com or majorgeeks_com. I would then once clean check your disk for errors followed by a system file check, sfc.exe /scannnow. 

It sounds like something if messing up your file associations, and malware is far more likely to be doing that than any driver. 

If that doesn't help please reply back with full system specs and we can try more at that time: 

When posting a new question, please provide as much detail as possible describing your issue making sure to include the relevant hardware and software configuration.  
For example:

  • Issue Description: [Describe your issue in detail here]
  • Hardware: [Describe the make and model of your: Graphics Card, CPU, Motherboard, RAM, PSU, Display(s), etc.]
  • Software: [Describe version or release date of your: Operating System, Game/Application, Drivers, etc.]

Another clean driver install, this time with lastest beta 19.2.1 the problem persists

  • Issue Description:When I start the pc can't play any local video file, depending on the video player used either no video and only sound or the app just can't load the file at all and stops working. Weird thing is that if I reboot the pc, all is working ok. This issue only happends when I turn on the pc. Problem started when I updated the drivers.
  • Hardware: ASUS R9 270 DirectCU II OC, AMD FX4300, Motherboard GA-970A UD3, RAM 8G DDR3, PSU Cooler Master GX 650w, Samsung XL2370
  • Software: Windows 10 64bits, tested video players, Potplayer, VLC and Windows default video player, 19.1.1/19.1.2/19.2.1, no malware found. Will try to install old drivers.

your not really explaining what specifically isn't working and what is.  You say if you reboot the pc it works then say if you turn on the pc it doesn't, that is not very clear. You say some players work and list players but not which ones work or dont work. Does VLC work? If it does it is an indicator it may be codec related as VLC uses it's own built in codecs. Is the issue only with certain types of video files like MP4?  Do you also have the very latest MB bios and chipset driver? What version of Windows 10, 1803, 1809, are you on and are you positive it is full up to date?

Make sure all above is updated.

I think I would disable hibernation and fast startup and hibernation.

run DDU, from wagnardsoft_com from safe mode

disable internet

Install the driver 19.2.1

if it is not working at that point install 19.2.1 as an express install again over the driver don't uninstall it first


If VLC works, as Kingfish said install a that codec pack you might just have a hosed codec. I personally only do that as a last resort as sometimes it may fix one codec but create another issue. If it isn't broken don't fix it, but yours may be broken. 


Sorry pokester, I thought I was being clear, let's try this again:

When I turn on the pc I cannot play any local video file, I have not tested thoroughly, but I have tried with several common codecs within .mkv .mp4 .avi containers and they just doesn't work, they are also from different sources (camera, smartphone and movies backups). Some video players like VLC are able to reproduce the sound, but the video stays black; for the rest of video players tested they just get stuck at 00:00 and can't play the file at all.

I am only able to play those video files again when I restart the pc. I wasn't aware of this on the original post, that time I just installed a new video driver, saw everything went back to normal and thought it was solved, until I turned off the pc and turn it again next day only to discover that the problem came back.

Since then I have found old threads with similar problem however, these users report that they are also not able to play online videos like Youtube, something I can do. This could be related as far as I know that years ago Youtube went from h.264 to VP9 codec, however I have not tested any other video stream. I may have to test every possible video codec, maybe that could bring more information regarding this issue.

One suggestion found was to check task manager and identify which process may be the culprit when trying to play those local files, and several users identified audio related processes like "Audiosrv" and AudioEndpointBuilder" started using a lot of cpu resources, and when they ended them everything went back to normal, but I don't have those running and didn't have success with other processes tested.

Windows version is 1809, and should be everything up to date, I am not on that pc right know but yesterday checked that it had a .Net Framework update around the same dates this problem started, which was when I update the drivers to 19.1.1 version. However, maybe this is just a coincidence and is not related to AMD drivers, being the culprit a rogue windows update, after all they are into a bad streak lately.

Going back to your suggestions, I do know I have hibernation off on that pc, but will verified it and try the rest. Will also test to roll back that windows update.

I do not like to install codec packs, have not done it since windows XP because usually they end causing a total mess. But yeah, I can’t discard it as a last resort.


Adept I

I've been experiencing a similar issue with local video playback except in my case even if I restart my PC it doesn't help, which is weird because when I first installed the drivers (19.2.1) everything seemed to work fine at first, then these issues started happening eventually every time. For me, sometimes this same behavior can be observed on YouTube. Also my entire system hangs for a few seconds when opening any of these video files.

I only have 3 media players on my PC:

1. Windows Media Player (PC hangs for a few seconds, then only audio plays)

2. Movies & TV App (Can't play HEVC videos without a paid codec, so can't test)

3. Media Player Classic Home Cinema [from K-Lite Codec Pack] (PC hangs for a few seconds, then plays normally)

The PC also takes longer than usual to enter/exist sleep mode. I'm fairly certain that this is a driver issue because rolling back to previous drivers eliminates all of these issues. 19.2.1, 19.1.1 & all of the 2019 editions of the 18.x.x drivers exhibits these behaviors, even the formerly working 18.9.3 drivers has started misbehaving (after a recent cumulative update) which also leads me to believe that these latest Microsoft Windows 10 updates and AMD Display Drivers are conflicting with one another.

I now just stick with 17.7.2 display drivers version as it seems to work flawless (even with latest Windows updates) and only temporarily update display drivers if a particular game calls for it.

Journeyman III

Ok, it is fixed

I did what pokester suggested, used DDU in safe mode, then installed 19.2.1, the problem was still there so I express installed 19.2.1 again and that made the trick.

More info: with the driver uninstalled I was able to play every video file with windows default drivers even without a restart, so this was definetly related to AMD drivers.

Thanks guys.


For me, pokester‌'s suggestion only worked for that one current power session, after a reboot the issues came right back. This of course only happens with all the recent drivers so I guess I'll be sticking with older drivers until its time to buy a newer GPU and may have to switch to team green if its the same story with newer AMD GPUs.


Did you disable Fast Startup and Hibernation first, then disable windows from auto updating drivers? This is what reloads old driver data causing a corruption then Windows trys to fix it by loading back in a repository driver.