cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

marek220
Journeyman III

After I install driver, and restart my computer, the driver is not install.

Hi, i have this problem. Yesterday i download a new driver 17.4.4 on my graphic Asus Strix AMD R9 380 4GB. I download driver, and install it, but after install will appear EROR 1603, and next i restart computer. But after restart the driver is not install. On the screen will appear. (picture) I try reinstall driver but problem not solved. Thanks for help.

(Sory for ma bad english)

Snímka.JPG

0 Kudos
7 Replies
christso
Adept I

Re: After I install driver, and restart my computer, the driver is not install.

I have exact the same problem, so I guess it isn't gpu, maybe some problems with windows + drivers etc. Let's hope we get some answers and fix the problem.

0 Kudos
_nl_ben
Adept I

Re: After I install driver, and restart my computer, the driver is not install.

Hello marek220​ and christso​ - can you please start with checking the following article? Error 1603 – A General Error Has Occurred During the Installation of the AMD Software Package

It isn't guaranteed to help (sorry), but at least the cause of the errors can be narrowed down a bit

0 Kudos
marek220
Journeyman III

Re: After I install driver, and restart my computer, the driver is not install.

I try scan computer, and next instal driver. But problem not fix.

After every instalation gpu driver, will apear EROR 1603. What is this error?

0 Kudos
christso
Adept I

Re: After I install driver, and restart my computer, the driver is not install.

Well for me it didn't help, but anyway thank you for trying to help us, I ll keep trying to find how to fix it and if I found the way to fix I 'll post the answer. It's a really really weird problem, even with reinstalling windows 10 or 7, couldn't fix something 'till now

christso
Adept I

Re: After I install driver, and restart my computer, the driver is not install.

Hello guys , back with good news. I fixed my problem after speaking with AMD customer service. They asked me to instal 16.11.5 hotfix drivers (I got AMD rx 480). First i removed battery for some hours , reseted on mobo jumper, start on default when I powered on the pc and then use DDU to uninstall old drivers in safe mode. After that I installed 16.11.5 drivers and it works normally. I did a restart and drivers are there. So it works okay with those drivers now. If I have a problem in these days I ll post again. I hope you can fix your driver issues too.

P.S. I used before all of these Ccleaner (free version) and found some things missing in Registries, don't know if that helped but i did it.

marek220
Journeyman III

Re: After I install driver, and restart my computer, the driver is not install.

I try this what write christo. I turn off computer and i disconnect computer from electricity for 10 hours. Now i start computer, scan with ccleaner, in safe mode i with DDU uninstall drivers of graphic and restart. After restart i install 16.11.5, but after 100% install (picture). But drivers i dont have install.

Snímka1.JPG

0 Kudos
christso
Adept I

Re: After I install driver, and restart my computer, the driver is not install.

Hello marek220, I didn't only disconnect the power electricity but removed the battery from motherboard, check this step, I believe you have to reset your CMOS. To my pc yesterday at night I had drivers removed for some problem i wasnt fast enough to see, I installed them again and work, but have to test it for some days to be sure everything will be ok

0 Kudos