Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Adrenaline - Ultrawide Resolution Issue on Wakeup

When waking up my Ultrawide LG 34gk950f from sleep, the resolution of my monitor goes to 1200x800 and has black bars on the left and right side. The issue is resolved by either powercycling the monitor, reseating the DP cable, toggling the display port in the monitor between 1.4 and 1.2 or rebooting the PC. Thinking that the monitor may be starting slower than the 6900xt, I played with Windows power settings, nothing helped. I've turned off HDCP, freesync and all other settings within Adrenaline, this did not solve the issue. Installing the monitors latest driver did not solve the issue. Swapping to another DP cable did not solve the issue. Tried a RTX 3080 and could not duplicate the issue. Uninstalling/reinstalling the latest driver/adrenaline did not solve the issue (DDU was used for a clean wipe).

I did a clean boot of Windows and ended the Adrenaline process. When my monitor went to sleep, it woke up with the correct resolution. Tested this multiple times and each wake up worked correctly. I then started Adrenaline, let the monitor go to sleep, and the resolution issue returned. 

I uninstalled the driver and adrenaline software again, then installed ONLY the 6900xt driver. Ever since doing this, waking my monitor up from sleep has been fine. It seems something between Adrenaline and having an ultrawide monitor is causing this issue. I already reported the issue to AMD, but wanted to see if anyone else has experienced this problem or found a fix. At the least, making the community aware of my problem may help someone down the road too.

Motherboard: ASUS X570 TUF Pro-WiFi (SAM/BAR enabled)
CPU: AMD 5600x
RAM: 32gb G.Skill 3600Mhz 16-16-16-28
GPU: Sapphire 6900xt reference
Monitor: LG 34gk950f
OS: Windows 10, all current updates

112 Replies

Adrenaline 21.3.1 does not resolve the issue. When the monitor wakes up from deep sleep it is still locked to 1280x800 for me and has to be turned off and back on.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

For now your only option is to turn this setting off and just power down the monitor when you walk away or move to HDMI, they are the only fixes that work right now on my LG 34GK950F


I should have found this thread earlier. Same screen (LG 34GK950F), same issue for months. It was finally acknowledged as a known issue in 21.3.1, so it seems they are looking into it. But in 21.3.2 it's listed as "fixed", and I can confirm it's not, unfortunately. I made another bug report for it and I hope they look at this thread, too.


I am sending a bug report with each driver update. I was hoping our issue was that:

On a limited number of displays, the preferred desktop resolution in Windows® may change when the display is power cycled.

but it was apparently not. Really getting stressed.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

I wouldn't stress over it, just change the way you use it and turn the monitor off when you walk away. Problem solved.


A slight update. Recently I was given a Mac Book pro from work and used it for 2 weeks, the monitor sleeps perfectly. I have even tried it on Display Port. Same on my Linux laptop with AMD drivers in there, the monitor sleeps fine.


My theory is that something has changed in Windows 10, which is why certain drivers work! Then the drivers are built going forward and new windows 10 updates causing the issue. I can replicate this all the time on WIndows with display port, so a WIndows 10 timing issue, wake issue and also the panel at play.

The Mac I have on HDMI mainly so I can keep my gaming machine plugged in without faffing on with cables and it just works, but as I said, the Pro has a AMD GPU in it and on usb c to displayport it works fine, no sleep issue and the same for the linux laptop.

I really do think this is a WIndows 10 issue and Panel, I can find reports all over for other monitors makes and models doing the same with display port IPS panels. I know the likes of Dell etc use LG panels but I have seen Iiyama, AOC listed as issues with sleep/wake also.


Nice theory, but doesn't explain what is happening in practice. People have reported that reverting the driver to 20.9.x or so fixes the issue for them. So that indicates that something is wrong in the driver. I first reported it on 20.11.2 and included in the report that 20.10.1 was partially affected as well, though the resolution change wasn't persistent and consistently reproducible, only all of my windows got resized and moved in about 10% of the times where I woke the screen. Unfortunately, that and previous drivers were not an option for me anymore as they caused bluescreens upon waking my PC from standby (and some other problems), so I can't exactly trace back to when it happened (nor is that useful for me). The fact that they seem to acknowledge this problem is also a good indicator that it actually is the driver causing it.

And with regards to things changing in Windows: I have upgraded from 1909 to 20H2 two days ago while I have had the problem for months already. Nothing changed in that regard, and nothing significant has changed leading up to the manifestation of the problem. In that light, you'd expect Nvidia users to report similar problems, but the threads I can find on this issue are AMD-only.

Both Mac and Linux are different systems with different drivers, sharing none of the codebase for the OS-specific parts so a power-related problem in one isn't necessarily going to manifest itself in another. Other screens and screen vendors experiencing the same issue says nothing about whether the problem is driver- or OS-related if there are no other factors (e.g. GPU vendor) excluding the possibility of the display driver being at fault. And at the moment, there are none, or I haven't found them.

As for not stressing over it, I use my computer for more than just gaming or a single window. It is for productivity/work things as well, and I regularly have over 15 windows open (that's part of why I have an ultrawide screen). Coming back to my machine after a planned or unplanned break (in both moment and duration) I expect it to be in the state I left it in or configured it to be in, and that is not with a different resolution and my workspace completely reordered. Working around the problem in whatever way makes the problem less likely to be reported consistently, which might give AMD the false impression that the issue was fixed. Clearly their testing and production machines do suffer from this problem so it won't be caught by their pre-release test suite and day-to-day experience.


I too bought an ultrawide for multi window like yourself.

The issue with this being a driver issue is if it was we'd all have the same issue on the same driver!

I originally had it working on 20.9.1, you are 20.10.x others said 20.11.x so we can get it working on differing drivers. If it was a driver issue then I am sure we'd be working in the same driver and then failing on the next or have slight weirdness but if you swap your cable to HDMI it all goes away, so it's linked to display port, tried the usual of certified cables, refresh rates etc, even using LG Drivers instead of built in Windows ones, just happens on display port.

The Nvidia issue is the original LG community link I posted, the one posted recently is a new thread where we could all put our issues down.

Looking at the LG reply they are wiping their hands of it, it seems they are not interested.

I can replicate this issue all the time if I do sleep mode for the monitor only, my PC never sleeps. Interestingly, if I turn the monitor off and come back (intended or unintended break, I had to change my process as powering the monitor on and off just to get the res back was wasting more time) I do not get the res issue but like yourself my windows will resize, more interestingly on those I have snapped to the left side of the screen!

I caught this on video too with using a screensaver instead of sleep and the monitor makes everything go to top quarter of the screen.

I had this issue on my 144hz 24" dual Iiyama black eagles a few years back with an AMD R390x I got the 5700XT and they stopped doing it, then went ultrawide with the LG 34GK950F-B and it returned.

I have done driver cleanup and new install, I recently completely rebuilt my machine still there but now more interestingly is that the 20.9.1 driver that did work, now also displays the issue... Previously I was on Windows and upgraded through the versions, this is a clean build as if 4 days ago and now no driver works. This is where my guess came from about something in Windows, even upgrading holds onto older files or registry etc. Now I've clean built, no driver works, it does the issue on every driver I had from 20.8 - 21.3.1.

I hope there is a fix for it but we are half a year down, nothing sorts it, I raised it with MS as a bug and heard nothing either. I'd love a fix but our options are either go to HDMI and use the panel at 85Hz and forego the display port and 144hz or wait for a fix that might never come 

I think a few have confirmed that HDMI seems to work.

I borrowed a LG 38GN850 from work and the monitor works and sleeps fine on any driver which is why I'm thinking windows/panel issues here.

The issue we have is we don't know if AMD are even reading this or looking at the bug reports as I raise this too with every release, I am guessing we are a niche corner of the market with a very specific monitor.


The last driver that works for me is 20.11.1 (tested it yesterday again). And I can confirm the issue does not occur if my monitor is connected via HDMI, however then I am stuck at 85Hz.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

I'm having some trouble following your line of reasoning GreyMata. It seems you're overcomplicating things when they are really simple, as pointed out by vidko below your post, reverting to some earlier driver fixes the problem, that means the only difference is the driver and that is also the place where the behaviour can be changed to fix the problem in newer versions too. If it were actually a Windows problem, there would be one or more similar (and active) threads on the Nvidia side and reverting the driver wouldn't work, since the act of doing that does not change Windows.

I have looked through the thread for the Nvidia issue you talked about, but in that case the screen isn't even turning on at all. While it does reinforce the idea that the screen is either more strict or less compliant and it's on the power side of things, the issue itself seems different, at least for me because the screen turns on, just at 1280x800. It is similar though, might very well be the same thing, but Nvidia probably have fixed it, otherwise there would probably be an active thread on it with many Nvidia users replying.

It's not always black and white that we need to see the exact same symptoms with the same driver versions because a lot of our other hardware is different too, and issues like this usually do not have to have a clear and simple, one and singular, defined path to work up to it, it can be an interaction between different pieces of code. Power state changing code usually consists of a lot of different parts in some order with some defined timing in between that needs to be accurate. Even the BIOS could be a factor. One of the reasons why I can't easily go back to earlier drivers that don't have this problem for me is that they have other bugs that have since been fixed and are show-stoppers for me. One of them is a fairly high chance of a bluescreen when waking my PC from standby, and the trace shows the problem being in the AMD driver trying to change powerstates for my GPU. This happened after upgrading my CPU and BIOS to support it, so nothing in Windows or the drivers changed but the bug started to manifest itself and was subsequently fixed in a later driver. Even if you did a fresh install of Windows you might be running other things at different versions (e.g. BIOS) that are now consistently triggering this bug.

The simple act of fixing that bug A could have inadvertently introduced (just speculating here, just an example) a timing issue B or something similar that is not an issue on most screens but manifests itself in this way on this specific screen. It might very well be that there are more configurations that can cause A to occur but hadn't been discovered yet when the initial fix was made, so fixing the same bug for those other setups will require a new driver version. Now you could be in a situation where the same issue manifests itself on different driver versions on different configurations, while it does not exclude the driver from being at fault (because I have just defined it to be).

It does seem that the LG 34GK950F has some issue where it's not 100% standards-compliant or just behaves differently from what is expected, since it's reported a lot in this thread as being affected. It could easily be the other way around, that the AMD drivers/hardware are not 100% compliant but this screen is more strict about it. We can't really know unfortunately. But LG said they aren't going to do anything about it and are probably rightfully pointing to AMD when they have other drivers that do not exhibit the issue.

Turning off your screen does indeed, in most cases, move and resize all your windows. That's been an issue I've had ranging back all the way to 2011 and Win7 when I first started using DisplayPort. That does seem to be a Windows issue. In the old days of VGA and DVI, you'd set a resolution and there was little or no communication between the screen and the OS. The bit that was there (DCC/EDID) was passive AFAIK, so didn't require the screen to be on. Now with DP (not with HDMI AFAIK), the screen turning off is actually communicated to the host device/OS and can be observed by the "hardware disconnected" sound that's played. In that case, there is no screen to have windows on so Windows uses a virtual one which, coincidentally, is 1280x800 I believe. It'll move all your windows there and they are made to fit. When you turn the screen back on, it reconnects and the windows keep their new positions and sizes. I think a slight attempt is made at restoring the original positions but it's a far cry from being perfect. While I can sort of understand why they did this, I do consider this a bug in Windows and maybe even in the standards which they, unfortunately, still haven't addressed yet.

This is also why I think it's a timing/race thing that could be addressed by AMD, probably by waiting a bit longer for the screen to connect upon wake before telling Windows the display is gone. It then seems to proceed screwing up several things to give us the actual wrong resolution on the screen and no option to set it without actually "reconnecting" the display while the GPU is active.

I think, and I hope, that what they wrote in the change log actually is the issue we're experiencing and that they're working on a proper fix.


I fully agree with you and what you are saying.

The only reason I was leaning towards panel/firmware is that the issue happens on the 34GK950F-B and no matter how much I try it I can't get a solution to work.

If I use the 38GN950 from work (gutted I couldn't keep hold if it), it works flawlessly, no issue at all leading me to the panel/firmware of the 34" version. Only major difference on these montors the 34 is Freesync and I believe the 38GN is G-Sync, I need to look into it further. As you say, it could be a timing thing and I wonder if the G Sync monitors wait a littel longer or poll for the res before firing up. I might be tempted to sell the 34" and see if I can trade it or sell and put money towards the 38. Wish I had access to the Samsung 49" to see what happens on that screen.

Here's hoping there is something that can be done on the driver side with AMD as I don't think LG or MS will do a single thing about it


Meanwhile, I have now had two occurrences with the newest driver where the screen woke at the proper resolution and without having reordered my windows. I haven't kept an exact count but I'd say this is somewhere between 10 and 30 percent of cases (so far, for me) where it has worked properly. With the previous driver(s) it was a 100% consistent problem so it does seem they have tried to change something and may be on the right track of fixing it.


Latest drivers ar still a 100% failure rate for me. Been trying it for the last few days. As per, if you come back within 30 mins all is ok, if you leave it anything more than 30 mins the res issue is at 1200x800

Will try the next ones that come out


Did anyone have any joy with 21.4.1?

Been using them for a few hours but still got the screen issue on display port.

Just wondering how others got on.


Just installed it. Will report in a few hours.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

It woke up as it should for me today at least once, however I am not sure if it was in deep sleep or not. Will leave it on overnight and report back in the morning (I turned it off last night as I got used to turning it off before I go to bed).

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

This morning my monitor woke up just fine (I did however had a GPU driver crash notification (was mining and playing with voltages and undervolting), but then I went for a walk with my dog and was away for about three hours and it woke up normally again.

Will test some more, but it seems AMD fixed the issue with 21.4.1 driver.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

Too early to tell, but I haven't encountered the issue so far (n=4) on 21.4.1. Too early to call, though. It's been hit-and-miss on 21.3.2 and I haven't found a way to repro it 100% so I'll give it a few days and see how it goes.

After 2 days of testing, I can confirm the issue has been resolved: no more DisplayPort wake up issues with new 21.4.1. Kudos to AMD, however I would prefer having it mentioned in the driver release notes!

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

So I grabbed 21.4.1 and installed over the top of 21.3.1 and still had the issue. I recently had an issue with my PC so I did a full rebuild of windows and installed 21.4.1 and all is working.

Could it be something with WHQL drivers as looking back through the thread it seems we get reports of it working properly on WHQL drivers, the optional seem to cause issues.

Only been using for a few days so will see what happens down the line but so far so good.


Yeah I'm probably at n=10 now and I haven't encountered the issue anymore since 21.4.1. So I was inclined to believe they finally fixed it. Now that I read that it seems to have been fixed for you too, I'm more sure. A lot of people won't be coming back to this topic unless the problem appears again. I'll keep an eye out for it but indeed, looking good.

As for WHQL: those drivers aren't different from non-WHQL drivers. The WHQL process is just a certification, a sort of "guarantee" that those drivers are good and compatible with Windows, and it has nothing to do with the inner workings of your drivers. Getting your drivers certified means running a bunch of tests and sending the results to MS, who may take up to 30 or so days to check your results and afterwards you may release them as WHQL, and they may be included in Windows Update. Because this process takes quite a long time, driver developers often choose to release non-WHQL intermediate versions because they can be immediately available to the end-user when there are some hotfixes that need to be released immediately, or low-priority fixes that don't really warrant going through the whole process again while bigger fixes are still on the roadmap.

Remember, there have been plenty of drivers in the past months that are WHQL but still exhibit the problem, e.g. 21.3.1 which was your previous driver.

I'm glad it (so far) seems to be fixed for you, too. I'll keep an eye on this thread for a little bit to see if this is still a problem for others. In the meantime, other people who experienced this problem, please reply whether or not it was fixed for you with 21.4.1 and what screen(s) and graphics card you are using, and how they are connected. I'll try to compile the results and send them on, if necessary.

Vidko, as for not including it in the changelog, that should have been there yes, unless it was fixed unintentionally

So far:

  • vidko - 5700XT 50th and LG 34GK950F via DP on 21.4.1: seems fixed
  • GreyMata - 5700XT Red Devil and LG 34GK950F via DP on 21.4.1: seems fixed
  • DataGhost - 5700XT and LG 34GK950F via DP on 21.4.1: seems fixed

You can add my graphic card: 5700XT 50th Anniversary. Also, soldier989 (the original poster) could update the first post.

To be honest I do not really care anymore if it's in the release notes or not, as long as it is fixed. And even if next driver breaks it again, we have a driver we can revert to and is not half a year old or even older.


Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

So far so good, its not 100% but its working on wake, I have noticed that the lock screen image will go into a 1200x800 res but once logged in its at the proper 3440x1440 res at present.

Only other thing I have noticed is the resolution is fine but at times waking the machine certain windows have been resized.


Is that wake on computer sleep, or wake on screen sleep with the computer still fully active? Do you lock or log out? Can you assign some estimated percentages to these:

A : Wake at native resolution with original windows
B : Wake at native resolution but windows resized/moved
C : Lock screen is actually displaying at 1280x800 (huge font, big pixels), unlocking to native resolution with original windows
D : Lock screen is actually displaying at 1280x800 (huge font, big pixels), unlocking to native resolution with windows resized/moved
E : Lock screen is actually displaying at 1280x800 (huge font, big pixels), unlocking remains at 1280x800


Just screen sleep. I don't sleep the PC.

All I do is when I walk away from the machine I will do the lock and the monitor sleeps 1 min after that


What I see is the login screen image and text are large as in 1200x800, as soon as I log in its normal again.

I would say its happened 4 times in the last week so its not happening everytime.

I would say out of the 4 times its happened:


A - 90% 
B - 0%
C - 5%
D - 5%
E - 0%


so the majority of the time its been perfect, I have had one issue where windows were moved and resized after logging back in from the lock screen and then the same but after logging in the windows were fine.

What I have noticed is if the issue is going to happen, at times you get two tray icons and then it will vanish after a few seconds, looking into the event viewer there are issues where it says it has failed to load:

The description for Event ID 1060 from source Application Popup cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:


The message resource is present but the message was not found in the message table


Well, while it's still annoying when it happens, it seems it has generally improved quite a bit. The newest driver 21.5.1 just came out, maybe that fixes it completely for you?


I had a one time wake up issue with 21.4.1 where my display turned on, turned off for a split second and turned back on, otherwise not a single issue with waking up.

Before upgrading to 21.5.1, I will wait for your reports first

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

So the drivers seem to work as in they will not reduce the screen to a 1200x800 window, however I do get this every so often at the login and then when you are in windows you can see two drivers running, one is failed and the other is a restarted one!


As you can see the login background is at a higher res but the screen looks ok.

Checking on the event viewer, this is what is failing:

- EventData

C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe


Yeah, that's a different issue that's popped up for more people in the last two or so drivers. It's "just" the Radeon Software UI crashing and getting restarted, not the driver itself. Hovering over the icons will remove all but one of them. It's been reported quite a bit so I assume it'll be fixed soon in a newer version. Just curious though, can you reproduce it doing some specific steps, or is it a random occurrence for you? Although that might be better for a separate topic.


I can replicate it every time, all you need to do is start the PC without the monitor being powered on, come back to the pc after a few mins, turn monitor on and then you will see the issue.

I tend to power up the PC, walk away for a tick whilst its starting then power on monitor.


Watching this video: was the final nail in the coffin. This is my last LG monitor.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

Anyone having issue that with 144Hz refresh rate, that the color depth is reduced to 6-bit only with the latest two driver versions?

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B
Journeyman III

I'd attempt doing a BIOS factory reset to make sure there isn't some thing weird or wrong set in there.. Also deliver the 1 stick of RAM a attempt to rule out a defective stick..


I figured out it was DayZ Standalone game that was causing it.

I am having a weird issue with the latest three Adrenalin versions. Positions of my desktop icons get reset at every Adrenalin update, really annoying.

Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B