Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adrenaline Edition 2019 (18.12.2) - Radeon Settings and Driver Versions Don't Match and No Option to Install Radeon ReLive

Yesterday afternoon I updated my display driver to the new 2019 edition and noticed that I wasn't given the option to install ReLive after the upgrade. Whenever I clicked on the "Connect" tab I kept getting the Far Cry 5 advert and was trying to see how I could manually install ReLive. I ran DDU and reinstall the latest update and then when the installation finished I tried going into the Radeon Settings, but was met with the "Radeon settings version and Driver version do not match. Please try again after updating to latest version(s)" message. After running DDU, reinstalling the new update, and receiving the same message a few more times I rolled back to the previous driver (18.12.1) and everything is working fine.

Is there anyone else experiencing anything similar to this?

I have:

Windows 10 (64bit)

Radeon RX 580 OC 8GB

Radeon RX 590 OC 8GB

Crosshair Hero VI (WiFi)

Corsair 850i

GSkill Ripjaw DDR4 3600 16GB (2x8GB)

2 Replies

EDIT: Okay, so after I just turned on my computer and after I logged in I saw the "Radeon Update & Install" screen. I wanted to try installing the driver update without using DDU just to see what would happen and I was able to install the 2019 update without any problems. After my computer restarted, I noticed that the Radeon Settings was still pinned to my task bar. I opened it expecting to get the "Radeon Settings and Driver versions don't match" message, but it opened without the message popping up and Radeon ReLive was installed.

I'm guessing that if you use DDU before updating you're going to run into the Radeon Settings and Driver versions not matching and Radeon ReLive not installing. So, just keep the previous driver installed while you do the update. Like I said I'm only guessing since it worked like this for me.

As I stated in my main post, the driver I was previously using was 18.12.1 and since 18.12.2 was giving me problems after using DDU I rolled back.

A new version of DDU was released yesterday. Was that the version you used?