Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Adrenaline 21.3.1 Issue w/ Aorus FI27Q

I am experiencing an issue with the latest optional drivers,  21.3.1, where my monitor is not being recognized correctly.

The monitor does display an output, but there are a few caveats:

  • The resolution is stuck at 640x480
    • Cannot be changed in display settings
    • Can be overridden up to 1920x1080 w/i Adrenaline
  • Features like Freesync are not being recognized as supported

The previous drivers were cleaned with DDU in Safe Mode. This occurs with both my 5700XT and new 6700XT so I don't believe its a GPU hardware issue. The 5700XT works fine with all previous drivers. I suspect it has something to do with the monitor support (as noted in the known issues: "On a limited number of displays, the preferred desktop resolution in Windows® may change when the display is power cycled.", though my situation is slightly different than this exact scenario).

The monitor I am using is the Aorus FI27Q, 1440p, 165hz, Freesync Premium. The firmware was F03 but I upgraded the firmware to F05 and had the same result with 21.3.1. I've tried power cycling the monitor, replacing the DP cable, using different DP ports to no avail. I tested with a 4k TV via HDMI and it worked fine with no issues. 

Anyone else having similar issues?

4 Replies
Adept II

Ultrawide monitor users are not hit that severely, but we have issues too:

Could you please test 20.11.1 driver? That is the last driver that has no display issues for me.



Ryzen 7 5800X3D liquid cooled, Radeon RX 6800XT liquid cooled, Crosshair VIII Dark Hero, Dominator Platinum 64GB DDR4-4000, Force MP600 Pro XT 2TB, Force MP600 2TB, UltraGear 38GN950-B

Yes, I have the exact same monitor with the same firmware.

See my post here:

There are some serious trouble with the latest driver 21.3.1
Stay away from this update and I think AMD should revoke this from their website.

Best regards from Sweden.


Journeyman III

Ihave the same problem with the same monitor.

i bought Xfx Merc 319 6800 XT and installed the latest recommended driver. Then my monitor resoulution stucked at 640*480. I have tried almost everthing but i couldnt fix the problem.

when i installed the previous driver 20.11.2, everthing works fine! its not related to our monitor. its exactly happening because of the driver.

I have sent several bug reports, hope it will be fixed soon.

Journeyman III

Hey everyone reading this blog post later than November 2021,

I have had the exact same issue with my Aorus FI27Q since March 2021. The same update caused the same problems for me. Until today I stuck to Adrenaline 20.11.2 just as described above to avoid the issue.

However, I am happy to tell you, that Gigabyte has meanwhile published new firmware for the FI27Q.
I installed firmware F08 today. Now everything works like a charm with the latest AMD Radeon Version (21.11.1).

You can find the firmware here:

I hope, this will help everyone still struggling with the issue.

Best Regard,