Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Acer XR342CK constantly loses signal from Radeon RX 480 when connected through DisplayPort

I have this huge constant problem. I am posting this message on two forums: of the GPU and of the monitor manufacturer

For the longest time I was using MSI Radeon R7 370 4GB GAMING with my widescreen monitor Acer XR342CK bmijpphz on Windows 7 x64 without issues. But then in the summer of 2019 simultaneously both my video-card have failed and my operating system got corrupted. So I was forced to rework my machine. It is still the same monitor but now in conjunction with RX 480 GAMING X 8G on Windows 10. The motherboard [Asrock FM2A88X EXTREME6+] and the PSU [Seasonic Platinum-520FL Fanless (SS0P-520FL2 F3) 520W] and other components are still the same

Unfortunately the new setup has been working only with the "default" drivers, that were placed there by a technician who installed that Windows 10 from the scratch [I will be posting extensive data about those old drivers at the bottom]. And the problem went like this: after downloading directly from the AMD website AMD Graphics Driver 19.7.1 [Radeon Software Adrenalin 2019 Edition] and installing them, the monitor started to turn itself off. That is: after entering the Windows [thus past the User choice screen] the monitor displayed everything apparently A-OK, but after around 2-3 seconds everything always went black and my high end Acer monitor said that there was no signal. And then the monitor would start to scan the other ports [mini DP, HDMI 2.0, HDMI (MHL2.1)]- but after not finding signal through any of them [which was logical] it went back to the next one which was the DisplayPort [and that was also logical]. And by doing so the picture would come back, but once only for another brief moment. And then the whole cycle would start over infinitely: the screen went black and the monitor displayed an info about having no signal, the scanning begun, the picture came back when the scanning reached DisplayPort. But after restoring my operating system from an image, thus restoring previous drivers, the monitor was running smoothly as in the past

Back then in the summer of 2019 I also tried the AMD Radeon Software Crimson Edition 16.6.2 Driver For Windows 10 x64 16.6.2, but got the same negative results: the cycle of lost signal was happening. I also consulted the local helpdesk of AMD. They said that they were not entirely sure if they understood my problem correctly, but nevertheless they said that:

A] My PSU had enough power for that particular GPU card

B] I should re-install the drivers in a more thorough way: by using the Display Driver Uninstaller from the website - and then use the latest drivers that are available on the AMD site

C] I should make an update of the operating system to the latest build

D] I should make sure that the operating system is running in UEFI mode

E] I should update the BIOS of the motherboard

But as I had no time or energy to do that back then, I just continued to operate under the supposedly lesser drivers. But now I need to have them updated and he problem taken care off, because video editing software that I need to use apparently cannot even open itself because of inadequate AMD drivers [as it is a commonly reported theme in case of that video software]

And so now I tried once again installing the newest drivers. This time there were Adrenalin 2020 Edition 20.2.2 Recommended (WHQL) and later on also the win10-radeon-pro-software-enterprise-20.q1.1-feb14. As for compliance with those old helpdesk instructions

A] My PSU is still the same

B] These days I did use the newest Display Driver Uninstaller - version And did use it while running my Windows in a Safe Mode. And before that I also told the new drivers installers to remove the old ones

C] Back then I already had the newest Windows 10 version. And now I am running the new-newest: 1909

D] The system was and is still running in the recommended UEFI mode

E] The BIOS of the motherboard was and still is in its newest form: P4.20

And yet the end result are the same and repetitive as before. It goes like this:

The process of installation makes the picture go black few times as the progress bar goes further and further and the resolution changes. Also after the required reset the picture is still available, with some black screens
in between and maybe some artefacts / glitches. But the moment the installation is really finished, the cycle of losing and finding of the signal starts over [or maybe it starts a little before the end of installation but I am unable to take notice of it]. Resetting of the system does not help. But if I remove the drivers, the monitor stops losing the signal. And then I can once again install the drivers and once again end up with the monitor succumbing to that cycle of losing signal

As I have exhausted the
sensible and know to me AMD drivers approach, I started to close down processes in the Task Manager. But I only executed this on only few of them, those which had in their names some AMD / Radeon or video - because when my screen works only for a moment and then I have to wait for the picture to come back, then it is very time consuming and tiresome. And so I did not went thorough all those various processes in Task Manager that start with Service [like for example "Service Host: User Profile Service"]. But those that I did managed to close did not help at all; and I have also repeated this process later on

So then I went through all of the options available within my monitor, using its buttons [to see the picture thus the menu for the infinite time I had to evoke it when being in BIOS]. I tried switching DP Format from DP1.2 to DP1.1 but that did not help. The only ease up in this situation I got was when I changed the Auto Source option from ON to OFF- this made the cycle shorter, because the monitor after losing the signal was no longer going through all of the other ports but was looking for data coming in only in the DP slot. As for the other options, they have nothing to do with the signal / Display Port; or if they even somehow could make the monitor run on such faulty drivers, they would render the monitor a crippled device [as I am talking here about things like picture-in-picture and daisy-chain]. And so I did not explore them thus test them because it would only take even more time out of my life and in the best case scenario would only result in telling me what I know already: that a normal / fullscreen mode make the picture lose its signal after 2-3 seconds [when conjugated with certain software setup]

And I can add that I do not have other problems with what is being displayed. Although I do not play new / FPPs games, bot for example I do use a software that makes the movies when watched to have more frames then they are in the video file and I also use photo editing software extensively

So my question would be:

1] Have anyone experienced such signal / no-signal cycle with this particular video card

2] Have anyone experienced such
signal / no-signal cycle with this monitor, but when using other GPUs?

3] Does anyone have an idea what could be closed in the Task Manager to break that cycle [as apparently it is some soft component that is causing it]?

4] Does anyone have an idea what entry in the Services of the Windows 10 or maybe in its Task Scheduler can cause the monitor too apparently seek for the signal every 2-3 seconds in an unsuccessful way; and / or alternatively make the drivers / operating system lose the signal every 2-3 seconds?

5] What other drivers could I try out?

6] What other drivers removal tool I could try out?

Below is the setup that still works [the one that was created back then in summer of 2019, when my new operating system was installed along with the new GPU]

Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - Radeon (TM) RX 480 Graphics
Device ID - 67DF
Vendor ID - 1002
SubSystem ID - 3413
SubSystem Vendor ID - 1462
Revision ID - C7
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x16
BIOS Version -
BIOS Part Number - 113-V34111-F1
BIOS Date - 2016/07/19 23:05
Memory Size - 8192 MB
Memory Type - GDDR5
Memory Clock - 2000 MHz
Core Clock - 1303 MHz
Total Memory Bandwidth - 256 GByte/s
Memory Bit Rate - 8.00 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0002

Radeon Software Version - 17.1.1
Radeon Software Edition - Crimson ReLive
Graphics Chipset - Radeon (TM) RX 480 Graphics
Memory Size - 8192 MB
Memory Type - GDDR5
Core Clock - 1303 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 16 GB
CPU Type - AMD A10-7890K Radeon R7, 12 Compute Cores 4C+8G

Radeon Settings Version - 2017.0424.2119.36535
Driver Packaging Version - 17.10.1731-170424a2-313676E-WU-Template-1710
Provider - Advanced Micro Devices, Inc.
2D Driver Version -
Direct3D® Version -
OpenGL® Version -
OpenCL™ Version -
AMD Mantle Version -
AMD Mantle API Version - 102400
AMD Audio Driver Version -
Vulkan™ Driver Version - 1.5.0
Vulkan™ API Version - 1.0.39