Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

A lot of instalation events of high definition audio bus


I recently install the latest drivers for my RX480 18.10.1. Since then, High definition audio bus installations appear very frequently. Audio seems to be fine, no problems in game. Only the constants installations. Someone with the same problem?

  • AMD Graphics Card
    • RX480 XFX 8GB
  • Desktop
  • Windows 10 Pro
  • 18.10.1
  • Intel i5 7400


1 Solution
Adept I

I can confirm that the new driver 19.1.2 works. I do an upgrade from version 18.8.1 to 19.1.2. The old driver was uninstalled in safe mode using DDU. No more annoying new installation-events of the HDMI Audio Bus. Great!

View solution in original post

100 Replies

Too bad, this update just came out, and didn't fix it.


By the way my ticket was opened and closed, I don't think they are even

aware of the issue.

I hope I'm wrong though.

Adept I

Hello, I have also tried this problem and many solutions. Nothing helped. I did not try the old driver 18.5.x.

Has anyone tried to uncheck the HDMI audio driver when reinstalling?

I also reported the problem to AMD via Ticket and they replied that the engineers are aware of the problem and are working on a solution :-)


Yes I tried that, and didn't work

Adept I

Same issue with 18.12.1.

I have windows device driver updates blocked/disabled, have not had the issue on 1803, or now on 1809(installed 17th Nov.)

As a possible temp. workaround, anyone tried disabling the offending driver/s in device manager (one by one, trial & error basis).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Quite some time of this issue, no fix yet with newer drivers

Yes, the issue is still in the newest driver version

I have tested a little bit arround: 18.8.1 WHQL has not the issue, also 18.5.1.

The error came up with 18.9.x.

AMD-Support answered on my mail, that they know about the issue and working on it:

Support Mail from AMD, Date 28th November 2018

Response and Service Request History:

Thank you for the email.

I understand that you are noticing multiple installation of the AMD high definition audio after installing latest 18.11.2 driver.

I would like to inform that we have received the similar issue reported by other user and our engineering team currently investigating on it. 

I suggest you to please wait for the future driver release. I appreciate your patience and understanding regarding this.

Thanks for contacting AMD.

Somewhat annoying...

In addition to my previous posting, following possible work-arounds do not help:

- Deactivating the device in the device-manager (because after a reboot, die device is active again), - but also deacativating in the soundsettings did not help

- Uninstalling the driver and using the proper version do net help (because after a reboot, the driver from the driver-package will automactly install again)

- Deactivating Windows-Automatic-Driver-Update in the systemcontroll (devices and printers) do not help.


Welp, at least they are aware. I'm wondering if with 18.12.2 is still happening. Probably, because the release notes don't mention the issue

Adept II

Does the latest 18.12.3 fixed the issue or not?


I don't see anything in the release notes so I'm doubtful. I never heard

anything back on the second ticket they asked me to open.

Not sure we will be seeing a fix anytime soon.

No, sir, it does not.

Adept II

I just update the windows 10 to 1809 still with 18.11.1 driver without the ethernet cable plugged in and the problem seems to be solved. No notifications for restart no events in reliability monitor. I will update when windows update check for anything new.

Adept II

Nope problem is still there after windows update installations

This is my second case in a row that was closed by AMD without any update

or seemingly research into the issue. They never even reached out to me,

just closed the ticket. At this point AMD appears to be blatantly ignoring


Dear Customer,

Your update to Service Request SR#: 8200847298 was unsuccessful.

Since this Service Request has already been marked as closed, it will not

be possible to update it.

The problem here is that I'm still in 18.5.1 . That patch is from May, I think. And I want to play some recent games that I know that in subsequent patches have fixed some things.  I mean, it's been a long time

Adept I

Registered here just to say im experiencing this issue as well. Always two instances of it upon startup:

High Definition Audio Controller

High Definition Audio Bus

High Definition Audio Controller

High Definition Audio Bus

Pretty annoying and unnecessary. Why does it do this?

Several months now seems like AMD is not competent enough to resolve the issue. Sent in a ticket but they probably aren't going to do jack about it as many of you seem to only be let down by AMD..

My specs: Sapphire RX 580 4gb Nitro+, i5-8600K, MSI z370-a pro, windows 10 pro all windows (with all current updates), Radeon 18.12.2



same here. This bug is pretty annoying. Please fix it as soon as possible.

Even it affects me not as much as others (Driver is working, Sound through HDMI is ok on my monitor, but i use the onboard analog Sound on a 5.1-System), the persistent message of "reboot of the system is necessary" is annoying.

Many regards


Journeyman III


Go to the Device Manager and Double Click 'High Definition Audio Bus'. And update driver.

Version : version)

This version, is older than current 'High Definiton Audio Bus' Version, But is work properly!

If your system keeps these message, you should try execute DDU tool(safe mode) and restart. and you will enjoy 'No Annoying Message' System!

My PC Spec...

AMD 2700X

GIGABYTE B450 Aorus Elite

DDR4 8G(x2) 21300

Sapphire RX580 4G Pulse

I'm korean. And I'm not good in English. SORRY.

Nope didn't work out for me. It doesn't pop a message but windows install the 18.30.0 automatically check again the device manager

Adept II

The latest 19.1.1 driver is still bugged. I guess we have to live with that they will never fixed it and its not even mention as a known issue


I guess it’s because it’s a really random bug. Like I said, it happens only on my RX Vega64 rig, but not on my RX470 CFX rig or my R9 M280X Laptop.

Maybe it’s even only unique to a subset of cards even of the same family. I previously run Windows 10 1809 for a short time on another machine with a Vega card with the same drivers, and the issue didn’t happen. This time the machine was equipped with a Gigabyte Vega56. The machine exhibiting the symptom has an Asus Vega64.

Really frustrating.

Journeyman III

I have registered here to confirm, that I have been having this bug too. The Driver version from 1st May was working fine for me. Then I upgraded to the next suggested version from 1st October, I believe. Since then all subsequent versions show the High Definition Audio Bus reinstall message, including the latest 19.1.1.

I am using an Asus Strix Vega 64 in conjuction with a Ryzen 2700x. A friend of mine is having the same issue on a Sapphire Radeon RX 590. His CPU is a FX8350. Both systems are running on Windows 10.

It would be nice if AMD would at least acknowledge the issue in their known issues.

Has anyone recently raised a ticket for the issue? What was AMD's reply?

I've opened two tickets on this issue. Both were closed without any updates

or resolution. When I reached out for an update I was told: "The service

request has expired due to no updates."

This was after my first ticket expired due to no updates so they asked me

for specific information to include and still nothing was done. Not sure if

it was even looked at.

Second ticket was 8200847298, first ticket is somewhere else in this


this is what they said to me on Jan 8

Your service request : SR #{ticketno:[8200853666]} has been reviewed and updated.

Response and Service Request History:

Thank you for the email.

I understand that you are noticing multiple installation of the AMD high definition audio after installing latest 18.12.2 driver.

I would like to inform that we have received the similar issue reported by other user and our engineering team currently investigating on it.

I suggest you to please wait for the future driver release and rollback to previous driver version which worked for you without any issue. I appreciate your patience and understanding regarding this.

Thanks for contacting AMD.

In order to update this service request, please respond, leaving the service request reference intact.

Best regards,


AMD Global Customer Care

Problem is I think the problem was always persisting so I dont even know what version works fine.

Also I've tried using DDU and different drivers and DDU caused even more problems. I was longer able to smoothly alt+tab out of games instantly to other programs, there was now a black screen delayed of 3-5 seconds.


AMD support just closes it without answer.

Adept I

I am experiencing this issue as well. I started experiencing this issue when my system installed the Windows 10 update 1809 around 5 days ago. There is a delay when restarting Windows between when you see the logo screen with the swirling dots and the login screen. I assume the delay is due to it trying to reinstall the High Definition audio driver. I was getting the Windows notification constantly on 18.12.3. When I upgraded to 19.1.1 I still have the delay but I don't see the notification anymore.

It's frustrating not having my super fast restarts like before. I spend money on good SSDs for a reason...

Yeah I thought it was the 1809 update too, but I loaded up an image of my system pre-1809 and checked the reliability monitor and it shows the bus being updated every startup..


did you see the installation events on the reliability monitor?




Last restart on 8:38pm. Looks like I'm getting the notifications again.

Yes, this issue is very annoying



Why is this audio device there? I have the motherboards soundcard disabled. Looks like an AMD driver.

I will also investigate my spouse's PC. I don't believe it's experiencing the same issue. It hasn't been upgraded to Windows 1809. Both PCs are exactly the same except I have a Sapphire Nitro RX 580. The other PC is using a MSI Gaming X RX 480. I ended up getting the 580 because my 480 developed a strange issue. MSI sent me a new one so I have an extra lying around .

If it matters here are my specs:

CPU: 4790k

MB: Asus Maximus VII Hero

GPU: Sapphire Nitro RX 580 - 19.1.1 drivers (HD audio drivers are installed. Get issue either way. Does supply sound to my monitor if I want but never use it.)

RAM: 16GB Gskill 2400mhz

SC: Soundblaster Fatality (not sure this plays nice all the time with Windows 10, it's not a current card)


Re: 'Looks like an AMD driver'.

Not necessarily,

Do a file search of hdaudio.inf

Open the folder location of the corresponding file/s version(in your pic)

Open the file/s with Notepad

Looks like a Windows OS driver on mine, (I don't have the problem some others are experiencing).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Maybe i found a workaround for me, i will investigate today in the evening.

First thing to know is my configuration: I´ve got two monitors connected. The first with HDMI and a second (older) screen connected via DVI.

Since there was this mouse-lag problem (fixed with latest driver 19.1.1) when i got my second screen connected but in off-state, i´ve always powered on both screens. When i am playing games, i normally only need the main-screen. But i had to run both because of the mouselags...

Now, this is fixed, so i yesterday started my machine without powered-on second screen. And than i got no message regarding driver installation, reboot and so on...

I will give it a try today again. Even, after i power-on the second screen in running windows, there was no message. I think it´s only at boot-time, when both screens are connected and powered on.

Many regards



Interesting, I'm also in a dual-monitor setup connected via DisplayLink

cables. If the issue only occurs with both monitors powered on I would

imagine it wouldn't be very difficult for AMD to track down.

I can try to confirm this as well.


Hmm, don´t know why it didn´t occur yesterday, today, the driver installation is still there, without the powered on second display... grml... annoying like hell..

Adept I

Doesn't look like 19.1.2 fully fixes the issue yet either. Haven't seen the HD Audio notification but it's still taking longer to restart Windows just like before. Installation has been a bit wonky. Redid it a few times using DDU Haven't seen Radeon drivers do this before, it doesn't make you restart after installation this time.

I'm gonna use DDU to rip it off today and reinstall and I'll update you