cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

jcmlsn
Journeyman III
Journeyman III

8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

If you own a NUC "formerly" by the name of "Hades Canyon", you've most likely run into the same issue I have -- Graphics driver support is at rock bottom at the time of writing. Here's how to update to the very latest drivers AMD has to offer.

DISCLAIMER: I take no responsibility for damage to your hardware. You do this at your own risk. That being said, we want the latest and greatest, so moving on...

1. Download the latest "officially supported" software from AMD's website -- 20.4.1 -- and install normally --
https://www.amd.com/en/support/kb/release-notes/rn-rad-win-20-4-1

2. Download the latest Adrenalin software from AMD's website --
https://www.amd.com/en/support

... Choosing "Graphics", "Radeon™ RX Vega Series", "Radeon™ RX Vega Series", and "Radeon™ RX Vega 64". Click "Submit".
Expand your operating system, and under "Adrenalin 2020 Edition X.X.X Optional", click "Download*".

3. Deploy them as intended, by launching the executable, and unpacking them. By default, they will extract to "%SystemDrive%/AMD".

4. Manually update your Display Driver by launching "Device Manager" ("WinFlag" + "R", followed by "devmgmt.msc") and right-clicking "Display adapters > 'Radeon RX Vega M GH/GL'", followed by "Update driver".

5. Choose "Browse my computer for driver software", followed by "Let me pick from a list of available drivers on my computer".

6. Specify the location of the directory where the relevant *.inf files are located. --

In the field "Copy manufacturer's files from", input the full path to the drivers -- don't click "Browse..."! -- which should be the "WT6A_INF" folder, located, as an example, in "%SystemDrive%\AMD\Win10-Radeon-Software-Adrenalin-2020-Edition-X.X.X-XXX\Packages\Drivers\Display\WT6A_INF".

7. Once you've entered the correct path, click "OK", and a list will be populated with available drivers to use. Select the first "Radeon RX Vega" you can find in the list -- in my case there were two to choose from, so I picked the first one. It will prompt you a warning, click "Yes" to proceed.

8. Once installed, that's the driver done. You've successfully got the most recent updated driver configured on your computer. If you've no intention of using AMD's Adrenalin management software, and just want the most recent driver, and don't intend to overclock, you can stop here. Congrats! For everyone who wishes to proceed with the Adrenalin software...

9. Edit the registry value "HKEY_LOCAL_MACHINE\SOFTWARE\AMD\CN\DriverVersion" --

Adrenalin software support for "Radeon RX Vega M GH/GL" ended with version 20.4.1, which was available the first of April, 2019 -- and what now feels like an out-of-season April fool's joke.

Now, you can trick your installed Adrenalin software to work, with your most recent driver, by editing the registry key "DriverVersion" located in "HKEY_LOCAL_MACHINE\SOFTWARE\AMD\CN" -- you can access this with the "Registry Editor" ("WinFlag" + "R", followed by "regedit.exe")  -- this needs to match whatever driver version you're using.

You can find the driver version you've installed, by again going to "Device Manager", followed by your driver, which should now list as "Radeon RX Vega", right-clicking "Properties", and then under the "Driver" tab, finding your version listed. Once you've edited the registry key to this value, close the registry editor, and reboot your PC. AMD's Adrenalin software should now launch as normal.

8 Replies
mushroomchowmein
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Hi, thanks for the post. You mentioned that "Adrenalin software support for "Radeon RX Vega M GH/GL" ended with version 20.4.1", is that official? Or do you mean that the last update was provided then with the status of any future updates unknown? Could you clarify please. Thanks

0 Kudos
Nunatak
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Does not work. I get the message The best drivers for yor device are already installed...  when i check it still shoes the old driver....

0 Kudos
t020608
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

This works 100%. One thing to note though: After step 5, select "have disk" then proceed to step 6.

0 Kudos
tateconcepts
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

This seems to be causing an issue for me in Windows 1909 and same with 2004, 20H2 using Microsoft Flight Simulator 2020 and external GPU RX 5XXX/6XXX series graphics! Today, I can run the Vega 56 with the same driver however if I am attempt to follow this manually, I get various BSOD.

What are the thoughts AMD can and will deliver on their 5y update to this? I'd say we are due for another refresh and I'd like AMD to give me a reason to purchase a 6800 series card when I can't natively get the drivers supported to run both internal discrete and eGPU with Oculus hardware. This is most problematic and I feel AMD perhaps can take heart on those wanting to use their graphics.

0 Kudos
msrl
Adept I
Adept I

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Attached the new 21.2.1 version driver hacked by me.
https://drive.google.com/file/d/1bpIL7pSDms0coizjW4idzHy6PzgG6Suw/view?usp=sharing
Quick reminder how to install:
– Download the zip, unpack it.
– Go to windows settings, Updates & security, Recovery, Advanced startup, Restart now, Troubleshoot, Advanced options, Startup settings. When Windows Starts up choose option 7 (Disable driver signature enforcement).
– Go to the unzipped folder, run the Setup.exe.
– When prompted “driver is not signed” continue anyway.
– Error alert will appear at the installation end. it’s ok.
– Go to Device Manager (right click on the Start button – then “Manage”) – Display adapters – Readon Rx Vega.
– Open it – Driver tab, update driver, choose manually the folder of the driver under “I have disk” (…\Packages\Drivers\Display\WT6A_INF)
– Uncheck “Show compatible Hardware” and choose the first “Readon RX Vega” (NOT! Vega M GH…)
– Accept everything, restart.

Enjoy

AlexKeky
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Heya. Nice hack. But "config" dir in zip archive is clean and setup.exe doesn't run.. =(

Tags (1)
0 Kudos
Muyfa666
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Hi. I just tried this, but as AlexKeky commented, something is missing as the setup won't run. Can you re-upload the correct latest version please?
Tags (1)
Thomas-wx
Journeyman III
Journeyman III

Re: 8I7HNK/8I7HVK Hades Canyon "Radeon RX Vega M" Manual Driver Update Guide

Thanks for your work, but the setup didn't work either on my system.

0 Kudos