Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

7900xtx and pimax 8kx does not work, driver crash

2 days ago i got an XFX Radeon RX 7900XTX MERC310 Black Edition 2 and so far all the games i tried work and i see a very good performance in the games. ( example valheim, msflight simulator ect )
But when i turn on my pimax software  ( pitools or piclient/shop ) then the graphics card driver crash and freeze the screen every time. Only in rare cases can i get further than this.

After houres of testing and trying all kind of things i must admit i belive the problem is that he video card driver have a bug
related to VR and that is the only thing that will fix the problem.
I think the problem have something to do with the Displayport not sending the correct signal since the headset will not turn on the screen in the headset.  Before i had the 6900xt and the pimax software and vr headset worked, but with the 7900xtx it does not work at all.

Sometimes i have been able to provoke the headset and pimax software so i was able to get parts of the headset to work.
I can sometimes get into the software and make the headset track the base stations on the wall and i can also startup example a flight sim named dcs  world. I see on my monitor a split screen vr image that show what the vr headset should see, but there is just a black screen in the vr headset. Also if i move the headset fast and look around then the image cannot keep up and fall behind.  In other rare cases i have had an image in my vr headset that look perfect like it should be with an pimax logo in the
vr image in my headset.. But when i turn on example dcs world again then the image goes crazy and look in all directions very fast.

I am sorry to say so but the 7900xtx and the pimax 8kx does not work together.
The pimax code on the back of the headset read 1978. I cannot read the other numbers since theyr are worn out.
A guy on the pimax xr forum said that i have the 2075 version of the headset ( maybe )
I tried with the AMD driver 23.1.1 and 23.1.2  but both graphics drivers crash when i turn on pimax VR.
For though who do not need to use a pimax we need to turn on pimax/pitool software and after that steam vr takes over and it function like a htc vive vr headset.

I have no onboard graphics and i also tried to move the cables around ect. but no luck.. Its a VR driver related bug i think.

I have reported the bug to pimax ( who are on vacation now )  and AMD via the radeon report bug tool, and xfx who just said they also belive its a driver related bug.

cpu 5900x
32 gb ddr4 ram
windows 11 ( i even reset windows 11 and started with a 100% fresh formatted pc and new drivers ect )
2 x m.2 ssd
1x 7200 harddisk
1000w rog powersupply.

5 Replies
Journeyman III

Getting the same exact issue. Hoping for a fix soon


Adept I

I'm also waiting for a fix for the radeon 7900 series and pimax.

I would even try a "beta" driver if it could help to get it to work

Journeyman III

Im getting an issue with the Pimax 5K headset, that seems similar

Adept I

I have made a support request direct to amd to ask if theres any timeline for a fix.

If I get any information I'll update here

Adept I

Sadly no news

so gonna get something else that works