Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

7900 XT and Samsung QN90A hdr problem

QN90A + 7900 XT hdr not working

Sapphire Radeon 7900 XT + QE50QN90a (samsung 2021) tv - problem with getting HDR to work ( TV in game mode doesn't detect HDR). 


PC specs:

GPU: Sapphire radeon 7900xt ( latest driver, used ddu today).

CPU: RYZEN 9 5900x

Motherboard: MSI X470 Gaming pro plus

BIOS Version: 10/09/2021 A.K4

RAM: 32GB 4x 8GB G. Skill 3200

PSU: Sharkoon 750W gold

Case: Be quiet - silent base midi tower

Operating System & Version: tried on windows 10, atm at windows 11 pro 22H2

GPU Drivers: AMD Adrenaline software

Chipset Drivers: AMD X470 (Low-Power Promontory PROM28.A)

Background Applications: Constant aplications open: Logitech GHUB, adrenaline software, powertools, amd adrenaline software

TV software: 2111.1 ( T-NKM2DEUC-2111.1,BT-S).

HDMI 2.1 Certified cable (48gbps)

Ever since switching from Nvidia GPU to AMD GPU, i can't seem to get HDR working in gamemode on mentioned TV. Problem is affecting as it seems everyone with same setup or atleast lots of people. Sadly since not a lot of people use TV as their main monitor for PC, this problem is not known at all.

problem :
HDR on   + gaming mode OFF on tv = TV detects HDR on input signal without a problem, picture gamma is set to 2084 and picture settings recognise HDR.

HDR on + gaming mode ON + free sync premium pro ON = TV doesn't detect HDR, not even on input signal, not on gamemode bar, picture gamma hard locked to 2.2 or bt1886.

HDR on + gaming mode ON + free sync premium pro OFF = TV doesn't detect HDR, not even on input signal, not on gamemode bar, picture gamma hard locked to 2.2 or bt1886.


Sadly both AMD technical support and SAMSUNG technical support did not find the problem yet, and stopped replying.

What I have tried :

  • Tried getting hdr work on Windows 10 and Windows 11.

  • All my drivers are updated ( checked with iobit driver booster), updated motherboard bios drivers, chipset drivers.

  • Tried setting hdr off in windows, and only turning it on in game,

  • Tried setting hdr on in windows and only turning it off in game,

  • Tried using HDR in game and in windows

  • Did DDU and factory reinstall of AMD adrenaline software,

  • Saw on forums that CRU could help with this problem, followed steps and HDR still is not available on my TV game mode settings. I have also tried reverse method of getting free sync available on tv without gamemode, but sadly after reseting my drivers i cannot enable free sync option in my radeon adrenaline software.

  • Tried 4k, 3840x2160, 2560x1440 resolutions and HDR isn’t detected.

  • Tried turning on HDR without having GPU drivers installed
  • Tried setting between  10bpc, 8bpc color depth with combination of RGB 4:4:4, YCbCr 4:4:4, YCbCr: 4:2:2 pixel formats, but HDR does not get enabled.

  • checked that 10-bit pixel format is disabled in my advanced settings.

  • factory reset of TV, then i left it out of power for 30 minutes before turning it on ( suggested by samsung customer support in my country ).

  • Tried using another AMD GPU.

  • Different HDMI cable.

  • Tried linking PC -> Soundbar ( passtrough) -> TV (same problem).

  • Tried CRU method that is listed on the last link, sadly it doesn't work for me.

Links with same problem or similar ( one thing in common with all of them is  AMD GPU).

on the last link ( this is my post), one person was kind enough to go trough detailed guide using CRU with me, since this is "only" fix some people reported that it works. Sadly this fix does not work for me, on page 2 there is a You-Tube link that he posted, explaining why this happens and what to do, plus he shows that HDR gets working) ( link : ), so while i did exact same thing i couldn't get HDR to work. I've posted my own video showing that this fix did not fix HDR for me. ( link : ). Only difference that i noticed was that he is using AMD 6900XT GPU compared to me.

I think that this should be adressed, as gaming on expensive gaming stuff should be w/o a problems.  There is most deffinetly some problem with EDID .

Any help would be appreciated, i will update this thread as support continues, we might find a solution to this problem togother.

1 Reply
Adept I

RX6700XT ,TCL Q10H,Same problem