Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

5700 XT VSR does not work on HDMI/TV

I bought a Sapphire Pulse 5700 XT about a month ago. I have never gotten VSR working on my TV (HDMI, 1080p, 60hz). I can enable the VSR toggle in the Radeon Settings but neither Windows nor any video game show resolutions higher than native. It is as if the toggle does nothing.

What DOES work:

If I set windows to only use my second display, a monitor (Displayport, 1080p, 60hz), VSR works.

What DOES NOT work:

If I set Windows to extend my desktop, like I normally do, with my TV(HDMI) and monitor(Displayport).

If I set Windows to only use my TV(HDMI).

To be clear, I can always enable the VSR toggle on either display, but no game, nor windows, shows higher than native resolutions when trying to use my TV, extended or solely.

My previous video card, a 980 Ti, could do DSR just fine with my TV, extended or not, so it shouldn't be an issue.

Any workarounds or am I stuck until a driver fixes this?

Monitor showing higher resolutions:

Asus Monitor VSR.png

TV not showing higher resolutions even with VSR toggled on:

Panasonic TV VSR.png

6 Replies
Adept I

Re: 5700 XT VSR does not work on HDMI/TV

Same issue here on both adrenalin 2019 and 2020.

Not able to select higher resolutions than native res on my LG TV. Tried different games that support it

(it works correctly on my ancient samsung monitor connected hdmi>dvi)

VSR does enable (screen switches black for a second and it keeps being enabled afterwards)

- LG 47LM620S 1080p/60hz

- reference 5700

- deinstalled drivers with DDU. Tried fresh windows install as well

- versions tried: 19.11.3, 19.12.1. , 19.12.3

- tried disabling all features (such as GPU scaling) except VSR, tried different combinations

Seems to be a bug. Hinders me from playing older games that i want to play in full effect.

VSR can also be a workaround for the stuttering that still happens in older games (forcing gpu boost). 

Starting to regret my 5700 , considering switching over to a 2060 super , which will cost me 100 eur extra but will save time and headaches

Adept I

Re: 5700 XT VSR does not work on HDMI/TV

Tried connecting to both an active and passive displayport>hdmi adapter. Both failed (no vsr).

Seems to be a bug. Reported to AMD. 

Hoping this will be fixed soon

Adept I

Re: 5700 XT VSR does not work on HDMI/TV

20.1.1 did not fix it.

Journeyman III

Re: 5700 XT VSR does not work on HDMI/TV

Hi All,

I have very similar issue. In my case the VSR works on either my monitor or TV (connected via home theater system) or both but with option "Extend these displays" mode. When I use Windows / Display / "Duplicate these displays" it switches off (maximum available reslution is Full HD again). I want to be able to enjoy my audio from home theater system all the time and be able to use TV as my external monitor from time to time. Now it is not possible. It might be important to note that the monitor is 16:10 (1920:1200, DVI monitor input with adapter from DP GPU output) and TV is 16:9 (1920:1080, HDMI). The "duplicate" mode works properly in FullHD resolutions. VSR function was one of the stronger points why I have chosen AMD Radeon card. Did anybody solved this problem anyhow? Is support working on that? 

Adept I

Re: 5700 XT VSR does not work on HDMI/TV

Support asked me to install all kinds of drivers, even asked me to contact the monitor vendor (if its apparently a driver issue, why whould i need to contact the monitor vendor?)

20.1.3, 20.1.4, 20.2.1, and older versions did not fix the issue.

Support now forwarded it to the right department. I hope they didnt lay me off this way and actually start doing something about it. 

Nvidia DSR works fine on the TV by the way. Might swap over to RTX 2070 .

Adept I

Re: 5700 XT VSR does not work on HDMI/TV

My request with AMD got closed 'because i did

not respond in 10 days'

In reality 'they didnt respond'on my questiond and remark.

So yes i got laid off.

The fact that i had to install a bazilion amount of drivers to me conforms that this should work and its a bug.