Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

5700 XT hdmi sound drops cuts

Just installed/bought,  GIGABYTE Radeon RX 5700 XT 8G.

Installation is a clean windows 10.

Audio is cutting/dropping every x seconds for 1 second.

It is happing with all sounds (in movie/netflix/music)
Radeon drivers are on the latest package version 19.12.3

I am using the hdmi output. My MB is asus prime pro x570 running the latest bios v 1405.

As a test I lowered PCIe version to gen3 instead f gen 4, this did not solve the problem.
Any tips or hints? Else i will try to get a refund for this card.

33 Replies
Adept I

This is audio driver related issue. You can find a long conversation about this here: 

As far as i know, there is not any fix and we just need to wait the driver update.

Adept I

I did a windows 10 restore, removing all the apps, all the personal data.
after the installer finished i had a clean windows that recognized all the drivers but obviously lacking the vendor specific software tools.
I chose to not install those tools and it seems my sound is stable at the moment.

Sure i cannot tweak all the options in the AMD software but i can play games (only tested fallout 4 for now) without an issue and I have sound! 

Dolby atmos is also enabled and working (this is the main reason why i wanted to use hdmi for sound).
I invested in some nice AVR, atmos setup, kinda mandatory this works!

netflix 4k playback is not yet tested, but afraid to install the HEVC codec.

I guess I will wait for some stable driver/tools release in the future.

Adept I

I solved the audio cut out stuttering problem by using an older HDMI driver.
That's version

Included in Radeon ™ Software Adrenalin Edition 18.10.1

It is located in the package \ drivers \ audio \ hdmi \ WT64A folder.


Please overwrite the driver via manual update.

I have the same issue, and thank you rockmong I will try the older hdmi driver.

5700xt on win10 


Unfortunately I still have cut outs during whatever playback via hdmi... also with this older driver version.

I use a Denon X3600H as an AVR. Maybe an issue with Denon? 

Used a 2060 with a different PC on the same AVR and Screen and did not had any issues.

This is very frustrating...


Im use TV arc with Yamaha sound bar  first time i had same Hdmi audio issue too by using arc Hdmi cable 1.4 (low spec) and TV EDID setting 

I solved problem by an arc Hdmi cable change to 2.0 and TV arc Hdmi port setting EDID 1.4  change to 2.0 ( Each Hdmi port) 

Symptoms of equipment and driver problems are the same ( audio cut out )

I dont know about your AVR  

I hope this helps.

Sorry about my bad English


I FIXED the sound issues on my PC, it appears its caused by a discrepancy on HDMI-GPU and HDMI-AVR speeds.

i did the following:

1) access radeon software

2) "display" tab

3) Enable "HDMI Link assurance" (This matches HDMI-GPU speed to your HDMI-AVR)


I haven't had an issue ever since.


My short tests this solution works, even though not flawlessly - i'm still getting hickup but like once per 5-10 minutes.

BUT... this works for stereo only. The moment i switch to 5.1 sound and run something GPU intensive (Mechwarrior 5 in my test case), the stuttering returns after few minutes and it's allmost imposible to play. Just listening to youtube/music works fine.

So yes, HDMI Link Assurance seems to work if you run Stereo sound, but 5.1 behave as bad as without Link Assurance.


Are you using a HDCP 2.2 HDMI cable?

Journeyman III

I found a solution for my problem.

Its not yet clear to me what exactly made this work, but I´d like to share what I have done.

I have a Asrock Mainboard in this PC.

I changed the following settings in my BIOS.

PCIE1-4 Link Speed from "3x" to "Auto"

I guess only PCIE1 is actually making a difference here, as its the only one used. 

PCIE Native Control "disabled" to "enabled

PCIE ASPM Support "disabled" to "enabled

PCH PCIE ASPM Support "disabled" to "enabled

DMI ASPM Support "disabled" to "enabled

PCH DMI ASPM Support "disabled" to "enabled

As I said its not sure which setting actually does the job, I will follow up an test each setting and see if it breaks again, but I did not had any sound drops since this change. Does not matter if I listend to music or played a game.

I also changed the HDMI Cable to a shielded super duper version, but this did not do the job alone. After changing the cable I had audio drops as usual.

ASPM is Active State Power Management, perhaps this feature does have a different name in your BIOS.

HDMI Audio Driver
Radeon Driver 20.4.2

i7 7700, XFX 5700XT, Asrock z270m pro4 -> Denon AVR X3600H

BIOS Changes.jpg


I am also on 

HDMI Audio Driver
Radeon Driver 20.4.2

the problem still exists. I tried

BUT for me, when i leave sound settings in w10 on the dolby atmos output, it seems to run okay.

Whenever i change the output in windows to eg stereo, the droppings starts.

Sometimes the atmos software is not loaded correctly at boot, but a reboot always solves the issue.

Whenever i would prefer some other speaker output, i mix it on the AVR to eg stereo.

This is not perfect, but at least the sound does not drop every x seconds.

Hopefully this workaround can help others.


I got an update from AMD Support.

Dear Ben,

Your service request : SR #{ticketno:[8200969xxx]} has been reviewed and updated.

Response and Service Request History:

Thank you for the email.

Yes, we are aware of this issue and our driver team is currently working on it with top priority.

Thank you for contacting AMD.

Adept I

I registered here only to comment this post: it is 6 months I have an AMD card since I swapped from the "other company" and it is simply incredible that this hasn't been fixed yet.

I think you are aware of this issue since long time and instead of spending resources in making fancy interfaces for the driver control panel, you should fix basic functionality before.

Thank you.

Adept I

I have solved my HDMI audio issue by disabling 'Bitstream' input, instead setting 'PCM' in the TV side settings. Give it a try.


This could work if you sending the audio to a TV set where you will play with 2 speakers, but not with connections to an amplifier supposed to decode the 5.1 stream to feed the loudspeakers.


Yeah, no 5.1/7.1 PCM supported when I limited it to PCM mode on the TV side. only 2 channel PCM. It seems this limitation coming from either TV (more likely) or GPU or both though HDMI spec allows multichannel PCM.

Journeyman III

HDMI-HDMI connection to receiver has this problem... but easy resolution is to go DP-HDMI... takes care of issue completely.


Unfortunately i thought same, but even with active DP-HDMI cable problem persists. Time to return card and wait i guess.

Adept I

I FIXED the sound issues on my PC, it appears its caused by a discrepancy on HDMI-GPU and HDMI-AVR speeds.

i did the following:

1) access radeon software

2) "display" tab

3) Enable "HDMI Link assurance" (This matches HDMI-GPU speed to your HDMI-AVR)

I haven't had an issue ever since.

Adept I

I solved this problem by changing HDMI audio driver from AMD's to Windows 10 default.

1. Change HDMI audio driver to High Definition Audio Device

- Driver Provider : Microsoft

- Driver Date : 2019-03-18,

- Driver Version :10.0.18362.1

- Digital Signer : Microsoft Windows

- You can find this driver by choosing "Browse my computer~" and "pick from a list~".

2. Enable "HDMI Link assurance" in Radeon software.

3. Disable "Radeon Enhanced Sync" in Radeon software

4. Disable "Radeon Anti-Lag" in Radeon software

5. Disable "HDMI ULTRA HD Deep Color" in TV setting.

Every setting may not be necessary. So, I recommend you to try one by one.

My Hardware information is in below.

AMD Ryzen 7 3700X
AMD Radeon RX 5700XT (Sapphire Pulse)

Adept I

This is not a driver issue at all, this is a issue with the RX5700 chip.  Everyone using hdmi output for audio is having this issue with this card. AMD knows about this issue and it WAS listed as a known issue by AMD until it mysteriously dissipated without resolution. I speculated that it was removed because AMD does not want a mass of people returning their cards. Since my card has a 3 year warranty I will be returning it over and over until I either get my money back or a replacement that actually works. People say you can work around the issue with a displayport adapter but I do not see why I should have to go out an buy a special adapter when the 500 dollar card should work as advertised!

My system

MSI X370 sli plus

Ryzen 5 3600

32 gig kingston DDR4/3200 hyper X fury

MSI Radeon RX5700XT Mech OC

Onkyo HT-R398 5.1 dolby digital receiver

55" Samsung 4k UHD Curv Smart Tv

Journeyman III

This is the weirdest problem and I'm not sure it can't be fixed as some have said because some nights I can go all night without a drop out while other times it does it every couple of minutes and is annoying as hell. I have mine hooked to a Denon receiver by HDMI. I've tried many suggestions and thought the HDMI link assurance fixed the problem as it was perfect all night then the next time I listened to music it was doing it again. One time my windows sound was set to stereo and I switched it to 5.1 and it was good the rest of the night. Today I noticed it was skipping in 5.1 and I changed it to stereo and haven't had a drop out for a long time so maybe just changing that setting is fixing it for the current session somehow? I have no idea why that would be but maybe others can try it and see if it works and if so explain how simply changing the audio setup in windows could fix this issue? 


This is because there is a hard-coded issue with the chip that unless it is

under a certain amount of load it will cause the hdmi audio to drop. I

tested this theory by running a 3d mark while watching videos. During the

time the 3d mark was running there was zero audio drops. But as soon as 3d

mark ended it would start the audio drop.

I've read that as well but most of the time I'm actually playing a game while I listen to music so my video card is always under load in those scenarios and the sound still skips pretty regularly. I know it sounds weird but the only thing that seems to fix it is switching the windows audio configuration. I don't think it matters what it's set to, it seems that simply changing it resets something and the sound seems to work ok for that session.


I tried uninstalling the AMD hdmi audio and using the windows native hdmi audio driver however that also has audio drops for me and several others that thought it was a viable workaround only to have the issue pop up later. Also considering this issue is not brand specific aka msi, asus, sapphire, gigabyte etc.. all experience one common issue. Their Rx5700XT chips all have the audio drops and most if not all of these companies have their own card specific drivers. Given that commonality I can only think that it is a hardware issue with the 5700XT chip and not a software/driver issue.


I haven't tried that yet, that was going to be next. Going on 4 hours without a skip after simply changing from 5.1 to stereo lol...Not that stereo matters, as I said in the past I changed to 5.1 from stereo and also had no skips. 


In my experience the situation you described can be due to a software bug as well.


That could be the case however AMD has known about this issue for over a year now and had several new drivers since and none of the drivers has fix the issue. So either AMD is incompetent or it is something more then a driver/software issue I prefer to believe that it is something more then a driver/software issue.

Journeyman III

I have the fix for this problem. Go to sounds-playback-amd Hdmi- then go to update- Choose from this pc- and don't select amd hdmi. Instead select Microsoft HDMI in the list and update to that. Immediately for me all the sound cutting out business stopped. I did a lot of searching and this was the fix. My videos are perfect, gaming is perfect, everything is spot on. Hope it helps you guys. 


And thanks to all above for your efforts aswell. None worked for me except this fix that took me hours to work out. Thank you, and good gaming people ;)


I'll repost here too: There are 3 pseudo-solution for this appart from going team green.

- Download and activate the dolby (the free version) : downsides sound still drop but muting, unmute kinda work.
- Put load on the card, like light benchmark as an old furmark : downsides > fan noise, power consumption.

- Try to go DP to HDMI, either directly with a cable or with an active adaptor : downsides > sometimes sound get distorted with noise, Often after a wake up from sleep. Just press mute and unmute. Also you may have good sound only in 1920x1080, 720 will be distorted, under 800x600 : no sound over 1080p can get some cut, over 1440 no sound again

THANK AMD FOR THIS! I wonder how you can still have the HDMI compliance... 

This is not really a software bug, it's a driver/hardware bug, ' seems like AMD cannot find out how to cope with their DPC latency and ISR execution time.


I have found a very strange (and sub-optimal for most) solution to this audio dropping issue that has so far worked flawlessly for 2 days:

- Turn of HDR and Wide Color Gamut in windows 10

- Attached a second display via displayport and duplicate the display and your TV/projector (which is connected via HDMI)


I have no idea why this works but I've gone from skips/drops every 30 seconds for dolby digital plus content to none since doing the above. I searched so hard for "onkyo skips/drops audio" only to find out it's my GPU! I almost returned my receiver because of this!!

What a mess... At least I got the 5700xt on a really hot deal. 

Hope this helps some folks. I know losing HDR is a big bummer for those with nice TVs. I happen to be on a projector for which HDR looks worse, or at least no better than SDR.


Adept I

4 years and no fix.


5.1 and Denon, Marantz, Onkyo are really problematic for AMD cards.


Hope they come with a proper fix.