Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

23.8.2 software not working - cannot do clean install + cannot remove driver error 211

Installed the new version 23.8.2

Did a reboot as asked.

Surprise. Surprise. Software no longer loads, not works.

Trying to launch it manually :

The item referred to by this shortcut cannot be accessed. You may not have the appropriate permissions.

Trying to reinstall driver with clean install ? I can't. Because the geniuses at AMD made it so that checkbox cannot be clicked.

Trying to remove software to install it again ? No. Error 211.


So here I can. I can no longer remove not reinstall again.


Of all my machines, the ONLY one with NON STOP upgrade problems is the one with the Radeon graphic cards.

All other machines are using Nvidia cards. And in 8 years, I have NEVER EVER seen the crap, error messages and **bleep** the AMD software is giving me.


I swear to God I will never, ever buy AMD again.

6 Replies
Adept I

And it gets even better.

Tried to use the AMD software removal tool. Reboots the PC in safe mode. Nothing happens.

I reboot again, still in safe mode. Try to remove AMD software : error 211.


So. Your driver **bleep**ed up a Windows that has been working fine for 8 years.

I can no longer remove that piece of **bleep**. Can no longer upgrade it or reinstall.


AMD, if I am forced to reinstall that PC that has almost 8 Tb of data inside, and has been working fine for 8 years. I will make you pay for this.



Have you tried using DDU?

Too Many CPUs & GPUs to list...

What is the Make model of your new GPU?

Your complete system specs would be good to know too.

Too Many CPUs & GPUs to list...
Adept II

So, my recommendation in order to fix this issue would be, go download the latest version of DDU. Run it in Safe Mode, select the option to disable Windows Driver Updates, uninstall, restart out of Safe Mode. Then install the driver update.

In my experience this issue is caused by Windows thinking the OEM version of AMD drivers is newer/preferred over the freshly installed one. So after uninstalling, when you're installing the new drivers Windows interrupts/overwrites the new drivers mid install and then there's a mismatch and Catalyst doesn't work anymore.

DDU should uninstall these OEM drivers on a cleaning and you shouldn't have an issue when updating.

Adept III

Before installing the driver again, change this in Windows 11 /Settings!
Otherwise this stupid Win11 will overwrite your drivers again and again


Syste Driver overwrite - off.png

Ryzen7 5800X 4,95ghz; LLC3; 420mm Liquid Freezer2; Corsair RGB Pro SL 32gb/2 - 3600mhz CL18; Sapphire RX6800 Pulse OC; Asus XG27AQ 165Hz; MSI X570 Gaming Plus PPT:137W EDC:135A TDC:95A; BeQuiet! PP 730W

I tell on every threads just use 22.11.2 if possible.

MSI B550 Pro-VDH - MSI 6600XT - Ryzen 5600G