cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

E-vi
Journeyman III

23.11.1 Adrenalin | My microphone amd array is gone after updating AMD software

I recently updated my Adrenalin into 23.11.1 version and since this update my microphone is not detected in any app. Is not possible anymore for me to do somes vocals because my friends can't ear me. My mic driver is gone, I checked device manager but no mic driver is listed in audio inputs and outputs

28 Replies
ethon
Journeyman III

hello sir, just wondering would you mind providing the link to the driver booster that you used to update your mic? thank you in advance! 

Thank you so much for your advice! I was finaly able to fix it thanks to IObit Driver Booster

0 Likes

Sure, that sounds organic. lmao

0 Likes

muchisimas gracias es el mejor metodo 

 

0 Likes
SuperT702
Adept I

I have the issue too. Another issue I found is that changing the system volume no longer has an affect, you have to change the volume for individual apps from the volume mixer.

0 Likes
ValeyardTR
Journeyman III

I had the same problem. I solved the problem by installing old amd driver and software. I hope they fix it in new version.

Hp Victus Ryzen 5 5600 H with Radeon Graphics 

0 Likes
CodySlay
Adept I

For anyone facing the issues with missing microphone array and system volume not having effect (sound at 100% loudness) the device at fault is AMD Audio CoProcessor and an incorrect driver version applied to it after installing 23.11.1

No need to download any driver from doggy sources. The driver is already in your system, it just got replaced with another version by the installer.


To restore the previous working AMD Audio CoProcessor driver version:
1. Open Device manager.
2. Expand System Devices
3. Right Click on AMD Audio CoProcessor and select Update. 
4. On the update window select 'Search driver in computer' then chose 'Select from list of drivers in computer'
5. You'll see version 2.89.0.61 (2020) and some other (newer) version(s). Select the newer version and proceed.

It will asked to reboot the machine but the effect should apply immediately and your microphone and volume should start running right away. 

While you are at it you might also want to update AMD Audio Device from Audio, Video Controller group.

el metodo no me funciono, pero el de driver booster fue perfecto

0 Likes

Thanks a lot brother, it is working like a charm, Thanks again

0 Likes

Is there a way to manually obtain the correct driver? There are no drivers on my computer other than 2.89.0.61.

0 Likes

When I try this pc gives a blue screen, any idea what's happening? 

0 Likes


Uninstall the driver in safe mode.
To enter Safe Mode in Windows 10 and 11 hold the "shift" key on the keyboard, when clicking on "reboot" at shutdown (see details here)

see my reply to CodySlay s message for a detailed instruction of how to re-install the driver then

0 Likes

Lol I contacted both Microsoft and HP Support and they told me to factory reset, I almost cried lmao. Thanks for this, you're a lifesaver. But the problem is, whenever I try to install the latest driver I get a blue screen? It shows error code system_thread_exception_not_handled. What should I do? Please help.

0 Likes

I tried the solution.

After the update to the version provided with the 23.11.1 Adrenalin package, the mic was still not working.

Trying to install an older driver was impossible - because my Windows kept crashing when it tried to uninstall the driver for the AMD Audio CoProcessor.

Had to go to Safe Mode to uninstall the driver from Nov 2023 and date it back to an older version.
(I actually removed the whole 2023-11 Adrenalin driver package too)

To install the newer version, I followed the guide here at reddit

  1. download an old adrenalin-driver-package where the audio driver was still working fine (I used a driver from 2022-11)

  2. start the installation

  3. go to C:\AMD and search for the extracted driver package

  4. go to the subfolder packages\driver\

  5. copy the audio folder to a temporary location (e.g. simply C:\AMD\)

  6. Abort the installation of the old adrenaline driver package

  7. start the newest adrenaline driver installation

  8. find the extracted files for the installation in 
    C:\AMD\AMD-Software-Installer\Packages\Drivers

  9. delete the "audio" subfolder here.

  10. copy the "audio" folder from the temp dir to this location

  11. continue the installation of the driver

You will now have a 2023-11 graphics driver with an older driver for the whole audio system being installed.

__Thank you so much__ for this walkthrough! I have spent the entire day troubleshooting, uninstalling, reinstalling, finding old drivers, you name it... After 7 hours, this is what finally worked! 

Seriously... I am so effing grateful that I registered just to be able to say thank you.

Thank you!!!!!!!!!!!!

Cant find AMD Audio CoProcessor. My drivers are in Spanish. Wich one is it: 

exouster_0-1701791172389.png

 

 

0 Likes

Its sorted in the category "Sysmtem Devices"  [dispositivos del systema]   -  not in Audio Devices [... sonido...]

Ít has the Vendor ID 1022 and the device ID 15E2

see attached screenshot from  a german windowsScreenshot 2023-12-10 143651.png

0 Likes

Thanks so much! This fixed my onboard mic.

I have a Razer Blade 14.  For ages, I've had some "Radeon Software" provided by Razer that wouldn't launch, complained about not being the right version for my hardware.  I finally got around to uninstalling that version and grabbing the installer from AMD's site.  "Radeon Software" now launches correctly, but I went to make a video call and the mic wasn't hooked up.  The device was listed but trying to use it for anything came up as "unavailable".  I followed your instructions and switched both AMD Audio CoProcessor and "AMD Audio Device" (as CodySlay suggested) to the newest available version, then rebooted.  Mic works just like before.

0 Likes

Hello! I have a Razer Blade 14 (2021) as well and am experiencing the exact same issue. It somehow fixed itself a while ago, but now my microphone does not work again, which I find really frustrating. I followed both the instructions from @CodeSlay as well as @KasperX, but with no success. I'm wondering if I did something wrong, so some help would be much appreciated!

0 Likes

Have you tried to uninstall all Radeon Software and then installing an old driver where the mic was still working (e.g. 2022-11) ?

I am guessing you simply have an issue getting your windows to use the old driver - so a cleanup of the drivers [using https://www.amd.com/en/support/kb/faq/gpu-601 ]  and then installing an old version could prove this.

Once you have the old driver and the mic running, update to a recent version of the Adrenalin drivers. Just do not forget to replace the microphone drivers with the working one from the old package.

0 Likes

Just as a data point, until the day my mic broke I was using whatever was provided by Razer's own updater, or Windows Update, I never went out to AMD and specifically grabbed a standalone driver package.  Unfortunately, Razer doesn't really hand out a package of "stock" drivers on their website, at least that I've been able to find.  So I'm not sure exactly what driver Advik would be looking for to roll back to, at least if they were in a similar situation.

Yes, even when removing the drivers using AMD's Cleanup Utility and installing an old driver package from 2022-11 (https://www.amd.com/en/support/kb/release-notes/rn-rad-win-22-11-1 is the oldest I could find for the 5900HX), my microphone still does not work.

It it shown in applications, but does not record any sound. When attempting to record something using Windows' sound recorder, nothing happens for a few seconds and the program just crashes.

The device manager no longer shows the old driver (2.89.0.61) and when looking at the driver details in the AMD software (Settings > System > Hardware and drivers > Software and driver details), it says "Not available" for the AMD Audio driver version for some reason.

0 Likes

 

For the 5900HX this would be the website for the old driver versions.
Your link is broken - and maybe the wrong driver package?

Did you check on device and vendor id when installing the audio driver manually?
(see screenshot above)

0 Likes

The link was leading to the release notes of the driver I downloaded, I have no idea what broke it. But yeah, that's the site I got it from.

Weirdly enough, my microphone is working again since Tuesday, I am still not sure what exactly fixed it though or why it wasn't working right after installing the old driver. Also, the device and vendor IDs are the same as in the screenshot above. Thanks a lot for your help! 

0 Likes
Suittieflee2
Journeyman III

I've had the same issue with my internal microphone just dissapearing however following the instructions provided below helps fixes that issue until AMD resolves it.

0 Likes
scrammy
Journeyman III

That was the trick! Many thanks!

0 Likes
StefanUzunov897
Journeyman III

Hello! I found how to fix the microphone problem.

First: Go to Settings. After this go to sound and you will see ADVANCED, click on all sound devices, click on your microphone and you will see GENERAL click on Allow and youre ready! This will help you, because if its not showing on the device manager youre allowing the driver with this option!

Try it and Goodbye!

0 Likes