Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

22.3.1 Doom Eternal GPU won't downclock after playing. (Still happens on 22.3.2)

I don't know why that is. But after playing doom eternal the Clockrates remain "high" even after quitting the game (RX580). Only solution to this problem i've found is starting another game.
Is there a way to fix it by myself or do i have to wait for a driver updatE?

6 Replies

Can you try creating or adjusting a profile just for Doom inside adrenalin? 

I do have different clocks, voltages, settings and fan for each game. Maybe this way, when returning to windows it goes back to default.

The Englishman

Have you tried 22.3.2?


Yup issue remains.

Adept II

Similar problem: 

Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GR75Q-B QHD; Windows 11 Pro 23h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

Wow "wonderful" so they didn'T fix this stuff for months and don't even mentioning it in their "unfixed" page.

Community Manager

We have an existing discussion on this issue, please use that to track status updates and provide your feedback.