Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

21.5.2 problems plus rollback problems

Computer is a modified HP Pavilion TP01-0157c.  Erica motherboard; Ryzen 5 3400G APU.  12GB RAM, 256GB NVMe drive, 1 TB SATA HDD.  Modification consists of upgrade to HP OEM 400W PSU (L04618-800) and the addition of a Visiontek Radeon RX 560 4GB.  The GPU is bus-powered and the PSU provides more than the rated power requirement (yes, I checked).  Outputs via mini-Displayport.  Ryzen Master had been on the machine prior to the upgrade but is not doing anything; standard configuration.

Machine had worked fine until the 21.5.2 driver update last night.  Suddenly it can't recognize my monitor, sees it as a 640x480 generic PnP.  I used Windows control panel Apps/Features to remove the Radeon software in an attempt to redownload and reinstall last known good version.  Once I did that, the following happened:

[  ]  Web browsers will not "let go" of downloaded files.  I can't launch applications like the cleanup utility from Downloads because the browser won't complete the handoff of the completely-downloaded file to the file manager.  Browser hangs.  When I try to close the browser it deletes the file.

[  ]  I cannot launch the command line, either vanilla or Admin mode, from the Windows menu, the taskbar, or via Windows search.  So, no sfc or any utilities like that.

[  ]  I cannot open device manager.

[  ]  I cannot boot into safe mode; any of them.  F4, F5, etc. from cold start don't do anything.

[  ]  I cannot shut off or restart the machine from the Windows button.

[  ]  I cannot get into any of the Recovery options, launch Reset, or any of those other options from Control Panel or from shift-Restart.

Obviously this is frustrating.  I'm looking for advice on how to get my machine, which is 3 weeks old and worked perfectly prior to this, back into the same condition it was in before that disastrous driver update.

1 Reply
Journeyman III

Ended up solving this myself.  Booting with F11, F4 or F5 never ended up working.  Did another power-button long-press to turn the machine off; when I rebooted the machine I was able to get Shift+Restart working from the LOGIN screen/splash screen.  I'd never done that before but shockingly enough it worked.  Got into recovery tools and rolled back to a system restore point from before the driver update.

Now I just need to remember to never update Radeon drivers without 2 weeks of forum feedback reading first.