Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

2020 Radeon Software Transparent Window

I have a Radeon RX580 with a Ryzen 5 and MSI B450 mobo; I've tried installing the new 2020 Adrenalin Software, both 19.12.2 and 19.12.3. However, when I try to actually open the software the window just stays blurry and transparent and I'm unable to see any settings. Here is a screenshot of it I'm am able to move the window around and close it with the "X" so the program does not appear frozen. It appears to be display/driver related.

I am running Windows 10 1909 (OS Build 18363.535)

I've tried using DDU to completely uninstall the drivers before installing each version. I have also tried opening the task manager and disabling all startup programs without success. Does anyone have any other ideas?

5 Replies

I have this same problem too, but it happens randomly, especially if I had my system on for two long.

Adept I

Figured it out. It was Nahimic software. Once I unistalled that Adrenalin works like a charm.

Adept II

Same issue here with a 5700 XT. I think it occured already in 19.12.3, but it also occurs with the current recommended version, 20.1.3. I wasn't able to pinpoint yet from where it comes from. It seems like engineer_h4rr7‌ to be occuring after a certain (in-game?) time.

I filled a report by using the link in AMD Radeon Software directly with all the info. On a side note when i right clicked the task bar icon near the hour to open Radeon Software, it didn't open i had to open it from the start menu at first.

Some screenshots of the issue.

I temporarily fixed it by killing everything Radeon software related : Host Application & Radeon Settings: Host Service & Desktop Overlay. Killing "Radeon software: Host Application" only wasn't enough cf. try#2 in the screenshots.


What helped me figure out the issue for me (what other software was interfering) was to run the Windows Event Viewer Windows Logs and check for Application errors/hangs when I opened the Adrenalin software.

Journeyman III

Hi everyone, I had updated the driver of my RX 5700 on MSI B450 mobo from 19.something to Adrenalin 20.2.1. Quickly downgraded to 20.1.3 because I could not open games. And again down to 19.12.3 because i could not actually play the games. 19.12.3  allows me to open and play games, although my FPS get out of control on most games and my GPU heats up like never before. At least I can play..

But indeed, nowadays, the Radeon Software app cannot be opened after an hour or so of gaming. I get the exact same transparent window as denimore. I have to restart the desktop to open and config the Radeon software again

Have you guys received any update from AMD?