Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


20.3.1 Freesync broken in multiple games

Recently moved from 19.12.1 drivers to 20.3.1 and immediately noticed that freesync is not working properly in the new drivers. I have found that in about half of the games I run it works normally and in the other half it does not and causes consistent stutter. In some games it is micro stutter, in others it is more drastic but it is always consistent. Aside from the obvious stutter I've noticed some other things that are the same in all cases:

1. The refresh rate display in my monitor's OSD fluctuates wildly, instead of sitting around the game's current framerate like it does when freesync is working

2. In all cases, the behavior is fixed and freesync works normally if the "Disable fullcreen optimizations" box is checked in the game executable's properties window in windows.

It is important to note that none of this happens with the 19.12.1 drivers, freesync works normally in all these games. Here is a list of games I have tried:

Unigine Heaven - DX11
Unigine Heaven - DX9
Unigine Valley - DX11
Unigine Valley - DX9
Risen - DX9
Fallout 3 - DX9
Flatout 2 - DX9
Far Cry 3 - DX11
Left 4 Dead 2 - DX9
Two Worlds II - DX10
Serious Sam 2 - DX9

Path of Exile - DX11 while using VSR

Not Broken:
Unigine Heaven - OpenGL
Unigine Valley - OpenGL
Unigine Superposition - DX11
Unigine Superposition - OpenGL
Wreckfest - DX11
DOOM 2016 - Vulkan
Half-Life 2 - DX9
Civilization V - DX11
Pillars of Eternity - DX9
Serious Sam 3 BFE - DX9
The Talos Principle - DX11
Flatout 2 - Vulkan via DXVK

Path of Exile - DX11 native resolution

As you can see, it's a toss up as to whether it works properly or not, the older Serious Sam engine doesn't work, while the newer one does, meanwhile the older Source engine works while the newer one doesn't. The unigine demos work with some APIs and not others. Flatout 2 doesn't work but it does if you run it through DXVK.

Just to reiterate, this problem does not exist in 19.12.1, and "disable fullscreen optimizations" fixes the problem in 100% of cases. The problem is, disabling fullscreen optimizations opens you up to a host of very nasty driver bugs that cause BSODS.

3 Replies

Re: 20.3.1 Freesync broken in multiple games

Err I forgot to mention I'm using an RX 5700 reference card with latest windows 10. Have not tested any other cards.


Re: 20.3.1 Freesync broken in multiple games

Mount and Blade Bannerlord is another one where freesync is working correctly except when I use a VSR resolution. And in that case "disable fullscreen optimisations" fixes it.


Re: 20.3.1 Freesync broken in multiple games

Still an issue in 20.4.1. Looks like it only happens at VSR resolutions.

amdmatt‌ I'd be surprised if you couldn't reproduce this. Any of the listed games at a VSR resolution = broken freesync. Fixed by "disable fullscreen optimizations"