cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

vidko
Adept II

20.12.1 wrong display resolution after monitor wakeup

Hi!

I own an RX 5700 XT 50th Anniversary, connected via DisplayPort 1.4 cable to LG UltraGear 34GK950F-B.

Since I installed 20.12.1 drivers, I am having an issue, that whenever my monitor wakes up (I have set "Turn off display" to 15 minutes of inactivity in Windows power plan) it displays 1280x800 resolution instead of native 3440x1440. The only solution is to turn the monitor off via the switch and turn it back on, or to restart Windows, both very annoying:

image.png

I reverted to Adrenalin 12.11.3 which does not have the issue. Does anyone have the same issue with 20.12.1 or know how to fix it? Would be really appreciated. Thanks!

1 Reply
GreyMata
Adept I

Re: 20.12.1 wrong display resolution after monitor wakeup

I have the same monitor and the 5700XT Red Devil

Same issues as yourself on DP and not on HDMI, this is a driver issue I think as I can work fine on 20.9.1

I have tried rebuilds, clean driver installs, and nothing is working, if I use 20.9.1 and earlier it all works, if I use 20.11 or 20.12 then I get the resolution issue and I have to reboot or pull cables from the monitor and its annoying now.

I have tried all sorts and I can't get the issue to resolve on the latest driver.

If I lock the machine, the monitor will go to sleep after 5 mins, come back 20 mins later and I get the same resolution issue.

I will keep checking the thread in case you find a resolution for this, I have raised bug reports for months via the driver but every new one doesn't seem to resolve the issue :(

 

I've tried the usual with the enhanced sync off, the HDCP off etc in the overrides. Not sure what the issue is, wondering if there is a BIOS fix for the card but can't see anything on the Red Devil site for a newer BIOS.

 

UPDATE:

 

Grabbed the 20.12.1 drivers, turned off Freesync via the monitors OSD and turned off freesync in the AMD drivers and now it will wake sometimes without he resolution issue but you do get the black screen issue! Still have to turn the monitor off to sort it. Will stick on the 20.9.1 for the foreseeable I think and try again in a few months.

0 Likes