cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

johnny595
Journeyman III

19.5.2 Adrenelin is completely uninstallable in my machine

Hello there.

My RX580 8GB was running normally a few weeks back, playing every game smoothly and with Adrenalin support, until I installed a new game and, in an attempt to get the best experience, tried to update my driver.

Upon downloading 19.5.2, via the inbuilt Adrenalin updater, the installation stopped at 33%, and gave me a Blue Screen in Windows 10 with a sad face and a QR Code stating that the installation was unsuccessful.

I tried it again downloading directly from your website to no avail.

After that, I chose to stick around with my current (then working) version.

To do so, I had to go through 2 (very scary for a brand new PC) system restores and the Adrenalin that worked no longer opened.

Today, I was putting in a Freesync monitor, and had to solve the driver issue once and for all. I went to Windows Update to see if there was anything new, and apparently my Windows was not updated to 1903. Upon doing so, I thought "Maybe that was the problem". Nope, it wasn't. 19.5.2 broke my video card software once again and (after searching these forums) I took the task of deleting and doing a clean install using DDU (Display Driver Uninstaller).

Used DDU in no network Safemode, rebooted and attempted to install 19.5.2. Once again, it failed at 33%.

This update is destroying, not only my PC but also my patience and mental health. I do not understand what I am doing wrong here, since all those softwares should, either work automatically (such as Windows updates, like I have configured it) or do their job (like Adrenalin's software).

Right now, my PC seems to be running sluggish, with a longer boot time, and, after a last system restore, the video card is working, but attempting to open Radeon Settings gives me "Radeon Settings and Drive versions do not match. Please try again after updating to the next version". Well, driver version when going to Properties in Device Manager, shows me 24.20.11020.2. Def not close to anything I remember from installing...

Please. I came here after hours of research and multiple attempts, I do not understand what is wrong and why this is specifically happening to me. I am sorry if I missed on any of the "Must Reads" of postings here, I am just absolutely tired from this, and coming here was really a last resort.

Thanks in advance.

________________

System Specs (nothing overclocked):

CPU: Ryzen 3 2200G

GPU: Gigabyte Radeon RX 580 8GB

Motherboard: A320M-S2H-CF

RAM: 2x8GB Corsair Vengeance LPX 2666Mhz

HDD: 2TB

0 Likes
1 Reply
johnny595
Journeyman III

Re: 19.5.2 Adrenelin is completely uninstallable in my machine

I still have no answer here, please, anyone! Now No Man's Sky just recieved an update, and the game became completely unplayable on my end due to this problem.

0 Likes