Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

19.2.3 driver fails with Vega 3 with W10 LTSB 2016


I have some serious issues since day 1 - last October - when I baught my laptop:

Acer Aspire 3 (A315-41-R5H9): Ryzen 2200U, 4GB DDR4 (at 2400), 1 TB HDD + 128 GB M.2 SSD.

Then, I freshly installed a legal Win10 LTSB which was available for me. Driver update was a horrible mess, the system said generic Microsoft videocard, applying a monitor through HDMI instantly crashed the system, not a singe benchmark or relevant game started. Driver update was not possible, I had to install a forced Catalyst Control, after that, some drivers could be istalled and freshed, but it not solved the problem, mirroring display still was not possible, games ran at disappointing frame rates.

Then a few days ago (2/26/2019) I installed the recent 19.2.3 driver, which resulted in major improvements: dual display, extreme performance gains in certain games (GTA IV), BUT!

Since then, Windows 10 instantly crashes immediately after I click shut down or restart, every time, with a buzz, with blank screen and with a gradually increasing fan speed...

The older drivers are not stable, the most recent one is not stable, now what to do?

Can it be that they not optimized the drivers for W10 LTSB (2016)?

5 Replies

The current drivers are designed for the current release of the operating system which is 1809. You also chose to load an operating system on hardware that is older than the hardwares requirements. I don't doubt you had issues and current stability. Is this a computer from your employer? Usually only corporations run the LTSB versions. If you never had stability with your product, I highly recommend you work that out with your devices maker. Before contacting them you might just try restoring that device to factory settings. Typically you have a partition with all the original OS that will allow you to do that. Then fully update that OS to 1809 and then feel free to load the latest drivers from ACER for your device. The Vanilla drivers from AMD may or may not work on your device properly, as OEMs often change their devices from reference designs the AMD drivers are optimized for. AMD has no idea what changes ACER made to THEIR product thus may not work with it properly. With laptops it is always recommended to get drivers from the laptops maker. If you have to run that LTSB version then speak to the entity requiring you to do so for support suggestions. 

Thx for the fast reply!

I assume also that my  - at least for me new - W10 can be responsible for the troubles. But because my laptop is my first AMD and my first Acer product ever, I cannot exclude other possibilities, I have nothing to compare with. This operating system still gets security and stability updates, but not fancy / convenience ones (or bloatwares). This considered to be the most stable version of W10, that is why I chose it. I got it from the university's server where I've been working, it is activated and fully updated. Not my employer provided my PC for me, I've bought it myself, because my office PC is useless (P4, 1GB DDR1, Win XP, yes, in 2019!). I purchased my notebook without OS, so I cannot determine whether it has some problems itself, it immediately got the W10 LTSB by me. So that is why I said I have problems with the system, and I cannot be sure about the cause.

Maybe I should try a newer version of W10, but I really like the LTSB, it should be the default Windows, it is fast, responsive, without any unnecessary programs and functions. (Like a vanilla Android compared to vendor UIs).

I've tried all sources of drivers so far, both from AMD and from Acer (Care Center), as well as from other sources like Driver Booster...

AMD have just reclaimed driver support from OEMs with this 19.2.3 update, this is why I'm disappointed, I had a lot of trust in them. I like the company, I support the underdog, but I also expect professionalism from them...

I find 1809 to be great. Yes the last 3 were not as good. Not the case now, for me. We have migrated over 200 computers at my company to 1809 now. So yes we have a lot of faith in it at this point. From a personal gamer standpoint it is much better too. Just make sure to disable all the Windows gaming functions.

AMD is first didn't offer the driver to models that were differing from reference design. This is because in the past people have big issues with this. It isn't AMD's fault the OEMS don't follow the reference specs. So because people are complaining that OEMS aren't updating their drivers to be current with the new updates AMD brings out, AMD is getting the blame for that. So then they now offer the Vanilla drivers again that then don't work on some laptops. Vicious cycle I know but blame that OEMS, it's their fault not AMDs. And trust me I have no issue blaming AMD for the stuff that is their fault. There is plenty of it too!

You might reach out to the IT department of your university for help too.


Meanwhile I had the opportunity to test newer drivers on Ryzen 5 2400G Desktop CPU and Windows 10 Enterprise LTSB 2016.

Turns out most drivers newer than 18.7 hard locks the system when trying to shutdown. Previous drivers work fine. You can restart, but you can't shut down.

Something broke in the newer drivers, that made them completely unusable on slightly older windows. I wouldn't have expected such kind of behaviour, since those chips were supposed to support windows 10.


The same happens with Vega64 on LTSB 2016. My Lenovo E585 has the same issue on Ryzen 2500u/Vega8. The old Lenovo driver works, except it has graphical glitches on fullscreen video in dual monitor setup. I will check later if it is the same case for R9 290x which clearly should have no issues. From what i have seen, most newer drivers than 17.7 were built to require the creators update to run. The 19.2 drivers were the first, that could actually be installed on LTSB 2016 besides the initial drivers, which Lenovo has pulled from their site by now. Switching to a different version of windows 10 would be no option, as that would conflict with security constraints that i have for my machine.

Update: The Vega 64 started behaving at some point. No Idea what happened there. Still, I cant simply change my System to something other than LTSB 2016, since this is my work machine and this OS has been choosen for a reason that doesn't allow using 1809. Since Lenovo is no longer supplying drivers that work on LTSB 2016, I am dependent on alternative drivers by AMD that don't hang the machine in specific situations. If someone here wants to analyze the issue, i could provide crash dumps.