cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

johnnyzee
Adept I

18.x.x driver reporting that the RX570 is a RX580

Hi,

I'm using a Sapphire Nitro+ RX 570 and when I install the latest series (18.x.x) of drivers on my windows 10 system, the Adrenaline software reports that I'm using  a RX 580 which is not correct. The driver (17.1.x) works fine and it reports it properly as a RX570.

In my testing, I have found that when using the 18.x.x driver and it's reporting that it's a RX580, when I plug my MSI 144Hz Freesync monitor with Displayport I get mouse and keyboard lag. Also the the system will not power down, and overall system strangeness.

When I use the 17.1.x driver everything is fine and works properly. To me it seems like a timing issue with the DP because the monitor thinks its a RX580 and not a RX570.

What is needed that the latest drivers to identify the the RX570 as a RX570 and my problems will go away.

Please let me know if you know about this issue or are looking into.

John

Message was edited by: John Zanettos

0 Likes
14 Replies
joecrow
Elite

Just wanted to say that I am using an RX 570 (a Gigabyte version) with Win 10 pro (1803) and driver 18.7.1 and it is correctly identified in the Radeon Settings (see screenshot).

0 Likes

Thanks for that. I will try again, but not holding my breath.

0 Likes

Here are my findings...

Each screenshot i18.x.x.pngs titled with the version number...17.x.x.png

0 Likes
kingfish
Volunteer Moderator

0 Likes

I tried everything you suggested and still the latest driver sees it as an RX580.

There is a fundamental issue with the driver to do that.

I should not need to go through hoops just to get the worlds most stable drivers to work.

I am truly ashamed to see the Radeon team which I used to work for back in the ATI days miss such a simple bug. Totally fustrating!

John

0 Likes
johnnyzee
Adept I

It has been over a week and no response to my post!

It's frustrating that I have done all this troubleshooting to identify a bug that should of been caught by the development team. Also with my post being ignored this long is very troublesome!

AMD please respond to this post!!!!

0 Likes
kingfish
Volunteer Moderator

They are not going to respond to this post...as noted in the AMD Support Forums - Rules & Regulations & Terms of Membership  this is a user to user support forum.

If you wish to contact AMD driver support, there are several ways to do it. And be prepared to show them where the 'wrong' identifier makes your graphics card not work correctly.

Email Form

Thanks for letting me know! I just submitted a problem report!

Hi, have you found any fix for it, I jus bought and Rx 570 and it has the same problem you describe with the latest driver, I can't find anywhere to get a 17 driver version

0 Likes
heavysmok
Adept I

Same problem here. Sapphire nitro+ 570 4GB.

A solution.

Right click on video adapter,update drivers. Then from this PC.

2018-12-04-144743 — imgbb.com

Then click the 570 and install

2018-12-04-144823 — imgbb.com

Result:2018-12-04-145307 — imgbb.com

Thank a lot, that fixed the issue

0 Likes

I'm glad to help you

0 Likes
stulla
Journeyman III

Worked perfect for me. But after latest update there still is this bug that everything is stoping for 1 second every 4 seconds, it stops after i power on my tv that is connected to second hdmi port set for screen duplication. (rx570nitro plus 8gb)

0 Likes

Try the new drivers 18.12.2, they have some new features and finally the problem with 570 as 580 it's solved without need the solution i posted here (at least for me).

0 Likes