cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

wiak
Adept II
Adept II

Re: 18.8.1 Driver issues (no drivers installed)

have you tried force install the driver ini file?

0 Kudos
sayasukasusu
Journeyman III
Journeyman III

Re: 18.8.1 Driver issues (no drivers installed)

Hey guys, I've recently fixed this problem and this seems like the most appropriate place for me to post my findings.

OS: Windows 10 Home 64-bit

GPU: AMD RX 580

I found that when installing the drivers from the radeon settings application, I would get that error message in the device manager telling me that there was an issue verifying the digital signature of the device, however, when I installed them from the amd website:

https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-580

the problem was then solved and there was no error in the device manager and I was able to open Radeon settings.

When it checks your version just make sure to choose the option to use the local 18.8.1 drivers that you just downloaded off the site and everything should work fine as it did for me.

TL;DR: Go to the AMD Driver Support site and install the 18.8.1 update from there, don't bother trying to download it from the Radeon Settings application.

I hope everything works for you the same as it did for me.

pokester
Esteemed Contributor III

Re: 18.8.1 Driver issues (no drivers installed)

I never let Radeon Setting update my drivers. I have had horrible luck with this myself. I am glad you figured out to download the installer and do it that way.