cancel
Showing results for 
Search instead for 
Did you mean: 

Discussions

Highlighted
Challenger
Challenger

Proof of stock settings degrading 3rd Gen Ryzen performance

About a year ago (beginning of August 2019), not long after Third Gen Ryzen was released I bought the hardware my friend in Sweden needed to build his new computer.

I had a spare Gen 2 512 GB NVME M.2, a 512 GB SSD, an 8 TB HD drive and a Noctua NH-U9S Cooler which I could give him, and so it made sense to buy the rest of the hardware here in the UK where it was cheaper, and to configure everything for him and then to send it off to Sweden.

I bought the Ryzen 5 3600X, GigaByte AURUS X470 Gaming 7 WiFi Rev 1.1 and 16 GB of Team Group Edition 3600 CL16 RAM, which of course he paid for.

This was the same hardware I bought for myself at the time.

The case he got (also the same as mine) was the Phanteks Evolv X and the PSU he bought was an EVGA 650W SuperNova Gold, and he managed to get a great deal on an Nvidia 1080 Ti graphics card.

I already had the identical configuration and had already experimented with my own 3600X and had discovered the basics of how to properly configure the 3rd Gen Ryzen CPU which I outline in my guide Updating my definitive guide to configuring the Ryzen 3900X/3950X and all other 3000 Series CPUs 

I had found that just leaving the system at stock settings and only configuring the CPU and RAM in Ryzen Master to give the best results.

I installed and configured the system with Windows 10 Enterprise and Ryzen Master.

As it turns out, he forgot what I told him about having to load Ryzen Master every time he booted and to apply the profile I had created; so since he has had the system (from September 2019) he has just booted into the bog-standard, out of the box, stock settings.

I can't really blame him for forgetting, because it was a huge adventure for him to build his very first PC which I talked him through, and I failed to re-emphasise the necessity for loading Ryzen Master and applying the profile.

Fast forward to yesterday, where I was talking him through upgrading his BIOS to the latest version and installing the newest Ryzen Master and configuring it (which I did via TeamViewer).

When I configured the profile for Ryzen Master again, and tested it, the system would not run AT ALL with the settings which had previously been rock solid steady and stable, namely 4.225 GHz all-core at a maximum of 1.3 Volts, when running CineBench R20.

Before I sent him the configured system last year I tested it VERY extensively. The reason for this was that I had every intention of buying the 3950X when it came out (and also the GigaByte AURUS X570 XTREME when I could get it for a good price - which I did), and so, if his CPU was not as good as the 3600X I had (Silicon Lottery is a thing) I would just swap them.

His CPU was no better or worse than the one I had.

His system is now only capable of completing a CineBench R20 run at 4.175 GHz at 1.3 Volts, even punting the voltage up to 1.325 Volts will not make the system run at the 4.225 GHz it ran comfortably at when I originally configured it.

When I say, that it does not run at all, I mean that setting it to 4.225 GHz at 1.3 Volts results in an immediate hard crash, not even a BSOD. It will not even run at 4.2 GHz at 1.3 Volts - although the results there are a bit better, only resulting in CineBench terminating or a BSOD.

At 4.2 GHz it will however run if I put the voltage up to 1.325.

This is a clear indication that the CPU has degraded over the period of less than a year (September to July).

Of course I said to my friend that he could have my 3600X in exchange for his, because I only need the CPU as a backup in case anything happens with my 3950X and I need to RMA it.

I know that some of you reading this will try to hand-wave this away with the comment "Purely anecdotal"; however, considering that I EXTENSIVELY TESTED the CPU with the Ryzen Master settings for about a week, and in all that time it ran perfectly stable at 4.225 GHz at 1.3 Volts (even below that voltage, looking back at some of the screenshots I made of the performance) before I sent it to him, the fact of the degradation of the CPU is anything but trivial.

To run it now at 4.175 at 1.3 Volts I had to raise the LLC to "High" in the BIOS because that was the only way that CineBench R20 would run stably without crashing. The LLC had been set to stock "Auto", i.e. the lowest setting, before.

Without adjusting the LLC the highest it will run is 4.15 GHz all-core at 1.3 Volts.

This proves that the statements I made last year with regard to my consideration that the voltages AMD considered safe to apply to the CPU were idiotic and would result in the degradation of the Ryzen 3rd Gen CPUs over time. It was the reason why I looked around for an alternative way to configure a Ryzen 3rd Gen CPU in the first place.

29 Replies
Highlighted
Adept III
Adept III

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

You have an updated BIOS which might have changed the board voltage offset. This could be a reasson why the previous OC isnt stable anymore. Some early board appear to have a huge offset, and settings 1.3 might even push 1.375 or more to the CPU. You are pushing an all-core OC right?

As a rule of thumb, i never do OC's on systems that arent mine. But that doesnt help your situation.. updates in cinebench can even be the cause as changes in powerprofiles of pwm from within windows. 

On the LLC topic... Loadline calibration with have the board try and compensate for the powerdraw of the CPU. You having to push it higher means the CPU is using more power at a certain moment, which drops voltages as VRMs are trying to keep up. My experiences are that LLC is used when jou push a high OC, to compensate for huge out of spec swings in powerdraw and the inablity of the voltage controller to respond at that instant. Try the CPU in your board to rule out VRM issues, if you can get up to the old OC on yours it might be a board or PSU issue. On the voltage test with 1.35 max as offset might take it upto 1.425 even.

I've heard of degeneration on both Intel and AMD cpu's when pushing high voltages, and i know its a hot topic for extreme OC's pushing around 1.4v  or even more, but all degenerations of which i read are 1.4v+ for extended periods of time. 

What temps are you getting? And have you tried undervolting a bit? Also dont use cinebench20 as a stability test, use prime95. LLC shouldnt change, because its the board that sends more power as voltage droops under high load.

CPU capitance shouldnt change.

0 Kudos
Highlighted
Challenger
Challenger

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

If you read the guide I linked to then you will see that I set a MAXIMUM voltage in Ryzen Master. Once that is set, checking with HWInfo (Vcore SVI2) shows that it does not exceed that maximum.

In my guide I am NOT going outside of spec, and I am NOT "pushing an all-core OC" in the guide. I am not overclocking, I am within the spec for voltage and for the power envelope. All I am doing is optimising the clockspeed for the maximum voltage I have set.

I spoke in the article above ABOUT THE CPU RUNNING AT STOCK - NO OVERCLOCK! It's in the TITLE OF THE THREAD for God's sakes.

Where do you get the idea that I am talking about overclocking??

You might want to take a look at the following video from Buildzoid (Actually Hardcore Overclocking) to inform yourself a bit better about LLC:

I am also very much aware of the difference between SET and GET voltages with regard to the CPU.

The early CPUs from the 3600 to the 3800X were garbage silicon and just last week I configured (notice the word CONFIGURED and not OVERCLOCKED) a new 3600 and had a stable clockspeed of 4.3 GHz at 1.3 Volts MAXIMUM.

What this means is that under no circumstances can the CPU get more than 1.3 Volts, it CANNOT be fed anything above that voltage the way I configure it.

This is measured by and regulated by the internal sensor of the CPU itself (Vcore SVI2) and accounts for any VRM inefficiency. The X470 motherboard I chose for my friend, and for myself, had one of the best if not the best VRM of the X470 generation of mobos (true 10 Phase controlled by an IR35201 in a 5+2 configuration with IR3599 doublers and the 10 MOSFETs are the 40 Amp IR3553).

At stock the AMD 3rd Gen will feed up to 1.5 Volts into the CPU with a single core load and under an all core load, such as CineBench it will still punt in around 1.375 Volts or more, which is bloody ridiculous and caused me to find out how to mitigate this behaviour - and those are GET values!

The Tech Media and nearly all Tech YouTubers have been either too stupid, or too lazy, to learn how to configure 3rd Gen Ryzen correctly and I have been calling them out for this for many months now, and it seems to be finally bearing fruit.

In his latest video about the 3800XT JayzTwoCents plagiarized my work in this video and didn't even have the decency to give me any credit. This was after I had repeatedly called him out in his previous videos for his ignorance (wilful or not).

JayzTwoCents like you, does not know the meaning of the term "Overclcock". What this term means is that you set a clock and then you have to go above the specification of the CPU in terms of Voltage and Power (Amperage) to achieve that clockspeed.

Configuring on the other hand means that you fix the parameters within spec and then see how much clockspeed can be achieved stably within those parameters.

The "Over" in "Overclocking" is short for "Over specification" and the whole term is "Over Specification Clocking" or "Overclocking".

CineBench R20 is a perfectly good tool to use to test the stability of a system.

You prattle on about Prime95; but which version, what parameters, what are you actually wanting to test with the parameters?

The thing is that when I use words, I know what they mean.

All you have done is throw in some buzzwords which you obviously barely comprehend, to criticise points in my post THAT I WAS NOT EVEN MAKING!

0 Kudos
Highlighted
Adept III
Adept III

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

Lol, cool down a bit.. 

You stated that you got to 4.15Ghz all-core which is unlikely looking at boosting behaviour of 3th-gen. 

None i didnt read the link to the guide you posted, because of the bios-upgrade my mind went to the voltage offset some motherboard makers apply   

You dont know me, obviously, and i had no intention to explain LLC in detail. 

Prime95 smallfft, as it is a more stable and demanding load generator. I mentioned it once, as a better stress-tool.

But good luck, and bye

Highlighted
Challenger
Challenger

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

You want me to tell you about Prime95 running small FFTs (not smallest) on a Ryzen 5 3600 with an air cooler which I have configured running for not one hour, not two hours, but over three hours and want to see a screenshot?

So what clockspeed do you think this could be accomplished at?

3.6 GHz?

3.5 GHz?

2 GHz?

LOL, only if you never actually started the benchmark?

Well let's just look and see shall we?

prime95_4125_3hrs.PNG

0 Kudos
Highlighted
Esteemed Contributor III

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

RE: The "Over" in "Overclocking" is short for "Over specification" and the whole term is "Over Specification Clocking" or "Overclocking".

Seek help.

0 Kudos
Highlighted
Challenger
Challenger

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

My first ever overspec clocking (overclock) was with my Intel 8088 going from 4.77 MHz to the dizzying heights of 6 MHz.

I sense the Dunning-Kruger is strong within you.

0 Kudos
Highlighted
Exemplar
Exemplar

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

It does seem like the semantics are tripping people up here.  And overclock literally is just raising the clock speed above specification, which by itself will not alter component longevity if not accompanied by a voltage increase.  You do not necessarily have to raise the voltage to overclock, but most users do as the gains are otherwise limited.

Regardless, the matter at hand is a chip that is less performant now, than it was 10 months prior when set at 1.3V.  The chip was run at the stock boosting settings for those 10 months.  While interesting to be sure it does not "prove" anything.

"This is a clear indication that the CPU has degraded over the period of less than a year (September to July)."

Well, it is an indication that something has changed, but is it the CPU or the motherboard?  What you would need is a different CPU, that you also tested within that exact same motherboard that was never run under stock settings.  If that CPU is still equally as performant as it has always been, that would put the blame on the CPU.  And again, is it the voltages used or a manufacturing defect inside that particular CPU?  With an n of 1 and no control any conclusion would be incredibly difficult to make.  What would be very interesting is to drop the CPU into an identical motherboard and see if the performance recovers.

personally speaking my 3900X that I have had since late August, has not changed R20 scores outside standard deviation.  Despite being set at the stock settings for the entire time period.  Does that prove the boosting voltages to not degrade 3000 series CPUs?  Certainly not.  I also cannot test the scenario you listed above, as I never logged the maximum manual overclock at a set voltage to compare to.  So all I can say definitively is in my circumstance, the CPU runs exactly as it did 11 months ago in R20.

Does your friend have any benchmark data over the course of the 10 months to look for shifts and trends?  I imagine as a standard computer user, he probably hasn't been running benchmarks  with any frequency.

Highlighted
Challenger
Challenger

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

I'm way ahead of you on this one buddy. 

I got TWO 3600X CPUs at the same time, one for me and one for my friend in Sweden.

That 3600X has been sitting here doing nothing at all and I am sending it off to my friend to replace the one now has.

Whilst there is a possibility that what you say is correct, the motherboard he is using has a 10 Phase VRM with 40A powerstages, so I think that is highly unlikely that it would account for the performance degradation.

He is on holiday for a couple of weeks, so I can't send it out to him before that and it will take about a week to get from where I am to Sweden per post.

I am not really going to entertain the whole "Anecdotal" and "N=1 sample size"; because I predicted this would happen and it is a coincidence (and an unfortunate one) that he didn't apply the settings the way I told him to. I had also tested that CPU with regard to stability in both motherboards (I got identical hardware for both of us) and the results were exactly the same.

The reason why I did this is because I knew I wanted to get the 3950X and the GigaByte X570 AURUS XTREME motherboard (when it came down to a more reasonable price) so if there were any differences, I wanted him to have the better of the two (motherboard and CPU).

He has only been using his computer normally, and mainly for gaming.

So the system has been running at moderate levels of stress, the GPU he has is a 1080 Ti.

If I knew you in real life, I would be making a bet with you - and not a small wager either, if you were enough of a sucker to agree to the bet.

The bet would be that the 3600X I have that I am sending to him will perform as well as it did when I got it, and there will have been no degradation in the performance of the motherboard.

The chiplets used in the 3900X are of higher silicon quality than that used in the 3600X.

The other thing is that you didn't use my methodology to test in the first place and I don't know how conscientious you have been in monitoring not only the clockspeed but also the voltages.

I have a 3900X which I tested and I could get it to 4.4 GHz stable at 1.3 Volts with one CCD disabled. My 3950X will clock to 4.5 GHz at 1.3 Volts with one CCD disabled.

0 Kudos
Highlighted
Adept III
Adept III

Re: Proof of stock settings degrading 3rd Gen Ryzen performance

What about that fact that you helped him update his bios? Maybe the new bios has some flaw that is causing this. I don't and can't know for sure but it does seem like a possibility to me, it happens all the time with GPU drivers and sometimes just updating the bios causes problems.