cancel
Showing results for 
Search instead for 
Did you mean: 

Discussions

Highlighted
Elite
Elite

My R9 390 may be dead

So I turned off my computer for the night and when I got up and turned it on it just beeped with a vga debug light. I know the video card was starting to go but I had hoped it would be a litle bit longer, at least till the shortage was finished. however it is strange how it doesnt work. It sometimes works for a little bit then the screen goes black and the fans ramp up to 100%. it stays this way till i turn it off. the first few times it did this i could turn it off then wait 5 mins to turn it back on. i tried troubleshooting by putting another graphics card in that worked but i still havent had a chance to check the power supply to it since the card was an old card that didnt require power, but i have video and everything coming thru fine. I dissassembled the card and replaced the thermal paste and cleaned some corrosion that i found on the card and it turned right back on before crashing the same way. temps we fine only getting to 60c before the card lost video dont want to do much more to it before asking some questions. Hopefully its not completely dead as the 20 dollar gpu i got off ebay 3 years ago i pso i can do my college work wont even run any games.  Does anyone have any Ideas?

0 Kudos
6 Replies
Highlighted
Exemplar
Exemplar

Re: My R9 390 may be dead

do you have a different GPU at your hand?
you can try to flash the correct bios to the R9 390 again - its maybe a fix (big maybe)

but to be sure - your PSU can handle GPU? and everything connected?

0 Kudos
Highlighted
Elite
Elite

Re: My R9 390 may be dead

I have had my set up for almost a year now the gpu just stopped working properly. the gpu i am using right now is the cheap one from ebay and it works i am just wondering if the issue with my old gpu is fixable or if it is completly gone As i said worked fine for over a year and just now started black screening and ramping up the fans.

system specs without the gpu.

Ryzen 7 1700

MSI B350M gaming pro

16 gigs trident z 3000

1000w Rosewill Quark  PSU

0 Kudos
Highlighted
Exemplar
Exemplar

Re: My R9 390 may be dead

clean the GPU
new thermal paste if you dare to remove cooler (and put it back on)

PSU is ok

how did you buy the GPU? used? if yes - flash current bios
if you had bad luck it was used for mining - and is dead now

0 Kudos
Highlighted
Elite
Elite

Re: My R9 390 may be dead

Already cleaned and reapplied thermal paste. Arctic MX-4 bought new from newegg 2 years ago (finally found the invoice.) No mining. Flashed the bios last year and kept the original bios on the secondary bios option. its not the bios. tested both same issue.

0 Kudos
Highlighted
Exemplar
Exemplar

Re: My R9 390 may be dead

does it smell? like killed electro?

sell it as defective at ebay and buy a new RX580 4G
or wait what the RX580X brings

0 Kudos
Highlighted
Anonymous
Not applicable

Re: My R9 390 may be dead

Hello,

Did you carefully checked the pcb, i mean naked without vrm heatsink, to check if there are any broken smd component, especially near the vrm power stage.
Check also if the vrm metal shroud, fan assembly, heatskink are well mounted, avoiding any shorts.

From how you describe the issue it seems that, if the t° are not the issue somewhere, applying a mechanical stress on the card by disassembling it, brought it back alive for a few mins.

It could be there are some small solder crack somewhere under the balls of the die or the ram and/or somewhere else on the pcb. That why disassembling could made it works for some time.
The other explanation could be a power supply issue, but i suppose your replacement gpu is quite small and do not draw the same current as the 390. So you could maybe not notice the issue straight.

Usually if you want bring back dead gpu, when there is nothing else to do, you bake it in a oven at a precise t° or use a heat gun to heat the pcb.
The idea is to melt the solder to repair the small cracks, that break electrical connections. This could work in some cases where the gpu have no physical or component damage.
Other than that, it could simply be that the die/ram itself get some high voltage and just died, but pcb is intact.