cancel
Showing results for 
Search instead for 
Did you mean: 

Discussions

alphadan
Journeyman III

Driver install fails on linux 7900 xt

Im trying to install the driver but it fails:

 

system ubuntu 22.04 (installed this ubuntu version specifically to make this driver work failed with the same error in debian 12)

GPU XFX 7900 XT

im downloading the driver from: https://www.amd.com/en/support/graphics/amd-radeon-rx-7000-series/amd-radeon-rx-7900-series/amd-rade...

 

sudo dpkg -i amdgpu-install_5.7.50702-1_all.deb
Selecting previously unselected package amdgpu-install.
(Reading database ... 187031 files and directories currently installed.)
Preparing to unpack amdgpu-install_5.7.50702-1_all.deb ...
Unpacking amdgpu-install (5.7.50702-1683306.22.04) ...
Setting up amdgpu-install (5.7.50702-1683306.22.04) ...

sudo amdgpu-install --usecase=graphics,rocm
Hit:1 http://es.archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://es.archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:3 http://es.archive.ubuntu.com/ubuntu jammy-backports InRelease
Hit:4 http://security.ubuntu.com/ubuntu jammy-security InRelease
Hit:5 https://repo.radeon.com/amdgpu/5.7.2/ubuntu jammy InRelease
Hit:6 https://repo.radeon.com/rocm/apt/5.7.2 jammy InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
amdgpu-lib is already the newest version (1:5.7.50702-1683306.22.04).
amdgpu-lib32 is already the newest version (1:5.7.50702-1683306.22.04).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up amdgpu-dkms (1:6.2.4.50702-1683306.22.04) ...
Removing old amdgpu-6.2.4-1683306.22.04 DKMS files...
Deleting module amdgpu-6.2.4-1683306.22.04 completely from the DKMS tree.
Loading new amdgpu-6.2.4-1683306.22.04 DKMS files...
Building for 6.2.0-37-generic
Building for architecture x86_64
Building initial module for 6.2.0-37-generic
ERROR (dkms apport): There was a segmentation fault when trying to build the module
Error! Bad return status for module build on kernel: 6.2.0-37-generic (x86_64)
Consult /var/lib/dkms/amdgpu/6.2.4-1683306.22.04/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
amdgpu-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

this is the error i get when trying to install the same error i got in debian too, i been trying different versions for about a week oday i saw there was a new version available to i made a new try every time im going to install i rollback my system with timeshift to prevent conflicts with drivers this is a fresh install and the timeshift snapshot was created just after install i jut want it to work.

ERROR (dkms apport): There was a segmentation fault when trying to build the module

im afraid this might be a problem with my hardware since i dont see anyone else having this issue

Problem 2

also when i try to make GPU Pass-through on KVM the guest system crashes sometimes i get signal when installing windows host and sometimes it just wont give signal and when i install the driver on the guest machine it freezes

 

I can live with the problem 2 but being unable to install the driver for rocm is sadly a must for me, so if this wont work i will have to return this card.

does another user have the same problem when instaling the driver with 7900XT?

 

 

0 Likes
0 Replies