cancel
Showing results for 
Search instead for 
Did you mean: 

Discussions

Highlighted
Journeyman III
Journeyman III

Assassins creed black flag crash need help

My build is

FX 6300 overclocked to 4 GHZ

evo 212 cooler

Strix RX580 8gb

GA 970A DS3p motherboard

12 gb of ddr3 ram

550 watt power supply

I am having the issue where after the segment where you run around in the animus before loading into the main game it crashes and kicks me back to the windows screen but the game audio is still playing i cant use my mouse and have to end the game in task manager for it to go back to normal.  I am on the latest drivers.

Tags (1)
0 Kudos
4 Replies
Highlighted
Forerunner
Forerunner

Re: Assassins creed black flag crash need help

Which OS and is it up to date? Have you played around with different settings in Radeon Settings? Is this the only game you're having this issue with?

Did you raise a support ticket or ask on the Ubisoft forums about this?

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Assassins creed black flag crash need help

I am on Windows 7 64 bit it was working on my 1050 TI but when I swapped cards it stopped working black flag is the only game having issues right now tried 10 others since card swap and no problems.

I have not raised a support ticket how do I do that?

0 Kudos
Highlighted
Exemplar
Exemplar

Re: Assassins creed black flag crash need help

use DDU (in safe mode - so it will reboot before) to clean both drivers (because i think you still have Nvidia driver left on system)
after reboot install latest 17.8.2 -> reboot again

you should be done

0 Kudos
Highlighted
Forerunner
Forerunner

Re: Assassins creed black flag crash need help

Keep in mind it is VERY important that you COMPLETELY update your Windows 7 installation BEFORE installation AMD drivers. As for reporting to Ubisoft, check on their website and forums to report bugs.

I would also check i Windows Event logs for any clues as to what's happening or causing the crash. Also, are you using Asus' GPU-TweakIt app? If so, uninstall it immediately; I had nothing but trouble with that installed alongside WattMan. This may not be the cause, but if you have it installed you might as well get rid of it anyway.

0 Kudos