cancel
Showing results for 
Search instead for 
Did you mean: 

Devgurus Discussion

Adept I
Adept I

Cannot execute ipopt solver in a CPU AMD RYZEN 9 3950X (AM4) PROCESSOR (PIB) WITHOUT COOLER

I have recently recieved a computer with a CPU AMD RYZEN 9 3950X (AM4) PROCESSOR (PIB) WITHOUT COOLER and I have installed winodws 10 version 2004. I want to  use it to solve  optimization problems written in pyomo, a language based on python. The solver employed is ipopt.

To install it, I have downloaded the latest version of Anaconda navigator  and then, I have followed these instructions. I have created the envoironment pyomo36 as defined there and also installed the libraries BLIS and MKL. Note that I have downloaded all of this from conda forge.

Unfortunately, whenerver I try to run any code which solves an optimization problem with ipopt as solver, I obtain the problem which can be seen in the  attached image. (I run the program pressing f5). 

I have also done a partition of the disk and installed the same programs in Ubuntu 20.04 following the same stepts. Although the program runs there,  the code is extremely slow (it takes 18 hours to run a program only to arrive at a restoration phase failed result). I don't know what to do. Please help.


Best regards.

P.S. I know that this code works because I have run it on an Intel CPU and it has worked there.

 

Output_error.png

 

 

0 Kudos
Reply