cancel
Showing results for 
Search instead for 
Did you mean: 

CodeXL

yurtesen
Miniboss
Miniboss

ALU/Fetch counters empty for Tahiti?

I am using latest CodeXL and tried this with 12.10 and 13.1 drivers on Ubuntu 12.04 64bit. I see ALU*, FetchInsts, FetchUnit* columns totally empty, is this normal?

Thanks,

Evren

0 Kudos
Reply
9 Replies
kalyanpk
Staff
Staff

Re: ALU/Fetch counters empty for Tahiti?

Hi,

Thanks for using CodeXL.

CodeXL 1.0 version is supported on Ubuntu 11.10 x64 OS.

Future versions of CodeXL will have support enabled for Ubuntu 12.04 x64.

Anyway, can you please brief more on the problem that you are facing?

What kind of application are you running? is it OpenCL or OpenGL?

is it possible to share the application with us so that we can analyse the problem locally?

Thanks,

Kalyan P

0 Kudos
Reply
cguenther
Adept II
Adept II

Re: ALU/Fetch counters empty for Tahiti?

Hi,

Maybe you have the same problem, like me. See the following thread:

http://devgurus.amd.com/thread/160110

best regards,

Christian Günther

0 Kudos
Reply
yurtesen
Miniboss
Miniboss

Re: ALU/Fetch counters empty for Tahiti?

Hmm, strange since system requirements at CodeXL page say "Ubuntu® 64-bit 11.10 or later"

http://developer.amd.com/tools/heterogeneous-computing/codexl/

According to the text, Ubuntu 11.04 is not supported! So is the web site incorrect? Ubuntu 12.04 is not that new, it definitely should be supported.

In Ubuntu 12.04, the same problem exists with OpenCL samples also... I ran bufferbandwidth example and attached a screenshot of it. Also the profile csv is attached.

I also have a secondary problem with my code, because it is running 25% slower with 13.1 drivers compared to 12.10 drivers. If I can send the test code, does it have to be through the public forum or can I email it to you?

0 Kudos
Reply
yurtesen
Miniboss
Miniboss

Re: ALU/Fetch counters empty for Tahiti?

It is quite strange, you seem to have different column names in your results. I use CodeXL 1.0.1042.0 which one are you using? If you see my screenshot, the columns are empty in my case. It appears to be a different problem?

0 Kudos
Reply
cguenther
Adept II
Adept II

Re: ALU/Fetch counters empty for Tahiti?

Oh sorry, i can't reconstruct exactly. But i know that i am using at the moment Ubuntu 12.10 with current CodeXL release and it seems to work every fine. I have neither my early described problem nor the empty columns what you shows.

So i can say, if not another tool you are using resist the upgrade to 12.10, try this one.

best regards,

Christian

0 Kudos
Reply
yurtesen
Miniboss
Miniboss

Re: ALU/Fetch counters empty for Tahiti?

cguenther wrote:

So i can say, if not another tool you are using resist the upgrade to 12.10, try this one.

I have 12.10 on a usb stick. I will see what it does next week and return back to you.

0 Kudos
Reply
yurtesen
Miniboss
Miniboss

Re: ALU/Fetch counters empty for Tahiti?

I tested with Ubuntu 12.10, Catalyst 13.1 drivers and latest CodeXL 1.1 and got exactly the same results.

cguenther, when you run clinfo, which driver version you see? (on a different machine, I realized Catalyst was not updating opencl runtime driver versions at all and required some intervention ).

EDIT: I now have OpenCL 1.2 AMD-APP (1113.2) as runtime version, but still the same problem

0 Kudos
Reply
dorono
Staff
Staff

Re: ALU/Fetch counters empty for Tahiti?

Hi,

Please send the test code to Gputools.Support@amd.com so we can have a look at it.

Thanks,

0 Kudos
Reply
yurtesen
Miniboss
Miniboss

Re: ALU/Fetch counters empty for Tahiti?

I am running the bufferbandwidth program which arrived with the SDK itself. So you probably have it I also attached a screenshot of exactly how the output looks like. What other information do you need?

0 Kudos
Reply