Showing results for 
Search instead for 
Did you mean: 

Blender Discussions


ProRender plugin crashes Blender immediately all of a sudden.

On my second PC,(an iMac with Windows) Blender and ProRender has always worked great, I have had Blender 2.80 and 2.81 installed on it, and have been using RPR 2.0.162 just fine.  It worked yesterday morning, then in the evening I tried to open Blender and it crashes at the gray screen, and it does this for either version of blender.  The only way Blender will run is if I manually remove the rprblender folder from the addons folder.  I tried reinstalling Blender and ProRender, with the same results, although after completely reinstalling ProRender, then, Blender doesn't crash until I tick the box to enable RPR, then it crashes right to the desktop.   I did run Blender through the command prompt, and I have included a screenshot of the command line errors it produces.   Also, it's probably not related, but I still, on both my computers, get the same error during install of prorender, saying "it cant find python.exe in a specific location, did I type it right?"  but the python.exe file is in that location, although the path written in the error message is sorta different (see the screen shot below).  This error during RPR install is not new, and has been doing that for months, so I doubt it has anything to do with why ProRender all of a sudden just stopped working on this machine yesterday.  I did also run "dism/restore health..." command to fix any OS errors yesterday after all this happened.  Because this computer is running bootcamp I cant update to the latest AMD display drivers, I have to use the bootcamp drivers that are available, so they are 18.2.2, but like I said before, RPR has always worked fine, and even yesterday morning RPR was working fine, so I'm a bit stumped here, both my PCs are up to date with all windows updates, although this PC(iMac) is on version 1809, and my gaming PC is on 1909, but I don't want to upgrade this one yet because not surprisingly after doing the 1909 update to my gaming PC, a few of my games just stopped loading, and Windows will not let me go back to v1809 on that PC now, so I am forced to play those games on my crappy Mac, instead of my purpose built gaming rig,  go figure.  But I do like using Blender with ProRender on this iMac because it looks great on the 5k screen, i have 40gb of ram, and the Pro 570 4gb GPU manages to do a decent enough job at it.   I really hope to get this problem resolved so I can use it again, in the meantime I will try to locate an older version of RPR and see if that may work again, thanks.


This is the command prompt message when ProRender causes Blender to crash at loading.

blender RPR fail.jpg

I've been getting this error when installing RPR for months.

4 Replies
Not applicable


Have you tried the plugin version 2.1.1(current release version)? The installation issue with Blender 2.81 is fixed in it.

I suppose I will try v2.1.1 when I get a chance soon,  But I don't see how that could be an issue,  RPR had been working fine(all versions, older versions better than newer) and this specific problem of killing blender if RPR is activated just started all of a sudden, and out of the blue.  Plus I have since tried every version of Blender, 2.80, 2.81 and 2.82, and it still kills it.  I have even tried the last three releases of RPR for blender (with the exception of 2.1, as I didn't even know it was released).  So I suspect it may be something else on that computer, maybe a windows update possibly, it is on Bootcamp so it very rarely gets AMD related updated, and certainly not automatically.

Not applicable

Just in case - was anything else changed on your computer recently, like drivers update?


Thanks for the help,  The computer is an iMac running windows 10 in Bootcamp, so there have been no hardware changes ever, and since it is a bootcamp environment it doesn't get any hardware driver updates unless Apple releases another Bootcamp driver "package" for the iMacs, which includes the drivers for the AMD discrete GPUs.  For that reason it is still on AMDs driver version 18.xx.x,  but I have had no issues prior to this, and I litteraly used blender at 10am, left for a while, and came back at 5pm and blender refuses to open if ProRender is already selected as an enabled addon, or if I try to enable it after.   It's strange that when enabling it from the preferences menu, in the past any time I ever had an issue with RPR enabling I would expect to see the error show in the console, and in a popup, but this just terminates it suddenly.  The only possible thing I could think could be a windows fed update while I was away, but none of my other PCs have had an issue, and some are updated to win 1909.    I just left it since that day, but I'll look at it soon, thanks.