cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Staff
Staff

Re: Prorender does not work with recent 2.8 builds

It should work for 18.04.  We'll test and get back to you.

0 Kudos
Adept I
Adept I

Re: Prorender does not work with recent 2.8 builds

any results?

0 Kudos
Adept I
Adept I

Re: Prorender does not work with recent 2.8 builds

If you activate the render in the assembly on March 25, you will also get an error.
Ubuntu 18.04

_dezigner.tilda.ws_13.08.2019_12_10.png

0 Kudos
Journeyman III
Journeyman III

Re: Prorender does not work with recent 2.8 builds

I'm having the same problem, with the exact same Traceback.
May i ask what is your cpu?

0 Kudos

Re: Prorender does not work with recent 2.8 builds

Not sure, if you replied to my post (I have exactly the same traceback, see above) or to dez1gner's. Anyway, I'm using Intel Xeon E5 CPUs.

However, I don't believe the CPU to be the problem. To me, it seems more likely that there are some leftovers from other systems in the code. I remember having seen a different traceback at least once that mentioned some missing dll that only exists on Windows. But I could be wrong, of course, and this could be a totally unrelated bug.

Journeyman III
Journeyman III

Re: Prorender does not work with recent 2.8 builds

I tried to use the Intel SDE emulator, as my cpu doesnt have SSE4 ( Phenom II x4), and it worked, sorta, it didn't render, it gave another error, but it activated.

0 Kudos

Re: Prorender does not work with recent 2.8 builds

May I ask, if there any news on this issue? I still can't even activate ProRender in Blender 2.80, let alone use it for rendering.

0 Kudos
Adept I
Adept I

Re: Prorender does not work with recent 2.8 builds

I managed to run ProRender in Linux.
To do this, I installed libOpenCL.so
The renderer works. It is very interesting.
I want to do some work on it.

But.
The blender closes with an error if you enable denoise.

Here's what the console writes:

location: <unknown location>:-1
Traceback (most recent call last):
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/__init__.py", line 65, in update
self.engine.sync(depsgraph)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/engine/render_engine.py", line 416, in sync
self.setup_image_filter(image_filter_settings)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/engine/engine.py", line 203, in setup_image_filter
self._enable_image_filter(settings)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/engine/engine.py", line 269, in _enable_image_filter
self.rpr_context.context, inputs, {}, params, width, height)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/engine/image_filter.py", line 46, in __init__
self._create_filter()
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/engine/image_filter.py", line 105, in _create_filter
self.filter = self.context.create_filter(rif.IMAGE_FILTER_LWR_DENOISE)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/pyrprimagefilters.py", line 142, in create_filter
return ImageFilter(self, filter_type)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/pyrprimagefilters.py", line 286, in __init__
ContextCreateImageFilter(self.context, filter_type, self)
File "/home/dez/Blender/blender-2.80/2.80/scripts/addons/rprblender/pyrpr.py", line 65, in wrapped
raise CoreError(status, f.__name__, argv, module_name)
pyrpr.CoreError: RIF call ContextCreateImageFilter(<pyrprimagefilters.ContextGPU object at 0x7fdf2e6c2400>, 13, <pyrprimagefilters.ImageFilter object at 0x7fdf2e6c2358>) returned error code <-21> with error message: ''

Dear developers.
Please, pay attention.

0 Kudos

Re: Prorender does not work with recent 2.8 builds

Not to sound impatient, but...

May I please ask for some kind of feedback? Just to know, if the issues are being worked on... or if the developers have given up and we can stop hoping for ProRender to work with Blender 2.80.

Journeyman III
Journeyman III

Re: Prorender does not work with recent 2.8 builds

I can activate ProRender for Mac Blender 2.8 but beyond rendering the default cube, I can't render anything else, or move/scale objects when ProRender is running in the active viewport.

Judging by the lack of response to queries, I too wonder if things have halted?

0 Kudos