cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Esteemed Contributor III

Re: Prorender does not work with recent 2.8 builds

Well that's a win... Why is the main page where the vast majority of people will down the plugin not updated with the correct plugin?
Do you know who should be contacted to get that fixed?
I will test both anyhow and see if this:
pastedImage_1.png
makes any difference.

Thanks.

0 Kudos
Esteemed Contributor III

Re: Prorender does not work with recent 2.8 builds

Using the Blender Plugin downloaded from the obvious place, where most people will go to try it out  i.e.:
pastedImage_1.png

Resuls in this: using the just released (about 7.5 hours ago)  Blender Version blender-2.80-8b2b79c2108b-win64.zip

pastedImage_1.png

i.e. it is broken using the plugin available from the AMD Download Page.

0 Kudos
Esteemed Contributor III

Re: Prorender does not work with recent 2.8 builds

Using the ProRender Plugin available from here:
pastedImage_1.png

Results in this: using the just released (about 7.5 hours ago)  Blender Version blender-2.80-8b2b79c2108b-win64.zip

pastedImage_1.png

pastedImage_2.png

That is great, it even seems to render properly using an R9 280X GCN 1.0 GPU.

Conclusion.

Please make sure this RadeonProRenderBlender_2.0.85.msi  - which I guess is the latest BETA ProRender Plugin version for Blender 2.0 Beta  is available for download from the official AMD download page here:
pastedImage_1.png

According to Norton Security File Insight there are not many people who have tried RadeonProRenderBlender_2.0.85.msi:

pastedImage_3.png

It shows fewer than 5 (probably happy) Users.

The official download ProRender Plugin version for Blender 2.0 Beta, radeonprorenderforblender.msi does not work with latest versions Blender 2.0 Beta, so anyone getting that experience will have their time wasted and have a bad impression of ProRender Plugin.

Thanks.

0 Kudos

Re: Prorender does not work with recent 2.8 builds

Hi there,

I seem to be have the same problem as described in this thread, i.e. I can't activate the ProRender plugin in more recent builds of Blender 2.80. I'm using Linux, however, so the solution described here (downloading a newer build from AMD Radeon ProRender for Blender 2.80 Beta) is of no help for me, as there's no Linux build in that thread.

Any help?

0 Kudos
Staff
Staff

Re: Prorender does not work with recent 2.8 builds

We'll post it when the final build of Blender 2.80 is out.

Staff
Staff

Re: Prorender does not work with recent 2.8 builds

Hi marcus.  You can download the official 2.0 build for blender 2.80 here:  https://www.amd.com/en/technologies/radeon-prorender-downloads

0 Kudos

Re: Prorender does not work with recent 2.8 builds

Thanks, that's good news indeed. Will try and report back.

0 Kudos

Re: Prorender does not work with recent 2.8 builds

As described in this thread, I still have problems activating the RPR addon in the latest (non-RC) version of Blender. I'm trying version 2.0.112 of RPR. Here's the traceback:

 

Traceback (most recent call last):
File "/opt/Blender-2.80/2.80/scripts/modules/addon_utils.py", line 351, in enable
mod = __import__(module_name)
File "/home/marcus/.config/blender/2.80/scripts/addons/rprblender/__init__.py", line 19, in <module>
from .engine.engine import Engine
File "/home/marcus/.config/blender/2.80/scripts/addons/rprblender/engine/__init__.py", line 83, in <module>
assert pyrpr_init(bindings_import_path, rprsdk_bin_path)
AssertionError

I even completely uninstalled and re-installed Blender, to be sure this was not caused by some leftover pieces of code.

Any help would be much appreciated.

0 Kudos
Staff
Staff

Re: Prorender does not work with recent 2.8 builds

What ubuntu version is this?

0 Kudos

Re: Prorender does not work with recent 2.8 builds

I'm running Linux Mint 19.1, which is based on Ubuntu 18.04 Bionic Beaver.

I do realize that the installer says something about being compatible with Ubuntu 16.04... But I don't think anyone (who got the RPR addon installed) still uses a Ubuntu version from the beginning of 2016? So, I was kinda hoping it would work nonetheless.

Do I really need to downgrade to be able to use RPR?

0 Kudos