cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Highlighted

Prorender does not work with recent 2.8 builds

Hi, I've found an issue with the 4 Apr 2019 build of AMD Prorender with the current Blender 2.8 beta builds after 16 May 2019.

This change has been made to the Blender API, breaking Prorender (and potentially other renderers):

https://developer.blender.org/rB2ee762344f8742618804e869536e3efee6ab0bd0#change-SGUusqczrUIQ

With the stock Prorender when trying to use a very recent Blender 2.8 build and enabling the addon I'm getting this traceback:

File "/Applications/blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 384, in enable mod.register()
File "/Users/[redacted]/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 111, in register() bpy.utils.register_class(RPREngine)
ValueError: expected RenderEngine, RPREngine class "view_update" function to have 3 args, found 2

I've traced it down to that change, linked above; Blender added the view_update and view_draw methods to take a depsgraph object in addition to a context object.

Tonight when I get home from work I'm going to poke around with the python portion of my installation, to see if I can get it working; but I think that adding the argument for depsgraph to these functions and adding the called functions to take that depsgraph object and use it instead of the context object will get it working again.  I'll update this post with my progress.

58 Replies
Highlighted

Re: Prorender does not work with recent 2.8 builds

Update: I made the changes to allow for the plugin to load, but it seems there's some other regression now that's preventing the viewport from shading.  In the viewport all objects are a flat gray silhouette, no shading or lighting.  The main renderer works fine, as the final output is okay.  This seems to be reported as early as 25 April.

0 Kudos
Highlighted
Adept II
Adept II

Re: Prorender does not work with recent 2.8 builds

I have reported the issue with another person back in April but that is I think a different materials issue. How did you manage to load Render back in newer beta? I traced it down to 5-15-2019 to be the last that’s actually worked with Render Pro. 

0 Kudos
Highlighted

Re: Prorender does not work with recent 2.8 builds

Unfortunately, NDAs I'm under will prevent me from being able to release code without going through a long process at my day job.  I can point to how to fix it though.  You'll need to modify the two functions that changed, view_update and view_draw to take a despgraph object as the last positional argument.  Then follow the pattern they used to modify the Cycles engine in this patch https://developer.blender.org/rB2ee762344f8742618804e869536e3efee6ab0bd0 to use the depsgraph from the args instead of out of the context object.

0 Kudos
Highlighted
Adept II
Adept II

Re: Prorender does not work with recent 2.8 builds

Actually I rather wait and see if they will fix the issue that it is not showing up. As for the rest of the issue I have reported I hope AMD will update their product as there are quite some rendering issues pending.

0 Kudos
Highlighted
Adept I
Adept I

Re: Prorender does not work with recent 2.8 builds

Any Updates? 

0 Kudos
Highlighted
Esteemed Contributor III

Re: Prorender does not work with recent 2.8 builds

This is the latest situation ...
https://community.amd.com/thread/240065 
Still broken.
I didn't try changing any Python scripts.

Bye.

0 Kudos
Highlighted
Adept II
Adept II

Re: Prorender does not work with recent 2.8 builds

It works with the latest beta 2.8 and make sure you download the new version of Render Pro!

0 Kudos
Highlighted
Esteemed Contributor III

Re: Prorender does not work with recent 2.8 builds

I downloaded the ProRender plugin from here, for windows, highlighted in grey, Version 2.0 Beta for Blender 2.80 Beta: 

pastedImage_1.png
I tested with blender-2.80-8fa65ed31b7f-win64.zip which was the latest version of blender available to download 7 hours ago from here:

pastedImage_2.png

I just tried a download again and I now get this: blender-2.80-8b2b79c2108b-win64.zip
I am installing it now and will see if that works.

If any of the above looks wrong or if you know where to get a later download for Blender or the ProRender plugin then please advise. If either of the above websites are showing incorrect Blender or Plugin download information it needs to be fixed.

Thanks.

0 Kudos
Highlighted
Adept II
Adept II

Re: Prorender does not work with recent 2.8 builds

Download the render pro from here. Unfortunately they did not update the website yet: https://community.amd.com/docs/DOC-2183 <https://community.amd.com/docs/DOC-2183>