cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

david57
Adept II
Adept II

Bug enabling cards

4.0 GHz Intel Core i7-6700K Quad-Core

2 x AMD Radeon RX 480 with 8GB VRAM

16GB of 3000 MHz DDR4 RAM

Blender 2.8 beta current version

2.0.94 Radeon ProRender plugin for blender 2.8

Having problems enabling cards.

When I enable 2 cards the render is slower than rendering with just 1 card.

Image below is my settings with rendering.

RPR  Floor.jpg

RPR Settings .jpg

0 Kudos
5 Replies
gelert
Elite
Elite

Re: Bug enabling cards

Sadly, this has been the case for a while now. Performance of Multi Devices has tanked. It used to scale beautifully but sadly there's something wrong at the moment.

I'd turn off Tiled Rendering though.... that's even worse performance than a normal 2xGPU option in RPR at the moment.

It's only useful if you're trying to render a 4K plus sized image so that it'll fit into VRAM.

Try Min Samples 250, Max Samples 2500, Noise Threshold 0.02, Samples per update 4, turn off Tiled Rendering and try the 2xGPU then do 1xGPU as a test.

If you want a no noise final render, set Noise Threshold to 0.0 and set a time limit to 20 minutes or something.

I've been testing Noise Threshold a lot and for quick test renders you can get away with 0.03 or 0.04 without really sacrificing much quality but the speed up is quite profound on complex renders.

0 Kudos
david57
Adept II
Adept II

Re: Bug enabling cards

I used the render settings that you requested.

Here are the results in this three renders.

Also included the same denoiser settings that I used for the renders.

2 x GPU's .png

1 x GPU's .png

20 Minute Render.png

gelert
Elite
Elite

Re: Bug enabling cards

This is utterly brilliant  well done. Great result and testing.

Turning off Tiled Rendering has worked perfectly.

Your two Pascal cards, RX 480's work together really well on the settings I suggested.

And you're getting a render time improvement from 20 minutes to 13 minutes with the Noise Threshold setting and 2xGPU which is an awesome result.

You're also seeing a 5 minute saving running two GPUs, which isn't fantastic. It's about 4 minutes longer than it should be but hopefully the next version of RPR will improve on that front.

At least you are seeing an improvement now.

0 Kudos
david57
Adept II
Adept II

Re: Bug enabling cards

This is a 19 minute render. Its started to get noisy with dark pixels showing up

around a minute before stopping the render. I can not figure out what i did wrong here.

Thank you.

AMD - RPR.jpg

0 Kudos
david57
Adept II
Adept II

Re: Bug enabling cards

I changed the HDRI and I dont longer see those dark pixels.

Maybe just the HDRI that was causing the problem.

AMD - RPR 2.jpg

0 Kudos