cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

tashaskyup
Journeyman III

Assertion error attempting to enable addon in blender v2.79.6

Traceback (most recent call last):

  File "C:\HoppingMadGames\Blender\blender-2.79.0a\2.79\scripts\modules\addon_utils.py", line 370, in enable

    mod.register()

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\__init__.py", line 175, in register

    from . import render  # import render first to initialize pyrpr(can be used in other modules)

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\__init__.py", line 123, in <module>

    assert pyrpr_init(bindings_import_path, rprsdk_bin_path)

AssertionError

Traceback (most recent call last):

  File "C:\HoppingMadGames\Blender\blender-2.79.0a\2.79\scripts\modules\addon_utils.py", line 370, in enable

    mod.register()

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\__init__.py", line 175, in register

    from . import render  # import render first to initialize pyrpr(can be used in other modules)

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\__init__.py", line 123, in <module>

    assert pyrpr_init(bindings_import_path, rprsdk_bin_path)

AssertionError

Traceback (most recent call last):

  File "C:\HoppingMadGames\Blender\blender-2.79.0a\2.79\scripts\modules\addon_utils.py", line 370, in enable

    mod.register()

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\__init__.py", line 175, in register

    from . import render  # import render first to initialize pyrpr(can be used in other modules)

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\__init__.py", line 153, in <module>

    from rprblender import helpers

  File "C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\helpers.py", line 17, in <module>

    from pyrpr import ffi

ImportError: cannot import name 'ffi' from 'pyrpr' (C:\Users\Tasha\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\pyrpr.py)

Tags (1)
0 Likes
3 Replies
bsavery
Staff
Staff

Re: Assertion error attempting to enable addon in blender v2.79.6

Looks like you're using 2.79a0?  Can you try with an official 2.79b/c build?

0 Likes
tashaskyup
Journeyman III

Re: Assertion error attempting to enable addon in blender v2.79.6

It has no problems with the official 2.79. But the official is missing far to much functionality, I don't think most people use it.

0 Likes
bsavery
Staff
Staff

Re: Assertion error attempting to enable addon in blender v2.79.6

Unfortunately supporting unofficial builds of blender is a bit of a rabbit hole for us.  As you can imagine.  However I can give some insight here.  Not sure if you build that version yourself or what, but make sure you have python libs "ffi" installed when building blender.  It appears that library is missing from the python inside blender.

Barring that what version of python is in your blender build?

0 Likes