cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

d_a_a_
Adept II

Why does the fan speed stay at 26% when my GPU reaches 101°C?

Hi,

At the default 26% fan speed, some intensive OpenCL applications can make my Radeon HD6970 reach 100°C or more. I'm running Debian GNU/Linux with fglrx 11.12 drivers, and if I don't set the fan speed manually[1], the GPU would probably burn up. Is there a way to enable some kind of automatic fan speed control? What is the safe temperature for the Radeon HD6970?

1. Something like: aticonfig --pplib-cmd "set fanspeed 0 50"

0 Likes
4 Replies
eugenek
Journeyman III

Why does the fan speed stay at 26% when my GPU reaches 101°C?

It's always been this way. Even in Windows, the fan will stay at 35% when the GPU is fully loaded by an OpenCL program. NVIDIA drivers suffer from the same problem. For some reason, video drivers just don't perceive of OpenCL as "real" load.

0 Likes
d_a_a_
Adept II

Re: Why does the fan speed stay at 26% when my GPU reaches 101°C?

I've seen Nvidia drivers automatically adjusting fan speed (depending on the temperature) for a long time, at least on GNU/Linux. IMO, this is a must have feature.

0 Likes
drallan
Challenger

Re: Why does the fan speed stay at 26% when my GPU reaches 101°C?

I'm on Windows7 but my fans do work in auto and jump to 100% as soon as I start a heavy ocl load.

You might want to try one of the GPU tweaking tools, mine lets me set the fan speed to auto or

a fixed value, and overrides the drivers' settings.

I just looked, and there are a few GPU tweak tools for Linux but I don't know much about them.

Good luck.

0 Likes
djohn
Journeyman III

Re: Why does the fan speed stay at 26% when my GPU reaches 101°C?

I faced the same problem.

Therefore, I made up a small shell script running in background, that checks the temperature and adjusts fan-speed automatically.

while [ 1 ]; do

temp=`aticonfig --adapter=0 --odgt | awk '/Temperature/{print $5}' 2> /dev/null`

if [ `echo "$temp < 40" | bc` -eq 1 ] ; then

  aticonfig --pplib-cmd "set fanspeed 0 15" &> /dev/null

#... and so on ... (add cases however you want to)

fi

sleep 3

done

I hope this might help you with your problem.

0 Likes