cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

aokomoriuta
Journeyman III

Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

In my Radeon R9 290 (Hawaii), CL_DEVICE_VERSION is "OpenCL 1.2 AMD-APP (1642.5)".

CL_PLATFORM_VERSION is OpenCL 2.0 AMD-APP (1642.5).

Why is not CL_DEVICE_VERSION "OpenCL 2.0"?

Did I forget some special settings?

thanks.

0 Likes
1 Solution

Accepted Solutions
bsp2020
Elite

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

It looks like you have the required software. Are you getting CL_DEVICE_VERSION from clinfo, or your own application.

I think only 64 bit OCL library is OCL2.0 at the moment. Run clinfo and check the CL_DEVICE_VERSION. If you get 2.0 from clinfo but still get 1.2 from your own application, I think it is because your application is 32bit.

View solution in original post

0 Likes
5 Replies
bsp2020
Elite

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

Which OS are you using? When asking for help in any forum, it is a good idea to provide basic system information such as OS version and bitness. CPU/Memory size/MB used/etc.

0 Likes
aokomoriuta
Journeyman III

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

OS: Windows 7 Pro 64bit

CPU: AMD FX 8350

RAM: 16GB

Does this problem depend on OS or CPU or memory size?

0 Likes
ravkum
Staff
Staff

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

Hi,

The Hawaii card does support OpenCL 2.0 with Omega driver (clinfo driver version:1642.5). Could you send me the full clinfo logs?

Regards,

Ravi

0 Likes
bsp2020
Elite

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

It looks like you have the required software. Are you getting CL_DEVICE_VERSION from clinfo, or your own application.

I think only 64 bit OCL library is OCL2.0 at the moment. Run clinfo and check the CL_DEVICE_VERSION. If you get 2.0 from clinfo but still get 1.2 from your own application, I think it is because your application is 32bit.

0 Likes
aokomoriuta
Journeyman III

Re: Why does not my Hawaii support OpenCL 2.0 with driver 1642.5

Jump to solution

Yes, I built it as 32bit.

I can get CL_DEVICE_VERSION "OpenCL 2.0" when 64bit build!

Thank you!

0 Likes