cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

developer
Adept II

Re: What's wrong with this file?

Hello Nou,

THanks for the detailed steps.

I am using a Win64 box with AMD 6950 GPU (Cayman) here.

Nazim was talking about an add-on. Does the link given by you contain that add-on?

oiow, Can I reproduce what Nazim is saying with your steps?

OR Are you just suggesting the high memory usage?

In any case, I will try this out this week and let you all know.

Thanks,

Best Regards,

Workitem 6

0 Likes
npm1
Adept II

Re: What's wrong with this file?

Hia, the developer of blender cycles, has responded to these changes...

If you compile it like this, most features will be disabled, just

giving you an ambient occlusion style display without any materials.

This is known to work on AMD cards, no surprises there. But if you

enable more features (with e.g. __KERNEL_OPENCL_AMD__), that's when

you run into problems.

0 Likes
developer
Adept II

Re: What's wrong with this file?

Hello Nazim,

Will the steps provided by Nou sufficient to repro this problem?

Please help me reproduce the problem. I will definitely work with you to get this resolved.

Is the behaviour observed in Linux or windows? Or both?

32 or 64bit? or both?

By __KERNEL_OPENCL_AMD__, Do you mean a "Compiler" option that I can enable in my previous repro attempt?

Thanks,

Best Regards,

Workitem 6

0 Likes
nou
Exemplar

Re: What's wrong with this file?

Yes Nazim want working Blender Cycles render which utilize GPU through OpenCL. You can also try 2.64 http://download.blender.org/release/Blender2.64/ but not 2.65 as this version have disabled OpenCL tracing. With this it clogs my 8GB of RAM. Then I killed it manually.

0 Likes
npm1
Adept II

Re: What's wrong with this file?

Hia,

Thanks...

Heres the link to the full application....

http://download.blender.org/release/Blender2.64/

please download the blender 2.64a version...for either linux or windows

On either platform this problem re-occurs...

once downloaded unzip open "blender.exe"

on the bar at the top change blender internal(drop down menu) to cycles

press spacebar on keyboard type "user preferences"

go to the "system"steps.png

change the device from "CPU" to "OPENCL"

Then:

RENDERTAB.png

ONCE YOU CLICK RENDER WAIT...

THIS HOW YOU REPRODUCE THE SAME ERRORS AS I HAVE DONE(RUN OUT OF MEMORY AND OTHER ERRORS-THE COMPILING KERNEL STAGE TAKES TO LONG, RAM USAGE EXCEEDS 15GB)

(HOPE YOUR USING WINDOWS VISTA AND ABOVE)

0 Likes
developer
Adept II

Re: What's wrong with this file?

Thanks for the detailed steps. I will first confirm the repro and then will forward the issue to the correct people. Thanks!

underhood
Journeyman III

Re: What's wrong with this file?

Hi,

I want to confirm issues with OpenCL on Ubuntu x64 with HD7950 Tahiti card.

My specs:

FX-8350 CPU

Sapphire HD7950 OC boost

32GB RAM

Ubuntu 12.10 Linux 64bit

Latest SVN version of blender

Compilation of kernel takes also looong time and memory here. Additional issue is startup time of the finished OpenCL kernel and its memory usage (my memory usage jumps to 30GB of RAM before start of render) until it actually starts doing something. Then rendering is fast enough but together with loading/startup time it takes longer than CPU render.

Very simple scene takes 1 minute to render on CPU and 4 minutes on GPU !!!!

When you read some blogs and forums about issue of Blender + OpenCL conclusion of Blender development team is OpenCL is unusable for out purposes. This way AMD is loosing considerable number of customers to NVidia. Blender is very popular SW used also in professional 3D production and all of those guys buy NVidia cards to get GPU acceleration.

I do not know if kernel is poorly written or it is problem of OpenCL compiler or AMD driver, but "official" statement from Blender devs is AMD compiler doesn't work for bigger kernels + some other minor reasons. Very disappointing for all of us AMD guys out there.

If you need some help from me (additional tests or more detailed report) I am willing to invest some time to make this work. Just don't have experience with OpenCL.

0 Likes
underhood
Journeyman III

Re: What's wrong with this file?

Hi,

I forgot to mention that if you use latest version of blender you have to manually enable OpenCL support. It was disabled by default by Blender devs after they decided OpenCL is too problematic (and putting further development on hold until better SW is provided)

Official statement about OpenCL from Blender devs (stating problems they encountered during attempt to make it work):

http://wiki.blender.org/index.php/Dev:2.6/Source/Render/Cycles/OpenCL

On that page you can also read how to enable testing opencl support in latest release:

"The environment variable CYCLES_OPENCL_TEST can be defined to show it, which can be useful for developers that want to test it."

After that use steps in picture from Nazim Mer.

0 Likes
himanshu_gautam
Grandmaster

Re: What's wrong with this file?

We are looking into this issue. After repro, we will forward to the right team.

Thanks for your patience. We can get this working together.

0 Likes
npm1
Adept II

Re: What's wrong with this file?

In that version of blender, go to the bar at the top and click window from the drop down list select terminal, in the terminal u'll see the errors that may come up whilst compiling blender cycles' kernel

0 Likes