cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

galmok
Journeyman III

Vista64: Clock stays at 400MHz (5870)

In my desktop (with and without Aero), my GPU clock stays at 400MHz in idle and with OpenCL programs running.

How do I make the GPU run full speed with OpenCL programs?

0 Likes
6 Replies
galmok
Journeyman III

Sorry, AMD GPU Clock Tool told me UVD Status was BUSY and therefore the GPU clock is locked at 400MHz (no higher, no lower, regardless of what). In my hunt for the culprit (closing suspected programs), it seemed that Firefox was keeping UVD busy somehow (probably some video stream in one of my 100 tabs).

At any rate, I'd REALLY like the option of disabling UVD completely because I suspect I would be better of without it. With it off, I can view video and play 3D games at full speed at the same time. But is there a way to disable or remove UVD support from the drivers?

0 Likes

Most likely not. However UVD should be pretty much seperate from the rest of the chip. Rather than disabling UVD this issue with the clocks should be solved. I think it's not impossible to have both at the same time.

0 Likes

Well, at the moment, UVD always takes priority over the GPU clock frequencies and that is why I want to disable UVD. Perhaps I can remove/disable some part of the driver so applications wont get hold of UVD features?

0 Likes

i think that when you disable HW acceleration in flash it stop using UVD.

0 Likes

I think GPU Developer Tools is a better match for this thread. You can get better assistance there.

0 Likes
MicahVillmow
Staff

galmok,
This should be fixed in the next SDK/Catalyst release for cards that support dynamic UVD frequency changes. However, only HD6XXX series of cards have the hardware to support the fixes at this time. There is no ETA on if this behavior will be changed for the HD5XXX series of cards because of hardware issues.
0 Likes