cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

nicowong
Journeyman III

using catalyst 12.4 or later version in XP with Open CL

I would like to know if there any way to use catalyst 12.4 or later version in XP with OpenCL driver? or If I can extract the OpenCL installer package for installation individually?

Thanks,

Nicholas

0 Likes
8 Replies
himanshu_gautam
Grandmaster

Re: using catalyst 12.4 or later version in XP with Open CL

I dont think Microsoft themselves support XP anymore. You should consider upgrading to Windows7 or 8.

0 Likes
Raistmer
Adept II

Re: using catalyst 12.4 or later version in XP with Open CL

M$ known to make not good decisions regarding its own users. I don't see why AMD should just blindly follow same practice.

XP was and is very stable and useful OS and dropping its hardware support is sad at least. Especially if one knows what a nightmare (Windows 😎 awaits in the front...

Regarding 12.4 + OpenCL - so far there were no success reports AFAIK. At SETI@home we have quite big community that uses ATi GPUs with OpenCL support and many will be just glad to stay with Windows XP and its ability to use GPU in service mode, that impossible in Vista+. So if you will succeed in your OpenCL over recent Cat under XP attempt please share how to do this, you will help many peoples.

realhet
Miniboss

Re: using catalyst 12.4 or later version in XP with Open CL

Do you say that there is no OCL runtime environment in http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_xp.aspx ?

This XP version is 50MB less than the win7 version. I think it only lacks the APP SDK. But it should have the latest OpenCL environment (and a broken CAL interface also). I personally like XP too, XP is better in realtime things (much lower latency DSound output for example).

0 Likes
Raistmer
Adept II

Re: using catalyst 12.4 or later version in XP with Open CL

"APP SDK" in Catalyst distribution is the AMD OpenCL runtime actually. Cause "true" APP SDK much larger.

And yes, OpenCL runtime missed AFAIK.

EDIT: to be more specific:

with driver only installation one will get only bin subdir under AMD APP.

With AMD APP SDK installation one will have bin + docs lib include tools subdirs.

So, with Catalyst driver installation one gets OpenCL runtime, with AMD APP SDK installation one gets OpenCL SDK.

0 Likes
himanshu_gautam
Grandmaster

Re: using catalyst 12.4 or later version in XP with Open CL

Realhet,

Thanks for bringing this to my attention. I do see XP listed in http://support.amd.com/us/gpudownload/Pages/index.aspx

However, when you select this, the description is like this:

Description:

 

Package contains the following graphics drivers and dependent/required software for the products specified in the current version's official release notes:

                        Display Driver ver. 9.00.100.2

                        Catalyst Control Center ver. 2012.1129.1015.18318

There is no mention about OpenCL.

However, if you select Windows 7, OpenCL is also listed apart from the above.

Windows7 Description:

Package contains the following graphics drivers and dependent/required software for the products specified in the current version's official release notes for the 32 bit version of Windows Vista,  Windows 7 and Windows 8:

                        Display Driver ver. 9.012

                        OpenCL(tm) Driver ver. 10.0.1084.4

                        Catalyst Control Center ver. 2012.1219.1520.27485

So, I just believe OpenCL on XP is not supported.

But, I can confirm from driver team on this.

Thanks,

0 Likes
Raistmer
Adept II

Re: using catalyst 12.4 or later version in XP with Open CL

The real question not to confirm this, it was confirmed by quite many users already. The question is how to circumvent this.

It's possible to install older OpenCL runtime on fresh Catalyst drivers. Currently we use this technique to circumvent broken OpenCL compiler in Catalyst 12.10-13.1. OpenCL cleanup and subsequent reinstall of OpenCL runtime from 12.8 is possible. But this proven to work on inherently supported OSes like Win7. I saw no reports if such technique will work on Windows XP with Catalyst that inherently doesn't support OpenCL at all.

0 Likes
himanshu_gautam
Grandmaster

Re: using catalyst 12.4 or later version in XP with Open CL

If it is not available from the installer - then it is not available.

Hacking around to get support is not something that I want to comment about.

OR

Are you guys trying to do something that I am mis-understanding as hacking(or unsupported area)

0 Likes
realhet
Miniboss

Re: using catalyst 12.4 or later version in XP with Open CL

Indeed You and Raistmer were right.

I wanted to see it with my eyes, I installed 13.1 on XP and it simply restarts the computer on kernel runs.

I've tested OpenCL, Amd_IL in OpenCL and Amd_IL in CAL too. Non of them work now, and produces the same 'syndrome' 😕

Now I'm reinstalling 11.12 -> that's a great driver for XP and for Ocl and even for Cal.

0 Likes