cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

bigfootnlc
Journeyman III

User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

Greetings:

I've been using OpenCL for running Boinc (think Seti-at-Home) on my PC for years.  I've got a Radeon HD5750 in a Windows XP system, the sole video card.

Recently, I was required to upgrade my driver to 13.1.  I used the Uninstall utility to remove all of the old ATI software and driver, then installed the 13.1.  Now, GPU-Z.0.6.7, the latest version last I checked, is indicating my system is incapable of using OpenCL, image attached.  Needless to say, Boinc also can't find a usable GPU.

I opened a support ticket with AMD because a previous ticket regarding this issue had informed me "The issues with Open CL not working with newer drivers is under investigation by the driver development team and should be resolved in a future release, but may take 2-3 months."  This was in June 2012.  The latest ticket informed me "This problem does not happen with older driver sets", but I had the same issue with 12.2, 12.3, and 12.4 (previous ticket).  They went on to suggest I post a question here.  So...

Can anyone provide instructions to make this work again?  Am I missing an additional piece of software?  Is AMD/ATI just not going to support a working OpenCL implementation (I would think not as there's a lot of activity in this developer forum)?

As an aside, maybe it's related, CCC will NOT run on this system either, no matter what version is installed.  AMD support has so far been unable to fix that either.

Thanks so much for all assistance!!!!!

Neil

0 Likes
1 Solution

Accepted Solutions
Claggy
Adept II

Re: User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

OpenCL support for Windows XP was deprecated from Cat 12.2, the last Cat you can use is Cat 12.1

Claggy

View solution in original post

0 Likes
4 Replies
Claggy
Adept II

Re: User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

OpenCL support for Windows XP was deprecated from Cat 12.2, the last Cat you can use is Cat 12.1

Claggy

0 Likes
bigfootnlc
Journeyman III

Re: User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

Claggy (I recognize the name!)

Where is this deprecation documented?  Or, how do you know this?

I've read through the release notes for both 12.1, 12.2, and 13.1, and it's not mentioned.  The OpenCL is listed on the download page as part of the 12.1 through 12.4 bundles for XP.  This is very interesting/irritating.

However, based upon your statement, I uninstalled the 13.1 and installed the 12.1.  Voila!  It now works again.

Thanks for your assistance!

Neil

0 Likes
Claggy
Adept II

Re: User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

I don't think there is an actual article, at least none that can find,

Downloads for the APP SDK for XP dried up after APP SDK 2.4 (i think it was that version),

If the APP SDK isn't being produced for XP, it'll be the same for the APP runtime,

more recently HD4*** GPUs (which had Beta support with earlier APP SDKs) are now not supported,

you can see that they aren't supported from their absence from the APP SDK 2.7 & 2.8 System Requirements pages:

http://amddevcentral.com/tools/hc/AMDAPPSDK/pages/DriverCompatibility.aspx

http://developer.amd.com/tools/heterogeneous-computing/amd-accelerated-parallel-processing-app-sdk/s...

There has already been a few threads here mentioning that OpenCL support was documented as being in Cat 12.2 and later for XP when in practice it wasn't there, the mention of OpenCL support on the download pages i thought had been removed.

Claggy

0 Likes
bigfootnlc
Journeyman III

Re: User needs help with OpenCL w/13.1 driver on Windows XP

Jump to solution

Well, that's good to know, but still disappointing.

I guess I'll be forced to stick with 12.1.  So far, can't stand Windows 7 (they re-arranged too much(all they did?)) and I want a computer, not an over-sized phone, so will be staying away from 8.  Maybe Microsoft will get it right next time, or maybe I'll finally be forced to go strictly Linux.

Thanks!!!

Neil

0 Likes