cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

david_aiken
Journeyman III

Ubuntu 9.10 64-bit CL_DEVICE_TYPE_CPU not found for Intel Core 2 Quad

Is it possible to use CL_DEVICE_TYPE_CPU on Ubuntu 9.10 64-bit with an Intel Core 2 Quad CPU? clCreateContextFromType() is returning CL_DEVICE_NOT_FOUND on this platform. It works fine on Windows Vista.

0 Likes
3 Replies
nou
Exemplar

Ubuntu 9.10 64-bit CL_DEVICE_TYPE_CPU not found for Intel Core 2 Quad

from your post in printf() topic i assume that you have instaled GeForce 275 with OpenCL enabled driver. so when you run opencl sample from ati stream sdk it use nvidia OpenCL library. so on linux you must export LD_LIBRARY_PATH to OpenCL library from stream sdk. you run

export LD_LIBRARY_PATH=/path/to/ati-stream-sdk/lib/x86_64

then it should load libOpenCL.so from ati sdk folder. you can confirm which lib is loaded with ldd command. "ldd name_of_executable" it print out every dynamic library whis is loaded at start.

0 Likes
omkaranathan
Journeyman III

Ubuntu 9.10 64-bit CL_DEVICE_TYPE_CPU not found for Intel Core 2 Quad

Your CPU should not be creating any problems.

Noticed in another thread that you are using an Nvidia GPU, have you installed the nvidia SDK anytime?

0 Likes
david_aiken
Journeyman III

Ubuntu 9.10 64-bit CL_DEVICE_TYPE_CPU not found for Intel Core 2 Quad

Yes.. that is the problem. NVidia is putting a libOpenCL.so into /usr/lib which is present in the default Ubuntu LD_LIBRARY_PATH. I added the ATI directory to the END of this variable in my .bashrc - hence the problem. Since i want to use both AMD and NVidia environments, I've setup separate scripts for NVidia and AMD to set the LD_LIBRARY_PATH and PATH, with the NVidia and ATI-specific directories prefixed to the existing settings. Thanks for your help!

0 Likes