Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Trying to run sample OpenCL program on a Linux machine with ATI Firestream 9250


I have built sample programs and try to run them on a Linux box with ATI Firestream 9250 card.

The fgrlx driver is installed on that machine.

The programs run, but they do not detect GPU.

Sample output:

~/ATI/ati-stream-sdk-v2.0-beta4-lnx64/samples/opencl/bin/x86_64$ (export LD_LIBRARY_PATH=../../../../lib/x86_64/:/opt/acml4.3.0-int64/gfortran64_int64/lib:/opt/acml4.3.0-int64/gfortran64_int64/lib:$LD_LIBRARY_PATH; ./BinarySearch)


Sorted Input

0 1 1 1 1 1 1 2 3 4 5 6 6 6 7 7 7 8 8 9 9 9 9 10 11 11 12 12 13 13 14 14 14 14 14 14 15 16 17 17 18 18 19 19 20 20 21 22 22 23 24 25 25 25 25 26 26 26 27 28 28 28 28 28 


For test only: Expires on Sun Feb 28 00:00:00 2010

No protocol specified

Unsupported GPU device; falling back to CPU ...

l = 10, u = 11, isfound = 1, fm = 5


How do I tell the program to use GPU?

Help would be greatly appreciated.



9 Replies

just for sure. did you install beta drivers from ati stream page?

Adept I

Originally posted by: Zeljko Hi,


The fgrlx driver is installed on that machine.


Is the driver the one which came with OpenCL SDK beta4 release? 

Did you uninstall the previous drivers before installing the new driver?

Could you run the CAL sample 'FindNumDevices'  and post the results?


Please make sure DISPLAY is set to :0 and not :0.0

> Is the driver the one which came with OpenCL SDK beta4 release? 


Micah, I have run the FindNumDevices, still does not find the card

~/ATI/ati-stream-sdk-v2.0-beta4-lnx64/samples/cal/bin/x86_64$ export DISPLAY=<ipaddress>:0


~/ATI/ati-stream-sdk-v2.0-beta4-lnx64/samples/cal/bin/x86_64$ (export LD_LIBRARY_PATH=../../../../lib/x86_64/:/opt/acml4.3.0-int64/gfortran64_int64/lib:/opt/acml4.3.0-int64/gfortran64_int64/lib:$LD_LIBRARY_PATH; ./FindNumDevices )

Supported CAL Runtime Version: 1.3.185

Found CAL Runtime Version: 1.4.467

Use -? for help

CAL initialized.

Finding out number of devices :- 

Device Count = 0

CAL shutdown successful.


Press enter to exit...


The driver is not installed properly. Could you remove the existing drivers, do a fresh installation(OpenCL drivers only), and run the CAL sample again and see?


Hello everyone!

I'm new here, but am helping Zeljko with this locally.  First -- a little about our setup. 

Zeljko and a few other people are working on this box remotely via SSH.  Will this cause any issues?  I believe they do forwarding of X sessions via ssh. 

Secondly:  Is there a quicker way to fix this box rather than reinstall it?  I can see the GUI come up fine on the console and Xorg is using the fglxr driver without issue.  This makes me think it is properly installed. 

Thank you for your assistance,



If you are working remotely through SSH, your security settings might be preventing the access of display driver by ATIStream applications. You can find a document on running ATIStream applications remotely at


Thanks for this guide.

I did implement this & reboot the box.

Upon reboot I had some errors upon start:

[  260.784602] FindNumDevices:4213 conflicting memory types c0000000-d0000000 uncached-minus<->write-combining
[  260.784607] reserve_memtype failed 0xc0000000-0xd0000000, track uncached-minus, req write-combining
[  260.784610] [fglrx:KCL_MEM_VM_MapRegion] *ERROR* remap_pfn_range failed
[  260.784706] __ratelimit: 36 callbacks suppressed
[  260.784710] FindNumDevices[4213]: segfault at 3e8 ip 00007f0e892c46ea sp 00007fffb582bff0 error 4 in[7f0e89104000+577000]

I then stopped GDM, reinstalled the driver, and restarted GDM and that seemed to at least work, however we have no /dev/dri so obviously adding permissions is not going to work.

Why might we not have dri?  After restarting gdm, the messages returned by `dmesg` looked signifcantly better:

[  925.089942] [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
[  925.090163] [fglrx]   vendor: 1002 device: 9452 count: 1
[  925.090635] [fglrx] ioport: bar 4, base 0xdc00, size: 0x100
[  925.090649] pci 0000:03:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
[  925.090655] pci 0000:03:00.0: setting latency timer to 64
[  925.090896] [fglrx] Kernel PAT support is enabled
[  925.090919] [fglrx] module loaded - fglrx 8.67.4 [Oct 26 2009] with 1 minors
[  925.378512] fglrx_pci 0000:03:00.0: irq 82 for MSI/MSI-X
[  925.379578] [fglrx] Firegl kernel thread PID: 12770
[  925.768033] [fglrx] Gart USWC size:1235 M.
[  925.768036] [fglrx] Gart cacheable size:490 M.
[  925.768041] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[  925.768042] [fglrx] Reserved FB block: Unshared offset:fc21000, size:3df000
[  925.768044] [fglrx] Reserved FB block: Unshared offset:3fffb000, size:5000




Originally posted by: Robstar

[fglrx] Kernel PAT support is enabled




FWIW, I just got the beta 4 stuff running on my HD4870x2 - trick was to add kernel command line boot option "nopat" and reboot so that instead of "Kernel PAT" in dmesg as above I get in dmesg:

[fglrx] Kernel supports PAT but it has been disabled
[fglrx] Using driver built-in PAT support instead
[fglrx] Driver built-in PAT support is enabled successfully

Picked up here: