cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

lind
Journeyman III

Shared Virtual Memory Can not be larger than about 30M

Jump to solution

I've got an A10-7850K and a gigabyte mb, after I installed the HSA beta driver, the samples were okay. However, if I allocate more than about 30Mb memory in my own program the system will crash. It is just a simple test of SVM features:

unsigned char* a = new unsigned char[size];

unsigned char* b = new unsigned char[size];

unsigned char* result = new unsigned char[size];

...

clSetKernelArgSVMPointer(kernel, 0, a);

clSetKernelArgSVMPointer(kernel, 1, b);

...

clSetKernelArgSVMPointer(kernel, 3, result);

__kernel void booleanAndHSA(global uchar* a, global uchar* b, int size, global uchar* result)

{

    unsigned int id = get_global_id(0);

  if(id>=size)

  return;

  result[id]=a[id]&&b[id];

}

When size is 10*1000*1000, or at most 15*1000*1000, the system will crash, sometimes show a blue screen, sometimes just go black.

I wonder whether it is a bug in the beta driver, or it is just because I have not get an A88X PRO proposed in the driver's readme file, or other problems .

Tags (3)
0 Likes
1 Solution

Accepted Solutions
tzachi_cohen
Staff
Staff

Re: Shared Virtual Memory Can not be larger than about 30M

Jump to solution

Hi Lind,

What I suspect is happening is that you encounter a TDR.

I would disable TDRs in the registry.

TDR Registry Keys (Windows Drivers)

Tzachi

View solution in original post

0 Likes
2 Replies
tzachi_cohen
Staff
Staff

Re: Shared Virtual Memory Can not be larger than about 30M

Jump to solution

Hi Lind,

What I suspect is happening is that you encounter a TDR.

I would disable TDRs in the registry.

TDR Registry Keys (Windows Drivers)

Tzachi

View solution in original post

0 Likes
lind
Journeyman III

Re: Shared Virtual Memory Can not be larger than about 30M

Jump to solution

Thank you, it is the right answer.

I checked  TdrLevel added a few days ago, it is in GraphicsDrivers\UseNewKey, not in GraphicsDrivers. Directly create it in the left side of regedit window is the right way but I added in the right side last time. Now things are okay after a reboot.

0 Likes