cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

bpurnomo
Staff
Staff

Rendermonkey + OpenglES 2.0 = GL_FALSE

Do you not see ES2_Debug.txt file in the output directory that you set in the ES control panel if you set the Debugging Output to Text file?  C:\ is the default location.

 

0 Likes
tersyon
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

No, ES2_Debug.txt is not created in the output directory. I opened many OpenGL ES projects, but even the Fur sample (which can render a sphere-like object) does not create that file. Additionally, the output console in RenderMonkey does not show any warning or errors (all lines end with Done or Success).

 

I also looked into Errors.xt file in RenderMonkey directory. Once an ES project is opened up, the following lines are appended to Errors.txt file:

[RmPreviewGLWindow.cpp] (line  430): Successfully created GLSL-compliant preview window
[RmPreviewGLManager.cpp] (line 8660): C l e a n i n g   a l l   rendering manager resources...

When other projects are opened after the first one, the "cleaning all rendering manager resources" message is displayed 3 times before the "Suc. created preview wind." message. This is also the same in DirectX or OpenGL projects, so the problem is not there I suppose.

0 Likes
tanja1
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

Try to use another programm this one is very hard in use

0 Likes
tersyon
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

Does another similar program exist for opengl es?

0 Likes
ndhb
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

I have exactly the same problem. Rendermonkey 1.82 produces black preview for all ES samples (except the fur-example that renders a working preview).

ES Emulator is installed and works correctly. No debug output is generated (ES2_Debug.txt). No warnings or errors that indicate a failure.

Windows XP SP3. GF8800GTS (driver version 182.06).

0 Likes
Shamamane
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

Hi all,

I have the same problem here, using XP SP3 and GF8800GT with latest drivers.

That's really annoying... Anyone found out what's happening or even better, a solution ?

0 Likes
TillRathmann
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

I had the same problem with a GeForce 8800GTX but I just found a workaround:

Use NVemulate (http://developer.nvidia.com/object/nvemulate.html). set "GLSL Compiler Device Support" to "NV40 (GeForce 6000 Series, Quadro FX 4000" and click Apply. Then start RenderMonkey. OpenGL ES effects should work now! When you're done, set the option in NVemulate back to "Driver Default" and hit Apply to reactivate the full feature set of the GPU.

The bug seems to occur only on GeForce 8 series and upwards. Without using NVemulate, the NVIDIA GLSL compiler generates (for the vertex shaders) code for the new gp4vp profile (see http://www.nvidia.de/object/cg_2_0_may08.html). When compiling a vertex shader of the OpenGL ES samples of RenderMonkey, the compiler outputs: "warning: no vertex attribute is explicitly assigned to vertex attribute zero". When using NVemulate as described above the compiler generates vp40 code and no warning is thrown.

 

Note: I tested with a rather old ForceWare driver (158.27). A recent one (tested 190.38) did work too (using NVemulate), but many of the OpenGL ES samples in RenderMonkey did not compile (well, they compiled, but could not be linked). So if you encounter the same problems, try an older driver version.



0 Likes
bpurnomo
Staff
Staff

Rendermonkey + OpenglES 2.0 = GL_FALSE

Excellent job in finding the workaround.  Can anyone else confirm that this workaround work for them?

 

0 Likes
Shamamane
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

Originally posted by: bpurnomo Can anyone else confirm that this workaround work for them

It works on my machine, and I'm really happy about this ! Many thanks !

 

0 Likes
aik6980
Journeyman III

Rendermonkey + OpenglES 2.0 = GL_FALSE

working on my 8800GT, VistaX64 too!

10/10 for this work around!

0 Likes