cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

derethor
Journeyman III

Radeon HD 5450 support?

I installed a new ati hd 5450 on debian amd64, and the new sdk 2.01

all the opencl samples are working with --device cpu, but with gpu :

Error: clCreateContextFromType failed. Error code : CL_DEVICE_NOT_FOUND

what can i do to fix this?

 

0 Likes
5 Replies
omkaranathan
Journeyman III

derethor,

Which version of debian are you using? Did you install the drivers ? Could you run the CAL sample 'FindNumDevices' to see if the driver is installed properly and devices are being detected.?

0 Likes

i am using debian lenny x64 with kernel 2.6.33-2-amd64

i downloaded the drivers this friday :

(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 7.1.0, module version = 8.70.3
        Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        compiled for 7.1.0, module version = 8.70.3

CAL Finddevices says:

Supported CAL Runtime Version: 1.3.185
Found CAL Runtime Version: 1.4.553
Use -? for help
CAL initialized.
Finding out number of devices :-
Device Count = 0
CAL shutdown successful.

aticonfig finds:

* 0. 01:00.0 ATI Radeon HD 5400 Series

* - Default adapter

0 Likes

i guess, it can't compile the driver, because i dont have the linux-headers installed

but it should work, isn't? i mean, it is supported in linux?

0 Likes

derethor,

Catalyst driver supports Linux(OpenSUSE 11.0, Ubuntu 9.10 and RHEL 5.3 are the officially supported versions.)

 

0 Likes

ok, it worked without problems

you need to compile the module. The installer said nothing about that, but it complies the module. I suggest to report this in some way.

after that, i ran aticonfig, and the server was properly configured.

I run a linux box connected with ssh, with the xserver installed in a chroot jail (only the xserver). I is important for me to keep the install minimal, as i want to run apps that dont need x-window, while

so, execute xinit to start a dummy xserver, and then, you can connect with ssh, and run opencl commands. But it is important that:

export DISPLAY=":0"

 

0 Likes