Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Problems and how I solved them

Good day,

I just wanted to forward a summary of the conversation I had with AMD Global Customer Care on the off chance that the information ends up in the hands of the correct people.

Issue #1:

I cannot create an account on your community support forums. The "Confirm Address" button does nothing and I have not received an email in the past 30 minutes. As such, I cannot currently report my driver problem via the usual channels. Thought you'd like to know!


It seems my account was automatically created after I sent in this service request, but I had no associated password, so a quick password reset request solved that problem.

Issue #2:

The driver issue is that I was attempting to start developing with the Vulkan API and I would get an exception immediately. Looking into the problem, I followed some instructions on the LunarG website. I ran VIA and VulkanInfo which both mention the following problem:

WARNING: [loader] Code 0 : loader_icd_scan: ICD JSON C:\WINDOWS\System32\amd-vulkan64.json does not have an 'api_version' field.

Their website indicated that this is likely a driver installation problem, so I installed the latest version 17.2.1, to no avail. I reinstalled version 16.11.5, no dice. Then I ran Guru3d's Display Driver Uninstaller in safe mode as recommended and freshly installed version 17.2.1. This did not fix the problem, so I opened this ticket.


Okay, so upon closer inspection of amd-vulkan64.json, it seems that the 'api_version' field is just spelled wrong. I corrected it and the errors in VIA and VulkanInfo dissappeared, but my exception did not. I suspected that Vulkan is now operational, so to test that, I bought DOOM and successfully ran it using Vulkan. So now I know that the exception I'm getting is not related to my Vulkan installation.

I have attached the original file with the spelling error for reference. I do wonder why this error is in two different driver version which are a year apart. Then again, I also wonder why this file even exists, since it doesn't seem to contain any relevant data.

End of issues

Hope this helps someone,